summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-08-02 08:35:15 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-08-02 08:35:15 +0000
commit44f6d0a8cb6db67e2b4d41f622771802123ae9d7 (patch)
tree284687c4ca44db14e6d98ef895be80df60015f18
parentMerge updates from master (diff)
parentprofiles: Unmask >=x11-themes/adwaita-icon-theme-3.36 (diff)
downloadgentoo-44f6d0a8cb6db67e2b4d41f622771802123ae9d7.tar.gz
gentoo-44f6d0a8cb6db67e2b4d41f622771802123ae9d7.tar.bz2
gentoo-44f6d0a8cb6db67e2b4d41f622771802123ae9d7.zip
Merge updates from master
-rw-r--r--dev-lang/ghc/metadata.xml4
-rw-r--r--dev-python/funcy/funcy-1.10.1.ebuild2
-rw-r--r--dev-python/funcy/funcy-1.14.ebuild2
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild2
-rw-r--r--dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild2
-rw-r--r--dev-python/hgdistver/hgdistver-0.25.ebuild2
-rw-r--r--dev-python/imagesize/imagesize-1.1.0.ebuild2
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.14.1.ebuild61
-rw-r--r--dev-python/josepy/josepy-1.3.0.ebuild2
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild2
-rw-r--r--dev-python/lit/lit-10.0.0.ebuild2
-rw-r--r--dev-python/lit/lit-10.0.1.ebuild2
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild2
-rw-r--r--dev-python/lit/lit-11.0.0_rc1.ebuild2
-rw-r--r--dev-python/lit/lit-12.0.0.9999.ebuild2
-rw-r--r--dev-python/lit/lit-9.0.1.ebuild2
-rw-r--r--dev-python/lockfile/lockfile-0.12.2-r2.ebuild2
-rw-r--r--dev-python/monotonic/monotonic-1.5-r1.ebuild2
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-1.18.1.ebuild2
-rw-r--r--dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.5.ebuild2
-rw-r--r--dev-python/reno/reno-2.11.3.ebuild2
-rw-r--r--dev-python/reno/reno-2.7.0.ebuild2
-rw-r--r--profiles/package.mask25
-rw-r--r--profiles/prefix/package.mask4
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild8
26 files changed, 54 insertions, 89 deletions
diff --git a/dev-lang/ghc/metadata.xml b/dev-lang/ghc/metadata.xml
index 5169f69026cc..eef249cad285 100644
--- a/dev-lang/ghc/metadata.xml
+++ b/dev-lang/ghc/metadata.xml
@@ -7,10 +7,10 @@
</maintainer>
<use>
<flag name="binary">Install the binary version directly, rather than using it to build the source version.</flag>
- <flag name="elfutils">Enable DWARF-based baclktraces using <pkg>dev-libs/elfutils</pkg>.</flag>
+ <flag name="elfutils">Enable DWARF-based backtraces using <pkg>dev-libs/elfutils</pkg>.</flag>
<flag name="ghcbootstrap">Internal: Bootstrap GHC from an existing GHC installation.</flag>
<flag name="ghcmakebinary">Internal: Build binary friendly for redistribution.</flag>
- <flag name="gmp">use <pkg>dev-libs/gmp</pkg> for integer operations (works faster, but an external depend).</flag>
+ <flag name="gmp">Use <pkg>dev-libs/gmp</pkg> for integer operations (works faster, but an external depend).</flag>
<flag name="numa">Enable NUMA thread balancing policy using <pkg>sys-process/numactl</pkg>.</flag>
</use>
</pkgmetadata>
diff --git a/dev-python/funcy/funcy-1.10.1.ebuild b/dev-python/funcy/funcy-1.10.1.ebuild
index 1223e2f48a5c..10053c851502 100644
--- a/dev-python/funcy/funcy-1.10.1.ebuild
+++ b/dev-python/funcy/funcy-1.10.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1
DESCRIPTION="A collection of fancy functional tools focused on practicality"
diff --git a/dev-python/funcy/funcy-1.14.ebuild b/dev-python/funcy/funcy-1.14.ebuild
index 9e8501191d4c..dbae274d8803 100644
--- a/dev-python/funcy/funcy-1.14.ebuild
+++ b/dev-python/funcy/funcy-1.14.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
DESCRIPTION="A collection of fancy functional tools focused on practicality"
diff --git a/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
index f89ae7f8f23e..2f9e9c7cfd98 100644
--- a/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
+++ b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
diff --git a/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild b/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
index 8723a4a8b4b7..70fe16344d32 100644
--- a/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
+++ b/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
diff --git a/dev-python/hgdistver/hgdistver-0.25.ebuild b/dev-python/hgdistver/hgdistver-0.25.ebuild
index eebff5382012..0d7d367e807f 100644
--- a/dev-python/hgdistver/hgdistver-0.25.ebuild
+++ b/dev-python/hgdistver/hgdistver-0.25.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
inherit distutils-r1
diff --git a/dev-python/imagesize/imagesize-1.1.0.ebuild b/dev-python/imagesize/imagesize-1.1.0.ebuild
index 949c9fdc6f5e..74dfd6ea9b98 100644
--- a/dev-python/imagesize/imagesize-1.1.0.ebuild
+++ b/dev-python/imagesize/imagesize-1.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6..9}} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit distutils-r1
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index ec1c551a5de7..e686eef9d2de 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,5 +1,4 @@
DIST django-stubs-1.5.0.tar.gz 180400 BLAKE2B 0619a76f89fe4fad456a82e3048009f25fdfd8b8e3071fd5a0cc0eebd62b3e9e8b77d29c5e4e8d1e0297fc466cc7e0c49771750b609fff49516e2aa1499c198b SHA512 c3e89f02a22561b5446e1cc0f01be791767984b5791fe5bd362ec6128e2ba7b32e921f9ee719a80ace05f7f0c84a912731700b457761f64617c1415cd232c7da
-DIST jedi-0.14.1.tar.gz 860206 BLAKE2B d1234ceb417f531c5a29908843a47bec5b198abbc848248517f2796d95319e2d930f7c01af9759cb9a3d44a28fb73c4080802642aea1be32f16689e76c1a49ce SHA512 d68c350259921792788917440c9dd6eb923c90eb1b8d0e078a6d428fad852c4d6bbdc74d8caa88ba5a87db344e4b372dc9cfc959d7bab922888d70402fcf4776
DIST jedi-0.15.2.tar.gz 422520 BLAKE2B f382e4026e1d0388c03b5116ea49fe4abf117c1555ccf0159541557e8d0d344774e15b983fbc66f996f60ae38552bb3b89f3f9cc809ab57f511a01664612f08f SHA512 079d9fc104125d188c72cfc0bd0ccd4de88eb5e7cdfba86e44f840e2427d0ab114bb812dad8e814e502e773d3a59f166547f5f6f287a5eedae64af99e8b5616e
DIST jedi-0.17.0.tar.gz 462810 BLAKE2B 71eeb3e3fa23786c577fbcb3727a49111d6188c2a5d9e13538123c7c6817b67d457f3bb88423dc9dac6ee09dec89d7281c86166bc771fa0215cd327a4432ebd7 SHA512 562ae25f0c4709cfe36fe4e737d383190d8ad435b3ff580b9fbe966544c8d035cfa29815459ceecfafd704547560a8dc397f841989043e6e18c8f9d639f75399
DIST jedi-0.17.1.tar.gz 472489 BLAKE2B 7486925cb307f6a25538c2f5d52763802222561cfc4beca1637e433f4450b06ef328204e75779b6b2ac4ca2cfcf5ab647daecd329941ca6fb0ae2a5dd2bd8b5f SHA512 0a9d552d2b4c45730c9cccf06ebb434b159b755acea0dbaddf5f628dccf8e9c752e03d151258e377b817f1a25fb9ca8e0289dbd2da290f55dc719883413b65cf
diff --git a/dev-python/jedi/jedi-0.14.1.ebuild b/dev-python/jedi/jedi-0.14.1.ebuild
deleted file mode 100644
index 6f023f45fc8a..000000000000
--- a/dev-python/jedi/jedi-0.14.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
-
-RDEPEND="dev-python/parso[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- # speed tests are fragile
- rm test/test_speed.py || die
-
- # 'path' completion test does not account for 'path' being a valid
- # package (i.e. dev-python/path-py)
- # https://github.com/davidhalter/jedi/issues/1210
- sed -i -e 's:test_get_modules_containing_name:_&:' \
- test/test_evaluate/test_imports.py || die
- sed -i -e 's:test_os_issues:_&:' \
- test/test_evaluate/test_imports.py || die
- sed -i -e 's:test_os_issues:_&:' \
- test/test_api/test_full_name.py || die
- sed -i -e 's:test_os_nowait:_&:' \
- test/test_api/test_full_name.py || die
- sed -i -e 's:test_os_nowait:_&:' \
- test/test_api/test_completion.py || die
- sed -i -e 's:test_import:_&:' \
- test/test_utils.py || die
-
- # don't run doctests, don't depend on colorama
- sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
- sed -i "s: --doctest-modules::" pytest.ini || die
-
- # no clue why it fails but we don't really care about .pyc files
- # without sources anyway
- rm test/test_evaluate/test_pyc.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if [[ ${EPYTHON} = python3.6 ]]; then
- # our very useful patching changes libdir for no good reason
- sed -i -e 's:test_venv_and_pths:_&:' \
- test/test_evaluate/test_sys_path.py || die
- fi
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/josepy/josepy-1.3.0.ebuild b/dev-python/josepy/josepy-1.3.0.ebuild
index 34d9145537eb..8f7ce5c780ae 100644
--- a/dev-python/josepy/josepy-1.3.0.ebuild
+++ b/dev-python/josepy/josepy-1.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
DESCRIPTION="JOSE protocol implementation in Python"
diff --git a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
index 5250c3905761..30330a213fc8 100644
--- a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
+++ b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
diff --git a/dev-python/lit/lit-10.0.0.ebuild b/dev-python/lit/lit-10.0.0.ebuild
index 3c71af53ec11..a61d6f3ca2be 100644
--- a/dev-python/lit/lit-10.0.0.ebuild
+++ b/dev-python/lit/lit-10.0.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1 llvm.org multiprocessing
diff --git a/dev-python/lit/lit-10.0.1.ebuild b/dev-python/lit/lit-10.0.1.ebuild
index 4afc13780a0b..b49965fce7d7 100644
--- a/dev-python/lit/lit-10.0.1.ebuild
+++ b/dev-python/lit/lit-10.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 llvm.org
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index b9123ef7bf14..eafbdc683987 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 llvm.org
diff --git a/dev-python/lit/lit-11.0.0_rc1.ebuild b/dev-python/lit/lit-11.0.0_rc1.ebuild
index b9123ef7bf14..eafbdc683987 100644
--- a/dev-python/lit/lit-11.0.0_rc1.ebuild
+++ b/dev-python/lit/lit-11.0.0_rc1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 llvm.org
diff --git a/dev-python/lit/lit-12.0.0.9999.ebuild b/dev-python/lit/lit-12.0.0.9999.ebuild
index b9123ef7bf14..eafbdc683987 100644
--- a/dev-python/lit/lit-12.0.0.9999.ebuild
+++ b/dev-python/lit/lit-12.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 llvm.org
diff --git a/dev-python/lit/lit-9.0.1.ebuild b/dev-python/lit/lit-9.0.1.ebuild
index 65669485c0bc..4ae5cb41cdee 100644
--- a/dev-python/lit/lit-9.0.1.ebuild
+++ b/dev-python/lit/lit-9.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1 llvm.org multiprocessing
diff --git a/dev-python/lockfile/lockfile-0.12.2-r2.ebuild b/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
index 61c5589f1a8e..715cb4795405 100644
--- a/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
+++ b/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
diff --git a/dev-python/monotonic/monotonic-1.5-r1.ebuild b/dev-python/monotonic/monotonic-1.5-r1.ebuild
index f0fb2bda547e..e85560961fcc 100644
--- a/dev-python/monotonic/monotonic-1.5-r1.ebuild
+++ b/dev-python/monotonic/monotonic-1.5-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-1.18.1.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-1.18.1.ebuild
index 0bf8cdbfde36..d0995244de72 100644
--- a/dev-python/openstackdocstheme/openstackdocstheme-1.18.1.ebuild
+++ b/dev-python/openstackdocstheme/openstackdocstheme-1.18.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
diff --git a/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.5.ebuild b/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.5.ebuild
index 2f5bcacd5318..fc62ee831c9f 100644
--- a/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.5.ebuild
+++ b/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
diff --git a/dev-python/reno/reno-2.11.3.ebuild b/dev-python/reno/reno-2.11.3.ebuild
index 67a2d6e5d14c..0ec706bfa07e 100644
--- a/dev-python/reno/reno-2.11.3.ebuild
+++ b/dev-python/reno/reno-2.11.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
diff --git a/dev-python/reno/reno-2.7.0.ebuild b/dev-python/reno/reno-2.7.0.ebuild
index a23ec8d58ca8..44eff81e2fd0 100644
--- a/dev-python/reno/reno-2.7.0.ebuild
+++ b/dev-python/reno/reno-2.7.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
diff --git a/profiles/package.mask b/profiles/package.mask
index dcaa1ecb1fa1..4b7e3ea20ca8 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,6 +32,26 @@
#--- END OF EXAMPLES ---
+# Michał Górny <mgorny@gentoo.org> (2020-08-02)
+# Discontinued upstream in favor of dev-python/mock. Py2 only.
+# The only revdep is last rited now.
+# Removal in 30 days. Bug #735158.
+dev-python/mox
+
+# Michał Górny <mgorny@gentoo.org> (2020-08-02)
+# Discontinued upstream in 2015. Python 2 only. No revdeps.
+# abseil-py (not package) is the suggested replacement.
+# Removal in 30 days. Bug #735156.
+dev-python/google-apputils
+
+# Mikle Kolyada <zlogene@gentoo.org> (2020-08-02)
+# consolekit is abandoned upstream.
+# People are encouraged to switch to any logind
+# implementation (systemd/elogind).
+# Removal in 60 days (bug #727730)
+sys-auth/consolekit
+sec-policy/selinux-consolekit
+
# Aaron Bauman <bman@gentoo.org> (2020-08-02)
# Py3.6 backport for dataclasses. No rdeps left.
# Removal in 30 days
@@ -372,11 +392,6 @@ dev-perl/Data-Diver
# Removal in 30 days.
app-admin/denyhosts
-# Matt Turner <mattst88@gentoo.org> (2019-09-01)
-# Icons look funny. E.g., the X (close) icon is wrong. I suspect files are
-# installed incorrectly
->=x11-themes/adwaita-icon-theme-3.36
-
# William Hubbs <williamh@gentoo.org> (2020-07-14)
# The kubernetes split packages are old versions with known security
# issues.
diff --git a/profiles/prefix/package.mask b/profiles/prefix/package.mask
index 0003ee995550..f47f8d80b660 100644
--- a/profiles/prefix/package.mask
+++ b/profiles/prefix/package.mask
@@ -9,6 +9,10 @@
#
# Fabian Groffen <grobian@gentoo.org> (2020-08-02)
+# Python 3.6 is soon going away and won't be updated for Prefix anymore.
+dev-lang/python:3.6
+
+# Fabian Groffen <grobian@gentoo.org> (2020-08-02)
# Python 2 is no longer supported
# Recent Portage releases no longer supports Python 2, and the version
# available in the Prefix tree has security issues. If you still need
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
index e203c8b52578..8628545b95aa 100644
--- a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
@@ -51,5 +51,13 @@ src_prepare() {
}
src_configure() {
+ # less than 2.45 being a problem is just a guess, but we didn't carry anything between 2.40 and 2.48 in main tree
+ if has_version '<gnome-base/librsvg-2.45:2'; then
+ ewarn "You are building ${CATEGORY}/${PN} against an older"
+ ewarn "gnome-base/librsvg, which will result in various broken symbolic icons until"
+ ewarn "rebuild with newer librsvg, and misrendering of scalable icons at runtime"
+ ewarn "until gnome-base/librsvg is upgraded!"
+ fi
+
gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
}