summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-08-18 20:14:13 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-08-18 20:14:13 +0000
commit37e96f915cd63849777b1235279f988f89f30892 (patch)
treeb65bee62bca07763840cb97fe61f8eddf14d9ba6
parent2016-08-18 19:48:51 UTC (diff)
parentdev-vcs/subversion: arm stable, bug #586046 (diff)
downloadgentoo-37e96f915cd63849777b1235279f988f89f30892.tar.gz
gentoo-37e96f915cd63849777b1235279f988f89f30892.tar.bz2
gentoo-37e96f915cd63849777b1235279f988f89f30892.zip
Merge updates from master
-rw-r--r--dev-games/tiled/Manifest1
-rw-r--r--dev-games/tiled/tiled-0.17.0.ebuild69
-rw-r--r--dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild2
-rw-r--r--dev-php/phpunit/phpunit-5.0.10.ebuild4
-rw-r--r--dev-ruby/listen/listen-3.1.5.ebuild2
-rw-r--r--dev-ruby/ruby_dep/ruby_dep-1.4.0.ebuild2
-rw-r--r--dev-vcs/subversion/subversion-1.9.4.ebuild2
-rw-r--r--media-libs/libmikmod/libmikmod-3.3.8.ebuild4
8 files changed, 78 insertions, 8 deletions
diff --git a/dev-games/tiled/Manifest b/dev-games/tiled/Manifest
index e619f8b88149..5c8c2cf85a07 100644
--- a/dev-games/tiled/Manifest
+++ b/dev-games/tiled/Manifest
@@ -1 +1,2 @@
DIST tiled-0.16.2.tar.gz 4503339 SHA256 801f607ae1eb306cbffd5d3e42ac1131dca0c0be9511118e126c8cc842474351 SHA512 a8cd9aee4111586de16935e00824b4adcea69a8e610578fa1f0cf417d2320f5e60aa97796221c9962bfbb7a0198bcfc79c47cde6f43531165d93ab6c0263060f WHIRLPOOL b1960db6c7d70ff8be7a4fa0e03df3bfe779eecbc25562e4e6d5c61c7a4963d01f42b6f716f70d23b2cd14bf16a1a5a9fee42c806f49a08cecaf88dec61eeb83
+DIST tiled-0.17.0.tar.gz 4852620 SHA256 f7fce2006a04c9e6e5d45a15fb31d342a4a66f7a01e1e6bc0753035cfbf42f31 SHA512 bf9b0cdd08c9091238a5e37f0670f2f3c389a46892c682a81f817e5daae0e6e3b13edf5d61a4105d9064e44585a4d6c7f7956b4c69b14488ee04af1834bf066c WHIRLPOOL 9e8b21098016cb20be66071e115f678bd10531a63b99c949e8a0e04ba6302834c414cc1ddf294f36b13bf1e43c22b9403a2aa13dc52ddbe84c24eb95d9b88ddb
diff --git a/dev-games/tiled/tiled-0.17.0.ebuild b/dev-games/tiled/tiled-0.17.0.ebuild
new file mode 100644
index 000000000000..7caaf4710ef5
--- /dev/null
+++ b/dev-games/tiled/tiled-0.17.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit fdo-mime gnome2-utils multilib python-single-r1 qmake-utils
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=dev-qt/qtopengl-5.6:5
+ >=dev-qt/qtwidgets-5.6:5
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+DOCS=( AUTHORS COPYING NEWS.md README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ eqmake5 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr" DISABLE_PYTHON_PLUGIN="$(usex !python)"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ einstalldocs
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
index ac08f357d602..30af621972d0 100644
--- a/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
+++ b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
@@ -5,7 +5,7 @@
EAPI=6
MY_PN="${PN/PEAR-/}"
-KEYWORDS="~amd64 ~hppa ~x86"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
DESCRIPTION="OO interface for searching and manipulating LDAP-entries"
HOMEPAGE="https://pear.php.net/package/${MY_PN}"
SRC_URI="http://download.pear.php.net/package/${MY_PN}-${PV}.tgz"
diff --git a/dev-php/phpunit/phpunit-5.0.10.ebuild b/dev-php/phpunit/phpunit-5.0.10.ebuild
index 4c2b768ecde9..51e9e64d1acd 100644
--- a/dev-php/phpunit/phpunit-5.0.10.ebuild
+++ b/dev-php/phpunit/phpunit-5.0.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,7 @@ SRC_URI="https://phar.phpunit.de/${PHPUNIT_PHAR}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
IUSE=""
DEPEND="
diff --git a/dev-ruby/listen/listen-3.1.5.ebuild b/dev-ruby/listen/listen-3.1.5.ebuild
index 0e2a7c90e242..7fec1575f86c 100644
--- a/dev-ruby/listen/listen-3.1.5.ebuild
+++ b/dev-ruby/listen/listen-3.1.5.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://github.com/guard/listen"
LICENSE="MIT"
SLOT="3"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm"
IUSE="test"
# Block on other packages trying to install a /usr/bin/listen
diff --git a/dev-ruby/ruby_dep/ruby_dep-1.4.0.ebuild b/dev-ruby/ruby_dep/ruby_dep-1.4.0.ebuild
index 61b116c38e5c..74338269ad5c 100644
--- a/dev-ruby/ruby_dep/ruby_dep-1.4.0.ebuild
+++ b/dev-ruby/ruby_dep/ruby_dep-1.4.0.ebuild
@@ -16,5 +16,5 @@ HOMEPAGE="https://github.com/e2/ruby_dep"
LICENSE="MIT"
SLOT="1"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm"
IUSE=""
diff --git a/dev-vcs/subversion/subversion-1.9.4.ebuild b/dev-vcs/subversion/subversion-1.9.4.ebuild
index 3ac7edd33403..105504137d89 100644
--- a/dev-vcs/subversion/subversion-1.9.4.ebuild
+++ b/dev-vcs/subversion/subversion-1.9.4.ebuild
@@ -19,7 +19,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="Subversion GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kde nls perl python ruby sasl test vim-syntax"
COMMON_DEPEND=">=dev-db/sqlite-3.7.12
diff --git a/media-libs/libmikmod/libmikmod-3.3.8.ebuild b/media-libs/libmikmod/libmikmod-3.3.8.ebuild
index 22193848d4de..19150b52c1d8 100644
--- a/media-libs/libmikmod/libmikmod-3.3.8.ebuild
+++ b/media-libs/libmikmod/libmikmod-3.3.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/mikmod/${P}.tar.gz"
LICENSE="LGPL-2+ LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="+alsa altivec coreaudio debug nas openal oss pulseaudio cpu_flags_x86_sse2 static-libs +threads"
REQUIRED_USE="|| ( alsa coreaudio nas openal oss pulseaudio )"