summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-23 22:16:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 23:04:53 +0100
commit33ae2d119eefa6f255e6adbf78f4d244efba1a90 (patch)
treeac38795ac43e06c9617f83ed6e1258a3e882c5f3
parentdev-python/iso8601: Bump to 1.0.2 (diff)
downloadgentoo-33ae2d119eefa6f255e6adbf78f4d244efba1a90.tar.gz
gentoo-33ae2d119eefa6f255e6adbf78f4d244efba1a90.tar.bz2
gentoo-33ae2d119eefa6f255e6adbf78f4d244efba1a90.zip
dev-python/python-socks: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 1d553bd20338..bd151d7bb157 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-1.2.4.gh.tar.gz 32192 BLAKE2B fa06f9158348292bef874c81623c11a54556db9c36cd7428d7a835428d152f3a4925d59e14d87518dfaae9e6937324e35db99bb5e1000f29fe9caf11fa2f8318 SHA512 6e70d8d98b2901e97250d30b350002944d979356bb6cd7dd4022af420e166076259a7b1aa4845d771243b18ab3f06ee955f07482c527835bb0135f0622d804be
+DIST python-socks-2.0.0.gh.tar.gz 38176 BLAKE2B 84711bd6747dd9ef8d7f47d90e7e1beeb99db7c51a370c01a272789e7d5356cdf3d0e3b1e822e1beb88a29ebbe23acac8f68206cf7a3f8b924f79d3783426f93 SHA512 088a606ca6e13de79cfa8b180d76e91cca129b3e1ffad2243e5924dc10530340924ea815eb9af0e53b5369daa9cf3e66b2f623da6913ed32916b91d24a47c1e4
diff --git a/dev-python/python-socks/python-socks-2.0.0.ebuild b/dev-python/python-socks/python-socks-2.0.0.ebuild
new file mode 100644
index 000000000000..77ea968045dc
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest