summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-15 21:58:41 +0300
committerMichał Górny <mgorny@gentoo.org>2023-08-15 21:15:28 +0200
commit3206dd9ba7ee70ff94334babc3bc33d055c634b9 (patch)
treecf80f7503983f795d6f5c53d80fea354e434a2fc
parentdev-python/argon2-cffi: Bump to 23.1.0 (diff)
downloadgentoo-3206dd9ba7ee70ff94334babc3bc33d055c634b9.tar.gz
gentoo-3206dd9ba7ee70ff94334babc3bc33d055c634b9.tar.bz2
gentoo-3206dd9ba7ee70ff94334babc3bc33d055c634b9.zip
dev-python/sqlglot: add 17.14.2
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32328 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.14.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index de59a6f57fef..46b2810454ea 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -3,3 +3,4 @@ DIST sqlglot-17.10.2.tar.gz 8399314 BLAKE2B c9695273925485f366f155f15a741074ed9b
DIST sqlglot-17.11.0.tar.gz 8399720 BLAKE2B 28a2da06afc70a510ad046d25432c2b145fc10374ecc41b78052e22ba771dc21d57503d5335839cf3c227fc53c12365f4cc2d6a4c9e1e1ccf02b71266e7e0cdb SHA512 026af3b24a2c62efee937238eaa69ebc47dd0ee8e2979cacd28a45c565dc36f3aa1e03f0fe46265a1f9c5e379eacc54f730c57b06bf80962ccb87d43893fc9e3
DIST sqlglot-17.12.0.tar.gz 8402758 BLAKE2B e563aecabdac819c55eabd678a12ee2a83f7a074eaa3d58d27503b04828233527c7320d237b699cc209f849d57d3b262a164f157fd4f24d1b125206994a45782 SHA512 d2e64e3692b93138f30904fab28490a3c9598e0201627112c29588c20889981354e2bf82ee844609d7633ea44aab9855159f294a6d711bb144ab922ed5ce1078
DIST sqlglot-17.14.0.tar.gz 8496712 BLAKE2B 5bdf3e3ffcb5da87f102cc706f52a1717abb571e30a5d780cfef7ec1f18ae987efda7728aef5ce7ba988a4340c1148a81d66048f2b6970a32404cc0970734b87 SHA512 c9058a91a3d0b763c64b5c1f2161d4bffde41ba113c76ccde5268f56b759bb63d83d92ad374a88e6e5cbddc5e46b885752f43db9c239182a7eb8e85d6401f4a8
+DIST sqlglot-17.14.2.tar.gz 8498185 BLAKE2B c556387a77aa2d5a52ce2f0ac630253ea68b9cd9426493e689e253b524643d25f1b7833e0a0970a52ac172eeced458de25584e55dc74d48e9398a02ab7f3dae1 SHA512 186011ccdbe3a3abff6dd94f31c6f2030a9a3c508569528e716fbfaffefccd9c31a508507caa8e2225582c95056e966466ba9aac95262d10152917c70003de7b
diff --git a/dev-python/sqlglot/sqlglot-17.14.2.ebuild b/dev-python/sqlglot/sqlglot-17.14.2.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.14.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}