summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-08-15 10:43:59 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-08-15 12:47:35 -0700
commit1d5683ef40db570b89f9384cd2467efab89bc1f5 (patch)
treee0494cf7d5069c575f89acd873a40ffdb6c8ecf8
parentdev-python/pytest-system-statistics: Revbump, add fix for loading with newer ... (diff)
downloadgentoo-1d5683ef40db570b89f9384cd2467efab89bc1f5.tar.gz
gentoo-1d5683ef40db570b89f9384cd2467efab89bc1f5.tar.bz2
gentoo-1d5683ef40db570b89f9384cd2467efab89bc1f5.zip
dev-python/pytest-salt-factories: add 1.0.0_rc25
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pytest-salt-factories/Manifest1
-rw-r--r--dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc25.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/pytest-salt-factories/Manifest b/dev-python/pytest-salt-factories/Manifest
index 11ba0bc07919..90adc5396b18 100644
--- a/dev-python/pytest-salt-factories/Manifest
+++ b/dev-python/pytest-salt-factories/Manifest
@@ -1,2 +1,3 @@
DIST pytest-salt-factories-1.0.0_rc20.gh.tar.gz 160140 BLAKE2B 7ecd9af695626c465e5776ed218bd92f30a556394cf4af0c2b6fb87c182f8aaf2d8f998358a7eef95fae53c85a6be2d4ed5a6ff191496fcac62a97e25cf19063 SHA512 5677c6638b5dc7f90c01f2c2204e1910c2bf6ea2c10b714173d3443d4c682b5f515ad7881e2ceee66f6eaf619e399d6fa10052604fdc9c5157c58348b63c8f2b
DIST pytest-salt-factories-1.0.0_rc23.gh.tar.gz 162711 BLAKE2B 28610679d7717d7a6f97a2f14a1ac838aec5101171ae65f2328d9b902d04b272c5e37f08d8ff3414af52ff7af954da24c083dfdc4afd1a9342b09cce0bf5aec3 SHA512 22d8f4a1c48a144437b9ff7d064760b59bb2a1003838e07f446a6150a77c162bffa7f21c570f796d8214d870d5b029e92abf7b0410ce19726085b607628364f0
+DIST pytest-salt-factories-1.0.0_rc25.gh.tar.gz 166148 BLAKE2B 11935c0164727968b9f2bd6f77498ea9ed4dbafd48bd6bb2730716fbcb1bb69b1ab09ef9ea2e2519368f4b6408bbb03f41fb0e52fc3cf75695f2b9c2b8d37294 SHA512 dd18688731b6bd2384abff9d739154b1ca7786bc3843d9fa8c293d1950925fff6c5820680a8095d4d5f3b75bcaeb07d8b3c7703ecab64a5f3a28bad11da18397
diff --git a/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc25.ebuild b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc25.ebuild
new file mode 100644
index 000000000000..137c3280230d
--- /dev/null
+++ b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc25.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_1{0..1} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="The new generation of the pytest-salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt-factories"
+SRC_URI="https://github.com/saltstack/${PN}/archive/${PV//_/}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${PV//_/}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/docker[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ >=dev-python/pytest-shell-utilities-1.4.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=app-admin/salt-3005.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e "s:use_scm_version=True:version='${PV}', name='${PN//-/.}':" -i setup.py || die
+ sed -r -e '/(setuptools|setup_requires)/ d' -i setup.cfg || die
+
+ sed -i 's:tool.setuptools_scm:tool.disabled:' pyproject.toml || die
+ printf '__version__ = "%s"\n' "${PV}" > src/saltfactories/version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -a EPYTEST_DESELECT=(
+ tests/functional/factories/cli/test_call.py::test_version_info
+ tests/functional/factories/cli/test_cloud.py::test_version_info
+ tests/functional/factories/cli/test_cp.py::test_version_info
+ tests/functional/factories/cli/test_key.py::test_version_info
+ tests/functional/factories/cli/test_run.py::test_version_info
+ tests/functional/factories/cli/test_salt.py::test_version_info
+ tests/functional/factories/cli/test_spm.py::test_version_info
+ tests/functional/factories/cli/test_ssh.py::test_version_info
+ tests/integration/factories/daemons/ssh/test_salt_ssh.py::test_salt_ssh
+ tests/integration/factories/daemons/sshd/test_sshd.py::test_connect
+ tests/scenarios/examples/test_echoext.py::test_echoext
+ tests/functional/factories/daemons/test_container_factory.py::test_skip_on_pull_failure
+ tests/functional/factories/daemons/test_container_factory.py::test_skip_if_docker_client_not_connectable
+ )
+
+ local tempdir
+ # ${T} is too long a path for the tests to work
+ tempdir="$(mktemp -du --tmpdir=/tmp salt-XXX)" || die
+ addwrite "${tempdir}"
+
+ (
+ cleanup() { rm -rf "${tempdir}" || die; }
+
+ trap cleanup EXIT
+ export SHELL="/bin/bash" TMPDIR="${tempdir}"
+ epytest --no-sys-stats
+ )
+}