summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:49:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:49:13 +0000
commit11c0fcf98274566c2431f26908f4b8b0df5fd6b9 (patch)
tree8ed1f12bd9421967a74a48560b8d0d9e10dce4e5
parent2024-07-15 08:19:31 UTC (diff)
parentdev-ruby/sshkit: avoid unneeded dependency on docker (diff)
downloadgentoo-11c0fcf98274566c2431f26908f4b8b0df5fd6b9.tar.gz
gentoo-11c0fcf98274566c2431f26908f4b8b0df5fd6b9.tar.bz2
gentoo-11c0fcf98274566c2431f26908f4b8b0df5fd6b9.zip
Merge updates from master
-rw-r--r--dev-ruby/nio4r/Manifest1
-rw-r--r--dev-ruby/nio4r/nio4r-2.7.3.ebuild38
-rw-r--r--dev-ruby/sshkit/sshkit-1.23.0.ebuild5
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-ruby/nio4r/Manifest b/dev-ruby/nio4r/Manifest
index 64efc36e79ed..ac3150d25064 100644
--- a/dev-ruby/nio4r/Manifest
+++ b/dev-ruby/nio4r/Manifest
@@ -2,3 +2,4 @@ DIST nio4r-2.5.9.gem 122368 BLAKE2B 4238e2963604539207e1adc7ee78430e4f501ea8b71d
DIST nio4r-2.6.1.gem 123904 BLAKE2B 5fbfe2a67fbd9fb6f49607358827391a56760c79435748f8fca0cbe6408f145cba224641b77afa8f6f49b1cd7e2fdd93e46e5aa3c75496f6539d66216ec3430b SHA512 bebf7f737f5e63107d77c4237a5750aa10f9bd1136deaa6bb1a8e5cab703d425a3a94a8f617df144e603f4f1f85ef62852740604a981e7dda41f0c43ae250406
DIST nio4r-2.7.0.gem 124416 BLAKE2B f02a16cf45dc2ea547dd8e036ddff5c37c24e9188db9ab4f817a55243f87f78264ed11bcd8d055e244c655aea08fa4922cd53dcae39e090031c87d0d78909c7b SHA512 aeb0bd3e727fa6999a314cd2b15a35035694f41294f7e9c406a72fd50a7a7a02311efec8c5795a116fd3793bf6b81e17d884e156b844722933e45d056f0cbeb9
DIST nio4r-2.7.1.gem 124416 BLAKE2B 4ae03731b0ae51bc51cfd12049e4d9beb9141feeb4196edafb26dd5ea4cc88e3cecaf0b121cd28c142cb509f991d22af5befe593443f7ecc420eb403fa83c0a1 SHA512 acade5696fe343b92f35f4bcfb7fbda48c8d9bbacff8e0571cffa193ade48d0c8f184db3480084bf3d796e5bd9176b285be4a52e4470c406bf867f538f1bfd4a
+DIST nio4r-2.7.3.tar.gz 123160 BLAKE2B 283e3f7ea278936a15efe8f8e7219ac3191b4be72f04ab63e64d6ca2125f6be7164353707a7418be31bcbed240317d51912e5c2a2dea0042b1ca2b3a39d56993 SHA512 185e0cbe146495d657e8954eef2208e61766c30f5cf132078ce9c00b5b6d678eafaa108102dc79bb8d42d90fd5809a606344d35b03bfc41d7a1f3f75a7c2820f
diff --git a/dev-ruby/nio4r/nio4r-2.7.3.ebuild b/dev-ruby/nio4r/nio4r-2.7.3.ebuild
new file mode 100644
index 000000000000..29610cf2f0db
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
+RUBY_FAKEGEM_GEMSPEC="nio4r.gemspec"
+
+inherit flag-o-matic ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+SRC_URI="https://github.com/socketry/nio4r/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+
+ sed -e 's:_relative ": "./:' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/sshkit/sshkit-1.23.0.ebuild b/dev-ruby/sshkit/sshkit-1.23.0.ebuild
index a15e9cb0cfc1..10267f61026b 100644
--- a/dev-ruby/sshkit/sshkit-1.23.0.ebuild
+++ b/dev-ruby/sshkit/sshkit-1.23.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
-# There are functional tests that require vagrant boxes to be set up.
+# There are functional tests that require docker containers to be set up.
RUBY_FAKEGEM_TASK_TEST="test:units"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
@@ -29,7 +29,8 @@ ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ sed -e '/\(unindent\|reporters\)/I s:^:#:' \
+ -e '/docker/I s:^:#:' \
-e '1irequire "pathname"' \
-i test/helper.rb || die