summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 17:05:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:25 +0100
commit0f8f411599918454d6a36e6b43245421d84d052c (patch)
tree0beb16bcb6915687650a136a36b99a6438d49ec5
parentdev-python/pywavelets: Bump to 1.3.0 (diff)
downloadgentoo-0f8f411599918454d6a36e6b43245421d84d052c.tar.gz
gentoo-0f8f411599918454d6a36e6b43245421d84d052c.tar.bz2
gentoo-0f8f411599918454d6a36e6b43245421d84d052c.zip
dev-python/mypy: Bump to 0.940
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.940.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 7dc76090bcc0..7fdec77494ad 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -2,3 +2,4 @@ DIST mypy-0.910.tar.gz 2551057 BLAKE2B a3c6939c8f0e2ea19a3a3f91031330df2fb25a93c
DIST mypy-0.921.tar.gz 2730985 BLAKE2B cfb7b54165b961758891fcf225f1a7d6bd9c6a7b14e6bb6d8adb990ed047bc4983b5e82de6709d3b8db85a3914e1bae2be4fd36e878d37db7387ebe6e81daac1 SHA512 f592d440b45a1bbcab973aeb717ffc805164168f1369793067a46bd2884fedcb9f981bfadd3447c6801120042553a7a7110d8cfc4e1649241d3b8685dffef653
DIST mypy-0.930.tar.gz 2777310 BLAKE2B 4681991993b04679d21c8f6bf8327a02eb628addc289ed22fbf06e4865ee9e60b90ab41a0d0b069d0a50924bf210816bdb87cff902d4424741f4e141f0957684 SHA512 f7f7ed762eb0f56b46a174c51c34423633d72b5046129617e456c41647705380b014c0c27bd0a104319e4872f2a7d7900a260bf6151d4419c95c93e4c01c6e9d
DIST mypy-0.931.tar.gz 2779826 BLAKE2B 11986102c6bc498a23bae52002e6ac515fa03724eed867b5356e3fb9aaa9a6eb7e699b612ab81b99dac215119402beecc702421fa82d655913976889dd4cb833 SHA512 8a336ae2f784c8ff912fc6b7dd53ed106cf14f435cee65604de74b8d4d7ab39ad65af0646060ef78e958d5a51a1de090fad628461412f2eef9593a8c032aa87a
+DIST mypy-0.940.tar.gz 2700469 BLAKE2B 4ac13002c3752566ade30a720c4de56d600552221c42f930af54a68573e6b5eb10de90ce66e2cd42f9eb419d5d09e354e4bf2d09cbcf0d6b841ab0e6710d7058 SHA512 5131ea3fe8d96f12442c68dddf04261582a063dcdd031804276263949af9f9af967be3dd775868d289709987773e1911f33e1f43951389f93cabf91c771e271f
diff --git a/dev-python/mypy/mypy-0.940.ebuild b/dev-python/mypy/mypy-0.940.ebuild
new file mode 100644
index 000000000000..aa40a8f0ad7f
--- /dev/null
+++ b/dev-python/mypy/mypy-0.940.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with pytest-xdist 2.3.0
+ # https://github.com/python/mypy/issues/11019
+ mypy/test/teststubtest.py
+ # fails due to setuptools deprecation warnings
+ mypyc/test/test_run.py::TestRun::run-imports.test::testImports
+ )
+
+ [[ "${EPYTHON}" == "python3.10" ]] && EPYTEST_DESELECT+=(
+ # https://github.com/python/mypy/issues/11018
+ mypyc/test/test_commandline.py::TestCommandLine::testErrorOutput
+ )
+
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}