aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/files/cryptography-43.0.0-rust-openssl-crash.patch')
-rw-r--r--dev-python/cryptography/files/cryptography-43.0.0-rust-openssl-crash.patch79
1 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/cryptography/files/cryptography-43.0.0-rust-openssl-crash.patch b/dev-python/cryptography/files/cryptography-43.0.0-rust-openssl-crash.patch
deleted file mode 100644
index 74d2e1c..0000000
--- a/dev-python/cryptography/files/cryptography-43.0.0-rust-openssl-crash.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From ef3578980ed117feb5e1b4c7a1f8c68efcdc066e Mon Sep 17 00:00:00 2001
-From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com>
-Date: Sun, 21 Jul 2024 16:36:43 +0000
-Subject: [PATCH] Bump openssl from 0.10.65 to 0.10.66 in /src/rust (#11320)
-
-Bumps [openssl](https://github.com/sfackler/rust-openssl) from 0.10.65 to 0.10.66.
-- [Release notes](https://github.com/sfackler/rust-openssl/releases)
-- [Commits](https://github.com/sfackler/rust-openssl/compare/openssl-v0.10.65...openssl-v0.10.66)
-
----
-updated-dependencies:
-- dependency-name: openssl
- dependency-type: direct:production
- update-type: version-update:semver-patch
-...
-
-Signed-off-by: dependabot[bot] <support@github.com>
-Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
----
- src/rust/Cargo.lock | 4 ++--
- src/rust/Cargo.toml | 2 +-
- src/rust/cryptography-key-parsing/Cargo.toml | 2 +-
- src/rust/cryptography-openssl/Cargo.toml | 2 +-
- 4 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/rust/Cargo.lock b/src/rust/Cargo.lock
-index fe3398f25393..c5a020fc8f10 100644
---- a/src/rust/Cargo.lock
-+++ b/src/rust/Cargo.lock
-@@ -179,9 +179,9 @@ checksum = "3fdb12b2476b595f9358c5161aa467c2438859caa136dec86c26fdd2efe17b92"
-
- [[package]]
- name = "openssl"
--version = "0.10.65"
-+version = "0.10.66"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "c2823eb4c6453ed64055057ea8bd416eda38c71018723869dd043a3b1186115e"
-+checksum = "9529f4786b70a3e8c61e11179af17ab6188ad8d0ded78c5529441ed39d4bd9c1"
- dependencies = [
- "bitflags",
- "cfg-if",
-diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
-index d58ee9e7ec28..4a91705de96c 100644
---- a/src/rust/Cargo.toml
-+++ b/src/rust/Cargo.toml
-@@ -26,7 +26,7 @@ cryptography-x509 = { path = "cryptography-x509" }
- cryptography-x509-verification = { path = "cryptography-x509-verification" }
- cryptography-openssl = { path = "cryptography-openssl" }
- pem = { version = "3", default-features = false }
--openssl = "0.10.65"
-+openssl = "0.10.66"
- openssl-sys = "0.9.103"
- foreign-types-shared = "0.1"
- self_cell = "1"
-diff --git a/src/rust/cryptography-key-parsing/Cargo.toml b/src/rust/cryptography-key-parsing/Cargo.toml
-index d1f945f961a0..e88e3bc9e691 100644
---- a/src/rust/cryptography-key-parsing/Cargo.toml
-+++ b/src/rust/cryptography-key-parsing/Cargo.toml
-@@ -9,6 +9,6 @@ rust-version.workspace = true
- [dependencies]
- asn1 = { version = "0.16.2", default-features = false }
- cfg-if = "1"
--openssl = "0.10.65"
-+openssl = "0.10.66"
- openssl-sys = "0.9.103"
- cryptography-x509 = { path = "../cryptography-x509" }
-diff --git a/src/rust/cryptography-openssl/Cargo.toml b/src/rust/cryptography-openssl/Cargo.toml
-index c0f3f5d72ce1..f340ed87cf53 100644
---- a/src/rust/cryptography-openssl/Cargo.toml
-+++ b/src/rust/cryptography-openssl/Cargo.toml
-@@ -8,7 +8,7 @@ rust-version.workspace = true
-
- [dependencies]
- cfg-if = "1"
--openssl = "0.10.65"
-+openssl = "0.10.66"
- ffi = { package = "openssl-sys", version = "0.9.101" }
- foreign-types = "0.3"
- foreign-types-shared = "0.1"