aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ugrd/ugrd-0.7.4.ebuild')
-rw-r--r--sys-kernel/ugrd/ugrd-0.7.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/ugrd-0.7.4.ebuild b/sys-kernel/ugrd/ugrd-0.7.4.ebuild
new file mode 100644
index 000000000..71ef70139
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-0.7.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} pypy3 )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-misc/pax-utils"
+
+src_install() {
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+ optfeature "ugrd.fs.zfs support" sys-fs/zfs
+}