aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ytarchive/ytarchive-0.5.0.ebuild')
-rw-r--r--media-video/ytarchive/ytarchive-0.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/ytarchive/ytarchive-0.5.0.ebuild b/media-video/ytarchive/ytarchive-0.5.0.ebuild
new file mode 100644
index 000000000..0d5e002e0
--- /dev/null
+++ b/media-video/ytarchive/ytarchive-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Youtube livestream downloader"
+HOMEPAGE="https://github.com/Kethsar/ytarchive"
+SRC_URI="
+ https://github.com/Kethsar/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://files.asokolov.org/gentoo/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-video/ffmpeg"
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin ytarchive
+ einstalldocs
+}