aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/atkinson-hyperlegible/Manifest1
-rw-r--r--media-fonts/atkinson-hyperlegible/atkinson-hyperlegible-20200514.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-fonts/atkinson-hyperlegible/Manifest b/media-fonts/atkinson-hyperlegible/Manifest
new file mode 100644
index 000000000..0e73089b3
--- /dev/null
+++ b/media-fonts/atkinson-hyperlegible/Manifest
@@ -0,0 +1 @@
+DIST atkinson-hyperlegible-20200514.zip 574460 BLAKE2B 06fdbe9337fd161be1fa0f5b906ecb89a0b01c0ace2fe2cede8a0db8b0b896d239f2b688f94f2c476f0769e41e4179fe5cb16d22da65a623440cb4563113b085 SHA512 869e4a477caac906731494daa6db216f621fd75231aeb94053a412ff1c3752726c873895a785b138d3a74dc721a06925b791ccf1a3cdaddd52edc99c4188a0bd
diff --git a/media-fonts/atkinson-hyperlegible/atkinson-hyperlegible-20200514.ebuild b/media-fonts/atkinson-hyperlegible/atkinson-hyperlegible-20200514.ebuild
new file mode 100644
index 000000000..54d4fa1e2
--- /dev/null
+++ b/media-fonts/atkinson-hyperlegible/atkinson-hyperlegible-20200514.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font
+
+DESCRIPTION="Braille Institute's Atkinson Hyperlegible font."
+HOMEPAGE="https://www.brailleinstitute.org/freefont/"
+
+MY_PV="2020-0514"
+SRC_URI="https://www.brailleinstitute.org/atkinson-hyperlegible-font/Atkinson-Hyperlegible-Font-Print-and-Web-${MY_PV}.zip -> ${P}.zip"
+S="${WORKDIR}/Atkinson-Hyperlegible-Font-Print-and-Web-${MY_PV}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+IUSE="otf +ttf"
+REQUIRED_USE="^^ ( otf ttf )"
+
+BDEPEND="app-arch/unzip"
+
+FONT_SUFFIX=""
+
+src_install() {
+ if use otf; then
+ FONT_SUFFIX+="otf"
+ FONT_S=( "Print Fonts/" )
+ fi
+ if use ttf; then
+ FONT_SUFFIX+="ttf"
+ FONT_S=( "Web Fonts/TTF" )
+ fi
+ font_src_install
+}