aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild9
-rw-r--r--dev-scheme/guile-colorized/guile-colorized-9999.ebuild9
-rw-r--r--dev-scheme/guile-gi/guile-gi-0.3.1.ebuild9
-rw-r--r--dev-scheme/guile-gi/guile-gi-9999.ebuild9
4 files changed, 36 insertions, 0 deletions
diff --git a/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild b/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
index a3759bbcb..52232af54 100644
--- a/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
+++ b/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
@@ -30,6 +30,15 @@ DOCS=( README.md )
src_prepare() {
default
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
diff --git a/dev-scheme/guile-colorized/guile-colorized-9999.ebuild b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
index a3759bbcb..52232af54 100644
--- a/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
+++ b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
@@ -30,6 +30,15 @@ DOCS=( README.md )
src_prepare() {
default
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
diff --git a/dev-scheme/guile-gi/guile-gi-0.3.1.ebuild b/dev-scheme/guile-gi/guile-gi-0.3.1.ebuild
index b3ddea965..0574aa727 100644
--- a/dev-scheme/guile-gi/guile-gi-0.3.1.ebuild
+++ b/dev-scheme/guile-gi/guile-gi-0.3.1.ebuild
@@ -34,6 +34,15 @@ QA_FLAGS_IGNORED=".*"
src_prepare() {
default
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
diff --git a/dev-scheme/guile-gi/guile-gi-9999.ebuild b/dev-scheme/guile-gi/guile-gi-9999.ebuild
index b3ddea965..0574aa727 100644
--- a/dev-scheme/guile-gi/guile-gi-9999.ebuild
+++ b/dev-scheme/guile-gi/guile-gi-9999.ebuild
@@ -34,6 +34,15 @@ QA_FLAGS_IGNORED=".*"
src_prepare() {
default
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}