aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-crystal/athena-spec/athena-spec-0.3.7.ebuild')
-rw-r--r--dev-crystal/athena-spec/athena-spec-0.3.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-crystal/athena-spec/athena-spec-0.3.7.ebuild b/dev-crystal/athena-spec/athena-spec-0.3.7.ebuild
new file mode 100644
index 000000000..d35fda19e
--- /dev/null
+++ b/dev-crystal/athena-spec/athena-spec-0.3.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit shards
+
+MY_PN="${PN#athena-}"
+DESCRIPTION="Common/helpful Spec compliant testing utilities"
+HOMEPAGE="
+ https://github.com/athena-framework/spec
+ https://athenaframework.org/Spec
+"
+SRC_URI="https://github.com/athena-framework/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ default
+
+ mkdir -p .github/workflows || die
+ touch .github/dependabot.yml || die
+}