aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/clevis/clevis-19-r2.ebuild')
-rw-r--r--app-crypt/clevis/clevis-19-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/clevis/clevis-19-r2.ebuild b/app-crypt/clevis/clevis-19-r2.ebuild
new file mode 100644
index 000000000..097d18b21
--- /dev/null
+++ b/app-crypt/clevis/clevis-19-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Automated Encryption Framework"
+HOMEPAGE="https://github.com/latchset/clevis"
+SRC_URI="https://github.com/latchset/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+luks +tpm"
+
+DEPEND="
+ dev-libs/jose
+ sys-fs/cryptsetup
+ luks? (
+ app-misc/jq
+ dev-libs/libpwquality
+ dev-libs/luksmeta
+ )
+ tpm? ( app-crypt/tpm2-tools )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/jansson
+ dev-libs/openssl:=
+"
+
+PATCHES=(
+ # From https://github.com/latchset/clevis/pull/347
+ # Allows using dracut without systemd
+ "${FILESDIR}/clevis-dracut.patch"
+ # Fix for systemd on Gentoo
+ "${FILESDIR}/clevis-meson.patch"
+)