aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
index d0072fe5d..499bbce0d 100644
--- a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
+++ b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
@@ -6,7 +6,7 @@ diff -urN a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-
# (this improves performance and avoids hard-to-debug behaviour);
MAKEFLAGS += -r
-override CFLAGS += -O2 -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
-+override CFLAGS += -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
++override CFLAGS += -Wall -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
override LDFLAGS += -lnl-genl-3 -lnl-3
ALL_TARGETS := intel-speed-select
@@ -25,12 +25,12 @@ diff -urN a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makef
diff -urN a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
--- a/tools/power/x86/x86_energy_perf_policy/Makefile 2022-12-11 17:15:18.000000000 -0500
+++ b/tools/power/x86/x86_energy_perf_policy/Makefile 2023-02-04 05:47:25.962523488 -0500
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,6 @@
endif
x86_energy_perf_policy : x86_energy_perf_policy.c
-override CFLAGS += -O2 -Wall -I../../../include
+override CFLAGS += -Wall -I../../../include
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
- override CFLAGS += -D_FORTIFY_SOURCE=2
+-override CFLAGS += -D_FORTIFY_SOURCE=2