aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/b2/Manifest1
-rw-r--r--app-backup/b2/b2-3.9.0.ebuild98
-rw-r--r--app-backup/b2/files/b2-2.5.0-nameclash.patch14
-rw-r--r--app-backup/b2/files/b2-3.9.0-disable-pip-requirement-installs.patch23
4 files changed, 0 insertions, 136 deletions
diff --git a/app-backup/b2/Manifest b/app-backup/b2/Manifest
index 604ce7bb8..8c82430e8 100644
--- a/app-backup/b2/Manifest
+++ b/app-backup/b2/Manifest
@@ -1,3 +1,2 @@
DIST b2-3.18.0.gh.tar.gz 189572 BLAKE2B 9516d98c7c493791f120c345480f16c8d615cbf425f692fa3fe6688c21ef7d26f14cdd7b44cfb22f2c13a5554166c046eb5fa1712a1e1994fa4e4181399eda84 SHA512 45c784e961b8b650d27e7fe642cacd194462b3c0864fdc1af52e41a70b435c36fbb803e80cfb2c88b8165ea95459a7e62b1995f26caf612110f8c77418cb6669
-DIST b2-3.9.0.tar.gz 131326 BLAKE2B c357831b7c0b4ae6abc4fafb6e09690f8ffe833d2c58c05610ffdbf94ba276f5fa143dd1528f7e7424b6fa96857c8328be993e6ffc60b61c44037bd9ef0b0e96 SHA512 db2fab07e973d6d39db3931dd7f645ee3c9737f4de0ab29327490607d52aad4df2e9049782ef347ee44f80b76dbe91f495ce273285001d49195abe91d5b2cb5d
DIST b2-4.0.1.gh.tar.gz 201737 BLAKE2B 74fb1dd52c8592816c2f2680469c2dd08910f8c25d4a923dd53258f63dd4c38ef77855e6845c41572b8fe52d33ee390a2fac6555016663c450feeb6ff89ed09e SHA512 02a14c2c78fecd1dda536539b5977d6ff45892db0355575209417d7f8471a45ace0d4766dd454c0ba0a65a1ae44e0c698cca38814b0bf36ca5e7a69efec9149a
diff --git a/app-backup/b2/b2-3.9.0.ebuild b/app-backup/b2/b2-3.9.0.ebuild
deleted file mode 100644
index 92990f461..000000000
--- a/app-backup/b2/b2-3.9.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Command-line tool for BackBlaze's B2 product"
-HOMEPAGE="https://github.com/Backblaze/B2_Command_Line_Tool"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.5.0-nameclash.patch"
- "${FILESDIR}/${PN}-3.9.0-disable-pip-requirement-installs.patch"
-)
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/argcomplete-2.1.2[${PYTHON_USEDEP}]
- >=dev-python/arrow-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/b2sdk-1.21.0[${PYTHON_USEDEP}]
- >=dev-python/docutils-0.19[${PYTHON_USEDEP}]
- >=dev-python/phx-class-registry-4.0.6[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/rst2ansi-0.1.5[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.65.0[${PYTHON_USEDEP}]
- ')
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-3.3.0[${PYTHON_USEDEP}]
- ' pypy3 python3_8)
-"
-
-DEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/backoff-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/pexpect-4.8.0[${PYTHON_USEDEP}]
- ')
- )
-"
-
-distutils_enable_tests pytest
-
-# - integration tests require an application key and id (which is reasonable)
-# - sync tests require network access
-python_test() {
- epytest \
- --deselect test/integration/test_autocomplete.py::test_autocomplete_b2_bucket_n_file_name \
- --deselect test/integration/test_autocomplete.py::test_autocomplete_b2_commands \
- --deselect test/integration/test_autocomplete.py::test_autocomplete_b2_only_matching_commands \
- --deselect test/integration/test_b2_command_line.py::test_integration \
- --deselect test/integration/test_b2_command_line.py::test_download \
- --deselect test/integration/test_b2_command_line.py::test_basic \
- --deselect test/integration/test_b2_command_line.py::test_bucket \
- --deselect test/integration/test_b2_command_line.py::test_key_restrictions \
- --deselect test/integration/test_b2_command_line.py::test_account \
- --deselect test/integration/test_b2_command_line.py::test_sync_up \
- --deselect test/integration/test_b2_command_line.py::test_sync_up_sse_b2 \
- --deselect test/integration/test_b2_command_line.py::test_sync_up_sse_c \
- --deselect test/integration/test_b2_command_line.py::test_sync_up_no_prefix \
- --deselect test/integration/test_b2_command_line.py::test_sync_down \
- --deselect test/integration/test_b2_command_line.py::test_sync_down_no_prefix \
- --deselect test/integration/test_b2_command_line.py::test_sync_down_sse_c_no_prefix \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy_no_prefix_default_encryption \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy_no_prefix_no_encryption \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy_no_prefix_sse_b2 \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy_no_prefix_sse_c \
- --deselect test/integration/test_b2_command_line.py::test_sync_copy_sse_c_single_bucket \
- --deselect test/integration/test_b2_command_line.py::test_sync_long_path \
- --deselect test/integration/test_b2_command_line.py::test_default_sse_b2 \
- --deselect test/integration/test_b2_command_line.py::test_sse_b2 \
- --deselect test/integration/test_b2_command_line.py::test_sse_c \
- --deselect test/integration/test_b2_command_line.py::test_license[True] \
- --deselect test/integration/test_b2_command_line.py::test_license[False] \
- --deselect test/integration/test_b2_command_line.py::test_file_lock \
- --deselect test/integration/test_b2_command_line.py::test_profile_switch \
- --deselect test/integration/test_b2_command_line.py::test_replication_basic \
- --deselect test/integration/test_b2_command_line.py::test_replication_setup \
- --deselect test/integration/test_b2_command_line.py::test_replication_monitoring \
- --deselect test/integration/test_b2_command_line.py::test_enable_file_lock_first_retention_second \
- --deselect test/integration/test_b2_command_line.py::test_enable_file_lock_and_set_retention_at_once \
- --deselect test/integration/test_b2_command_line.py::test_cut \
- --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_exact \
- --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_in_range
-}
-
-pkg_postinst() {
- elog "The b2 executable has been renamed to backblaze2 in order to"
- elog "avoid a name clash with b2 from boost-build"
-}
diff --git a/app-backup/b2/files/b2-2.5.0-nameclash.patch b/app-backup/b2/files/b2-2.5.0-nameclash.patch
deleted file mode 100644
index 507392ae1..000000000
--- a/app-backup/b2/files/b2-2.5.0-nameclash.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-# boost installs an executable named b2, which clashes with the default name for
-# this package. This package changes the executable name to avoid this clash.
-diff --git a/setup.py b/setup.py
-index f9c1bbe..76ca28f 100644
---- a/setup.py
-+++ b/setup.py
-@@ -135,6 +135,6 @@ setup(
- # "scripts" keyword. Entry points provide cross-platform support and allow
- # pip to create the appropriate form of executable for the target platform.
- entry_points={
-- 'console_scripts': ['b2=b2.console_tool:main'],
-+ 'console_scripts': ['backblaze2=b2.console_tool:main'],
- },
- )
diff --git a/app-backup/b2/files/b2-3.9.0-disable-pip-requirement-installs.patch b/app-backup/b2/files/b2-3.9.0-disable-pip-requirement-installs.patch
deleted file mode 100644
index e9ec96911..000000000
--- a/app-backup/b2/files/b2-3.9.0-disable-pip-requirement-installs.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-# These configurations attempt to install missing dependencies using pip, which
-# violates the network sandbox. Instead, we'll manage the dependencies in
-# portage.
---- a/setup.py
-+++ b/setup.py
-@@ -104,7 +104,7 @@
- # requirements files see:
- # https://packaging.python.org/en/latest/requirements.html
- dependency_links=[],
-- install_requires=read_requirements(),
-+ # install_requires=read_requirements(),
-
- # List additional groups of dependencies here (e.g. development
- # dependencies). You can install these using the following syntax,
-@@ -114,7 +114,7 @@
- 'doc': read_requirements('doc'),
- 'license': read_requirements('license'),
- },
-- setup_requires=['setuptools_scm<6.0'],
-+ # setup_requires=['setuptools_scm<6.0'],
- use_scm_version=True,
-
- # If there are data files included in your packages that need to be