aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/find-work/find-work-0.990.0.ebuild10
-rw-r--r--dev-util/find-work/find-work-9999.ebuild10
-rw-r--r--dev-util/glsl-language-server/Manifest1
-rw-r--r--dev-util/glsl-language-server/glsl-language-server-0.3.7.ebuild21
-rw-r--r--dev-util/glsl-language-server/metadata.xml8
-rw-r--r--net-misc/megasync/Manifest4
-rw-r--r--net-misc/megasync/megasync-5.6.1.0.ebuild (renamed from net-misc/megasync/megasync-5.5.0.0.ebuild)25
-rw-r--r--net-p2p/trezord-go/files/trezord-go-2.0.33_libusb.patch393
-rw-r--r--net-p2p/trezord-go/trezord-go-2.0.33.ebuild2
-rw-r--r--profiles/package.mask14
10 files changed, 435 insertions, 53 deletions
diff --git a/dev-util/find-work/find-work-0.990.0.ebuild b/dev-util/find-work/find-work-0.990.0.ebuild
index d487006d1..d39534f36 100644
--- a/dev-util/find-work/find-work-0.990.0.ebuild
+++ b/dev-util/find-work/find-work-0.990.0.ebuild
@@ -69,6 +69,16 @@ distutils_enable_sphinx docs \
dev-python/insipid-sphinx-theme \
dev-python/sphinx-prompt
+pkg_setup() {
+ DISTUTILS_ALL_SUBPHASE_IMPLS=()
+
+ # bug #944221
+ for impl in "${PYTHON_COMPAT[@]}"; do
+ use "python_targets_${impl}" && \
+ DISTUTILS_ALL_SUBPHASE_IMPLS+=( "${impl}" )
+ done
+}
+
python_compile_all() {
# copy-pasted from distutils_write_namespace
local path="${BUILD_DIR}/install$(python_get_sitedir)/find_work/__init__.py"
diff --git a/dev-util/find-work/find-work-9999.ebuild b/dev-util/find-work/find-work-9999.ebuild
index d487006d1..d39534f36 100644
--- a/dev-util/find-work/find-work-9999.ebuild
+++ b/dev-util/find-work/find-work-9999.ebuild
@@ -69,6 +69,16 @@ distutils_enable_sphinx docs \
dev-python/insipid-sphinx-theme \
dev-python/sphinx-prompt
+pkg_setup() {
+ DISTUTILS_ALL_SUBPHASE_IMPLS=()
+
+ # bug #944221
+ for impl in "${PYTHON_COMPAT[@]}"; do
+ use "python_targets_${impl}" && \
+ DISTUTILS_ALL_SUBPHASE_IMPLS+=( "${impl}" )
+ done
+}
+
python_compile_all() {
# copy-pasted from distutils_write_namespace
local path="${BUILD_DIR}/install$(python_get_sitedir)/find_work/__init__.py"
diff --git a/dev-util/glsl-language-server/Manifest b/dev-util/glsl-language-server/Manifest
deleted file mode 100644
index 087db1424..000000000
--- a/dev-util/glsl-language-server/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST 0.3.7-g.tar.gz 3627891 BLAKE2B b7b6724287b5660c33db4eb40d784b195c4c8087943968167bf0b66f44faf054e36350fea53597bf38cfa7f0e087f96992dce0e7afe3131c9d05795605af8e81 SHA512 822611e0b1b30c513870ce05f4ff32c9a9aaef72f6c2832b69c0af6b60a4e716590d9c728f46a66bb6e49e2e8568c2a04832e410c8a55c945798a20223a686ff
diff --git a/dev-util/glsl-language-server/glsl-language-server-0.3.7.ebuild b/dev-util/glsl-language-server/glsl-language-server-0.3.7.ebuild
deleted file mode 100644
index a218e10a2..000000000
--- a/dev-util/glsl-language-server/glsl-language-server-0.3.7.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Language server implementation for GLSL"
-HOMEPAGE="https://github.com/billyb2/glsl-language-server-gentoo"
-SRC_URI="https://github.com/billyb2/${PN}-gentoo/archive/refs/tags/${PV}-g.tar.gz"
-S="${WORKDIR}"/${PN}-gentoo-${PV}-g
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="dev-util/glslang dev-cpp/cli11 dev-cpp/nlohmann_json dev-libs/libfmt"
-RDEPEND="${DEPEND}"
-BDEPEND="app-alternatives/ninja"
-
-src_install() {
- DESTDIR="${D}" ninja -C"${S}/build" install
-}
diff --git a/dev-util/glsl-language-server/metadata.xml b/dev-util/glsl-language-server/metadata.xml
deleted file mode 100644
index 4c09107ad..000000000
--- a/dev-util/glsl-language-server/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">billyb2/glsl-language-server-gentoo</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-misc/megasync/Manifest b/net-misc/megasync/Manifest
index ee9a884e6..8bb3a95e6 100644
--- a/net-misc/megasync/Manifest
+++ b/net-misc/megasync/Manifest
@@ -1,4 +1,4 @@
-DIST megasync-5.5.0.0.tar.gz 24651476 BLAKE2B 6a62b9c27329864e53bc80a98018c6ccbc4a858518ef497a0825b251bd9458888e3b7f1c5ff09488971aa11d927bb173e14289f035db439b9e0340bd9add8a79 SHA512 4a62fadff5f472391b7ee1b0bf525878c1030bbb0e8d88e4f79571b61d5f9e86769d2ee8081638b0b0110ee59b9b9de1ad39cfdb87f36887286a8543aafcfd02
DIST megasync-5.6.0.0.tar.gz 24712966 BLAKE2B 644e2ccbb2d7e60e9b15278d0e75c46ed102bab436e33a46dfac5068d9e527f4d9e1fbf109f286200b07d02efc08a986c0c263f4ce588fa286dcfc5eb73310d2 SHA512 49105e145cb3af2628044eb0161efdb4c2b75d844d955fe65b54171d77b887e0b77c543911a9a39501fe2200f43fbcdf3f0f1b78fe5868fa8a1968e7e9e02aca
-DIST megasync-sdk-5.5.0.0.tar.gz 4206234 BLAKE2B 08da742a9dd7d89ebbdb7b0b45dc1c174819b605734a87ab28bb9f1dae4108162110e4d7c820e2427e7b63250cd0550daab20e514eaa33543e47f7d7ea44d1ec SHA512 20a87e4440d2d161335f268389b58c353d9dd6bb1f0b2423c403b1f7202cc927776d3225f4e174b238b03a062d998f65a3ded931fb7f8718275934529015a74c
+DIST megasync-5.6.1.0.tar.gz 24712997 BLAKE2B 0e1a80c3c4f934f0b9274beba0883a72ab41bb9dc71284109cf2dd17660adc30ace4e82258ff403d1f95e5edab3aedf309632c2e172b0c727bdfedf06379d09e SHA512 f62b8890eefd4b0f66eeaf99e98a04369da36daea1b3011888c16408578a6e10f3bbe5d584b18a249776ceff9184b77506a809fd1bba95b8f6671a8bf10a1dc1
DIST megasync-sdk-5.6.0.0.tar.gz 4231209 BLAKE2B 47e2bfe98879101c295e98556c21189a9e0223ed98c21558c6270534d0f58270e41a44eef7a2889caeb1c3256fd00e5d10c51c53c58c96e48efe29b56bb54d06 SHA512 4cf7bd84421a4399fe4269bac16916b5164755f2241c19a78b1c371dac342332c6e7e440942bac31370eeb840a6a71645fd26e1c98a8ff095a1ab8d10ca694e8
+DIST megasync-sdk-5.6.1.0.tar.gz 4231187 BLAKE2B 4e0640281b451d9de18f63be3cca832717fe3ea387d91ace63a7db9d63ea51dfdd54342912885b3a7bde475b93beb524c9a44da9d2106d157df4a6b13b470104 SHA512 f630c3232e3b7b5ac5d9fab0f2d3c8ea6acbd98bb27fdc948d150e91b9edf5ffda575a52544fe5af0e6a023fa53ffe3dc1632e06c823956928e7edb0637f2932
diff --git a/net-misc/megasync/megasync-5.5.0.0.ebuild b/net-misc/megasync/megasync-5.6.1.0.ebuild
index fa2c72a29..cd602354c 100644
--- a/net-misc/megasync/megasync-5.5.0.0.ebuild
+++ b/net-misc/megasync/megasync-5.6.1.0.ebuild
@@ -11,24 +11,17 @@ HOMEPAGE="
https://github.com/meganz/MEGAsync
"
-if [[ ${PV} == 9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
- EGIT_BRANCH="master"
- EGIT_SUBMODULES=( '*' )
-else
- MEGA_SDK_REV="eb86660026272d62a547099d2fed3a7d46fc64e7" # commit of src/MEGASync/mega submodule
- MEGA_TAG_SUFFIX="Linux"
- SRC_URI="
- https://github.com/meganz/MEGAsync/archive/v${PV}_${MEGA_TAG_SUFFIX}.tar.gz -> ${P}.tar.gz
- https://github.com/meganz/sdk/archive/${MEGA_SDK_REV}.tar.gz -> ${PN}-sdk-${PV}.tar.gz
- "
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}"/MEGAsync-${PV}_${MEGA_TAG_SUFFIX}
-fi
+MEGA_SDK_REV="ecc873026fcc0355f6d490b8529c9f22d5a4fd8c" # commit of src/MEGASync/mega submodule
+MEGA_TAG_SUFFIX="Linux"
+SRC_URI="
+ https://github.com/meganz/MEGAsync/archive/v${PV}_${MEGA_TAG_SUFFIX}.tar.gz -> ${P}.tar.gz
+ https://github.com/meganz/sdk/archive/${MEGA_SDK_REV}.tar.gz -> ${PN}-sdk-${PV}.tar.gz
+"
+S="${WORKDIR}"/MEGAsync-${PV}_${MEGA_TAG_SUFFIX}
LICENSE="MEGA"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="mediainfo nautilus nemo thumbnail thunar"
DEPEND="
@@ -85,6 +78,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.0.0-link-zlib.patch"
"${FILESDIR}/${PN}-5.3.0.0-fix-install-dir.patch"
"${FILESDIR}/${PN}-5.3.0.0-rename-libcryptopp.patch"
+ "${FILESDIR}/${PN}-5.6.0.0-remove-clang-format.patch"
)
nemo_run() {
@@ -120,6 +114,7 @@ src_configure() {
-DCMAKE_MODULE_PATH="${S}/src/MEGASync/mega/contrib/cmake/modules/packages"
-DENABLE_DESKTOP_APP_WERROR=OFF
-DENABLE_DESKTOP_UPDATE_GEN=OFF
+ -DENABLE_DESIGN_TOKENS_IMPORTER=OFF
-DENABLE_LINUX_EXT=$(usex nautilus)
-DUSE_FFMPEG=$(usex thumbnail)
-DUSE_FREEIMAGE=$(usex thumbnail)
diff --git a/net-p2p/trezord-go/files/trezord-go-2.0.33_libusb.patch b/net-p2p/trezord-go/files/trezord-go-2.0.33_libusb.patch
new file mode 100644
index 000000000..28d0562d2
--- /dev/null
+++ b/net-p2p/trezord-go/files/trezord-go-2.0.33_libusb.patch
@@ -0,0 +1,393 @@
+From 616473d53a8ae49f1099e36ab05a2981a08fa606 Mon Sep 17 00:00:00 2001
+From: Pisit Wajanasara <compisit1234@gmail.com>
+Date: Wed, 3 Jan 2024 15:33:49 -0800
+Subject: [PATCH] Fix libusb for newer golang version
+
+---
+ usb/lowlevel/libusb/libusb.go | 121 ++++++++++++++++++++++------------
+ 1 file changed, 80 insertions(+), 41 deletions(-)
+
+diff --git a/usb/lowlevel/libusb/libusb.go b/usb/lowlevel/libusb/libusb.go
+index abc289e..001a4d6 100644
+--- a/usb/lowlevel/libusb/libusb.go
++++ b/usb/lowlevel/libusb/libusb.go
+@@ -389,8 +389,11 @@ const HOTPLUG_MATCH_ANY = C.LIBUSB_HOTPLUG_MATCH_ANY
+ // A structure representing the standard USB endpoint descriptor.
+ // This descriptor is documented in section 9.6.6 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_Endpoint_Descriptor = C.struct_libusb_endpoint_descriptor
++
+ type Endpoint_Descriptor struct {
+- ptr *C.struct_libusb_endpoint_descriptor
++ ptr *Struct_Libusb_Endpoint_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BEndpointAddress uint8
+@@ -402,7 +405,7 @@ type Endpoint_Descriptor struct {
+ Extra []byte
+ }
+
+-func (x *C.struct_libusb_endpoint_descriptor) c2go() *Endpoint_Descriptor {
++func (x *Struct_Libusb_Endpoint_Descriptor) c2go() *Endpoint_Descriptor {
+ return &Endpoint_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -437,8 +440,11 @@ func (x *Endpoint_Descriptor) String() string {
+ // A structure representing the standard USB interface descriptor.
+ // This descriptor is documented in section 9.6.5 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_Interface_Descriptor = C.struct_libusb_interface_descriptor
++
+ type Interface_Descriptor struct {
+- ptr *C.struct_libusb_interface_descriptor
++ ptr *Struct_Libusb_Interface_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BInterfaceNumber uint8
+@@ -452,8 +458,8 @@ type Interface_Descriptor struct {
+ Extra []byte
+ }
+
+-func (x *C.struct_libusb_interface_descriptor) c2go() *Interface_Descriptor {
+- var list []C.struct_libusb_endpoint_descriptor
++func (x *Struct_Libusb_Interface_Descriptor) c2go() *Interface_Descriptor {
++ var list []Struct_Libusb_Endpoint_Descriptor
+ hdr := (*reflect.SliceHeader)(unsafe.Pointer(&list))
+ hdr.Cap = int(x.bNumEndpoints)
+ hdr.Len = int(x.bNumEndpoints)
+@@ -501,14 +507,17 @@ func (x *Interface_Descriptor) String() string {
+ //-----------------------------------------------------------------------------
+
+ // A collection of alternate settings for a particular USB interface.
++
++type Struct_Libusb_Interface = C.struct_libusb_interface
++
+ type Interface struct {
+- ptr *C.struct_libusb_interface
++ ptr *Struct_Libusb_Interface
+ Num_altsetting int
+ Altsetting []*Interface_Descriptor
+ }
+
+-func (x *C.struct_libusb_interface) c2go() *Interface {
+- var list []C.struct_libusb_interface_descriptor
++func (x *Struct_Libusb_Interface) c2go() *Interface {
++ var list []Struct_Libusb_Interface_Descriptor
+ hdr := (*reflect.SliceHeader)(unsafe.Pointer(&list))
+ hdr.Cap = int(x.num_altsetting)
+ hdr.Len = int(x.num_altsetting)
+@@ -540,8 +549,11 @@ func Interface_str(x *Interface) string {
+ // A structure representing the standard USB configuration descriptor.
+ // This descriptor is documented in section 9.6.3 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_Config_Descriptor = C.struct_libusb_config_descriptor
++
+ type Config_Descriptor struct {
+- ptr *C.struct_libusb_config_descriptor
++ ptr *Struct_Libusb_Config_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ WTotalLength uint16
+@@ -554,8 +566,8 @@ type Config_Descriptor struct {
+ Extra []byte
+ }
+
+-func (x *C.struct_libusb_config_descriptor) c2go() *Config_Descriptor {
+- var list []C.struct_libusb_interface
++func (x *Struct_Libusb_Config_Descriptor) c2go() *Config_Descriptor {
++ var list []Struct_Libusb_Interface
+ hdr := (*reflect.SliceHeader)(unsafe.Pointer(&list))
+ hdr.Cap = int(x.bNumInterfaces)
+ hdr.Len = int(x.bNumInterfaces)
+@@ -603,8 +615,11 @@ func (x *Config_Descriptor) String() string {
+ // A structure representing the superspeed endpoint companion descriptor.
+ // This descriptor is documented in section 9.6.7 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_SS_Endpoint_Companion_Descriptor = C.struct_libusb_ss_endpoint_companion_descriptor
++
+ type SS_Endpoint_Companion_Descriptor struct {
+- ptr *C.struct_libusb_ss_endpoint_companion_descriptor
++ ptr *Struct_Libusb_SS_Endpoint_Companion_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BMaxBurst uint8
+@@ -612,7 +627,7 @@ type SS_Endpoint_Companion_Descriptor struct {
+ WBytesPerInterval uint16
+ }
+
+-func (x *C.struct_libusb_ss_endpoint_companion_descriptor) c2go() *SS_Endpoint_Companion_Descriptor {
++func (x *Struct_Libusb_SS_Endpoint_Companion_Descriptor) c2go() *SS_Endpoint_Companion_Descriptor {
+ return &SS_Endpoint_Companion_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -628,15 +643,18 @@ func (x *C.struct_libusb_ss_endpoint_companion_descriptor) c2go() *SS_Endpoint_C
+ // A generic representation of a BOS Device Capability descriptor.
+ // It is advised to check BDevCapabilityType and call the matching
+ // Get_*_Descriptor function to get a structure fully matching the type.
++
++type Struct_Libusb_BOS_Dev_Capability_Descriptor = C.struct_libusb_bos_dev_capability_descriptor
++
+ type BOS_Dev_Capability_Descriptor struct {
+- ptr *C.struct_libusb_bos_dev_capability_descriptor
++ ptr *Struct_Libusb_BOS_Dev_Capability_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BDevCapabilityType uint8
+ Dev_capability_data []byte
+ }
+
+-func (x *C.struct_libusb_bos_dev_capability_descriptor) c2go() *BOS_Dev_Capability_Descriptor {
++func (x *Struct_Libusb_BOS_Dev_Capability_Descriptor) c2go() *BOS_Dev_Capability_Descriptor {
+ return &BOS_Dev_Capability_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -651,16 +669,19 @@ func (x *C.struct_libusb_bos_dev_capability_descriptor) c2go() *BOS_Dev_Capabili
+ // A structure representing the Binary Device Object Store (BOS) descriptor.
+ // This descriptor is documented in section 9.6.2 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_BOS_Descriptor = C.struct_libusb_bos_descriptor
++
+ type BOS_Descriptor struct {
+- ptr *C.struct_libusb_bos_descriptor
++ ptr *Struct_Libusb_BOS_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ WTotalLength uint16
+ Dev_capability []*BOS_Dev_Capability_Descriptor
+ }
+
+-func (x *C.struct_libusb_bos_descriptor) c2go() *BOS_Descriptor {
+- var list []*C.struct_libusb_bos_dev_capability_descriptor
++func (x *Struct_Libusb_BOS_Descriptor) c2go() *BOS_Descriptor {
++ var list []*Struct_Libusb_BOS_Dev_Capability_Descriptor
+ hdr := (*reflect.SliceHeader)(unsafe.Pointer(&list))
+ hdr.Cap = int(x.bNumDeviceCaps)
+ hdr.Len = int(x.bNumDeviceCaps)
+@@ -683,15 +704,18 @@ func (x *C.struct_libusb_bos_descriptor) c2go() *BOS_Descriptor {
+ // A structure representing the USB 2.0 Extension descriptor
+ // This descriptor is documented in section 9.6.2.1 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_USB_2_0_Extension_Descriptor = C.struct_libusb_usb_2_0_extension_descriptor
++
+ type USB_2_0_Extension_Descriptor struct {
+- ptr *C.struct_libusb_usb_2_0_extension_descriptor
++ ptr *Struct_Libusb_USB_2_0_Extension_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BDevCapabilityType uint8
+ BmAttributes uint32
+ }
+
+-func (x *C.struct_libusb_usb_2_0_extension_descriptor) c2go() *USB_2_0_Extension_Descriptor {
++func (x *Struct_Libusb_USB_2_0_Extension_Descriptor) c2go() *USB_2_0_Extension_Descriptor {
+ return &USB_2_0_Extension_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -706,8 +730,11 @@ func (x *C.struct_libusb_usb_2_0_extension_descriptor) c2go() *USB_2_0_Extension
+ // A structure representing the SuperSpeed USB Device Capability descriptor
+ // This descriptor is documented in section 9.6.2.2 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_SS_USB_Device_Capability_Descriptor = C.struct_libusb_ss_usb_device_capability_descriptor
++
+ type SS_USB_Device_Capability_Descriptor struct {
+- ptr *C.struct_libusb_ss_usb_device_capability_descriptor
++ ptr *Struct_Libusb_SS_USB_Device_Capability_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BDevCapabilityType uint8
+@@ -718,7 +745,7 @@ type SS_USB_Device_Capability_Descriptor struct {
+ BU2DevExitLat uint16
+ }
+
+-func (x *C.struct_libusb_ss_usb_device_capability_descriptor) c2go() *SS_USB_Device_Capability_Descriptor {
++func (x *Struct_Libusb_SS_USB_Device_Capability_Descriptor) c2go() *SS_USB_Device_Capability_Descriptor {
+ return &SS_USB_Device_Capability_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -737,8 +764,11 @@ func (x *C.struct_libusb_ss_usb_device_capability_descriptor) c2go() *SS_USB_Dev
+ // A structure representing the Container ID descriptor.
+ // This descriptor is documented in section 9.6.2.3 of the USB 3.0 specification.
+ // All multiple-byte fields, except UUIDs, are represented in host-endian format.
++
++type Struct_Libusb_Container_ID_Descriptor = C.struct_libusb_container_id_descriptor
++
+ type Container_ID_Descriptor struct {
+- ptr *C.struct_libusb_container_id_descriptor
++ ptr *Struct_Libusb_Container_ID_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BDevCapabilityType uint8
+@@ -746,7 +776,7 @@ type Container_ID_Descriptor struct {
+ ContainerID []byte
+ }
+
+-func (x *C.struct_libusb_container_id_descriptor) c2go() *Container_ID_Descriptor {
++func (x *Struct_Libusb_Container_ID_Descriptor) c2go() *Container_ID_Descriptor {
+ return &Container_ID_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -775,8 +805,11 @@ struct libusb_control_setup {
+ // A structure representing the standard USB device descriptor.
+ // This descriptor is documented in section 9.6.1 of the USB 3.0 specification.
+ // All multiple-byte fields are represented in host-endian format.
++
++type Struct_Libusb_Device_Descriptor = C.struct_libusb_device_descriptor
++
+ type Device_Descriptor struct {
+- ptr *C.struct_libusb_device_descriptor
++ ptr *Struct_Libusb_Device_Descriptor
+ BLength uint8
+ BDescriptorType uint8
+ BcdUSB uint16
+@@ -793,7 +826,7 @@ type Device_Descriptor struct {
+ BNumConfigurations uint8
+ }
+
+-func (x *C.struct_libusb_device_descriptor) c2go() *Device_Descriptor {
++func (x *Struct_Libusb_Device_Descriptor) c2go() *Device_Descriptor {
+ return &Device_Descriptor{
+ ptr: x,
+ BLength: uint8(x.bLength),
+@@ -859,17 +892,20 @@ struct libusb_transfer {
+ // then submits it in order to request a transfer. After the transfer has
+ // completed, the library populates the transfer with the results and passes
+ // it back to the user.
++
++type Struct_Libusb_Transfer = C.struct_libusb_transfer
++
+ type Transfer struct {
+- ptr *C.struct_libusb_transfer
++ ptr *Struct_Libusb_Transfer
+ }
+
+-func (x *C.struct_libusb_transfer) c2go() *Transfer {
++func (x *Struct_Libusb_Transfer) c2go() *Transfer {
+ return &Transfer{
+ ptr: x,
+ }
+ }
+
+-func (x *Transfer) go2c() *C.struct_libusb_transfer {
++func (x *Transfer) go2c() *Struct_Libusb_Transfer {
+ return x.ptr
+ }
+
+@@ -882,8 +918,11 @@ func (x *Transfer) String() string {
+ //-----------------------------------------------------------------------------
+
+ // Structure providing the version of the libusb runtime.
++
++type Struct_Libusb_Version = C.struct_libusb_version
++
+ type Version struct {
+- ptr *C.struct_libusb_version
++ ptr *Struct_Libusb_Version
+ Major uint16
+ Minor uint16
+ Micro uint16
+@@ -892,7 +931,7 @@ type Version struct {
+ Describe string
+ }
+
+-func (x *C.struct_libusb_version) c2go() *Version {
++func (x *Struct_Libusb_Version) c2go() *Version {
+ return &Version{
+ ptr: x,
+ Major: uint16(x.major),
+@@ -1146,7 +1185,7 @@ func Error_Name(code int) string {
+ }
+
+ func Get_Version() *Version {
+- ver := (*C.struct_libusb_version)(unsafe.Pointer(C.libusb_get_version()))
++ ver := (*Struct_Libusb_Version)(unsafe.Pointer(C.libusb_get_version()))
+ return ver.c2go()
+ }
+
+@@ -1173,7 +1212,7 @@ func Strerror(errcode int) string {
+ // USB descriptors
+
+ func Get_Device_Descriptor(dev Device) (*Device_Descriptor, error) {
+- var desc C.struct_libusb_device_descriptor
++ var desc Struct_Libusb_Device_Descriptor
+ rc := int(C.libusb_get_device_descriptor(dev, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1182,7 +1221,7 @@ func Get_Device_Descriptor(dev Device) (*Device_Descriptor, error) {
+ }
+
+ func Get_Active_Config_Descriptor(dev Device) (*Config_Descriptor, error) {
+- var desc *C.struct_libusb_config_descriptor
++ var desc *Struct_Libusb_Config_Descriptor
+ rc := int(C.libusb_get_active_config_descriptor(dev, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1191,7 +1230,7 @@ func Get_Active_Config_Descriptor(dev Device) (*Config_Descriptor, error) {
+ }
+
+ func Get_Config_Descriptor(dev Device, config_index uint8) (*Config_Descriptor, error) {
+- var desc *C.struct_libusb_config_descriptor
++ var desc *Struct_Libusb_Config_Descriptor
+ rc := int(C.libusb_get_config_descriptor(dev, (C.uint8_t)(config_index), &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1200,7 +1239,7 @@ func Get_Config_Descriptor(dev Device, config_index uint8) (*Config_Descriptor,
+ }
+
+ func Get_Config_Descriptor_By_Value(dev Device, bConfigurationValue uint8) (*Config_Descriptor, error) {
+- var desc *C.struct_libusb_config_descriptor
++ var desc *Struct_Libusb_Config_Descriptor
+ rc := int(C.libusb_get_config_descriptor_by_value(dev, (C.uint8_t)(bConfigurationValue), &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1213,7 +1252,7 @@ func Free_Config_Descriptor(config *Config_Descriptor) {
+ }
+
+ func Get_SS_Endpoint_Companion_Descriptor(ctx Context, endpoint *Endpoint_Descriptor) (*SS_Endpoint_Companion_Descriptor, error) {
+- var desc *C.struct_libusb_ss_endpoint_companion_descriptor
++ var desc *Struct_Libusb_SS_Endpoint_Companion_Descriptor
+ rc := int(C.libusb_get_ss_endpoint_companion_descriptor(ctx, endpoint.ptr, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1226,7 +1265,7 @@ func Free_SS_Endpoint_Companion_Descriptor(ep_comp *SS_Endpoint_Companion_Descri
+ }
+
+ func Get_BOS_Descriptor(hdl Device_Handle) (*BOS_Descriptor, error) {
+- var desc *C.struct_libusb_bos_descriptor
++ var desc *Struct_Libusb_BOS_Descriptor
+ rc := int(C.libusb_get_bos_descriptor(hdl, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1239,7 +1278,7 @@ func Free_BOS_Descriptor(bos *BOS_Descriptor) {
+ }
+
+ func Get_USB_2_0_Extension_Descriptor(ctx Context, dev_cap *BOS_Dev_Capability_Descriptor) (*USB_2_0_Extension_Descriptor, error) {
+- var desc *C.struct_libusb_usb_2_0_extension_descriptor
++ var desc *Struct_Libusb_USB_2_0_Extension_Descriptor
+ rc := int(C.libusb_get_usb_2_0_extension_descriptor(ctx, dev_cap.ptr, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1252,7 +1291,7 @@ func Free_USB_2_0_Extension_Descriptor(usb_2_0_extension *USB_2_0_Extension_Desc
+ }
+
+ func Get_SS_USB_Device_Capability_Descriptor(ctx Context, dev_cap *BOS_Dev_Capability_Descriptor) (*SS_USB_Device_Capability_Descriptor, error) {
+- var desc *C.struct_libusb_ss_usb_device_capability_descriptor
++ var desc *Struct_Libusb_SS_USB_Device_Capability_Descriptor
+ rc := int(C.libusb_get_ss_usb_device_capability_descriptor(ctx, dev_cap.ptr, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
+@@ -1265,7 +1304,7 @@ func Free_SS_USB_Device_Capability_Descriptor(ss_usb_device_cap *SS_USB_Device_C
+ }
+
+ func Get_Container_ID_Descriptor(ctx Context, dev_cap *BOS_Dev_Capability_Descriptor) (*Container_ID_Descriptor, error) {
+- var desc *C.struct_libusb_container_id_descriptor
++ var desc *Struct_Libusb_Container_ID_Descriptor
+ rc := int(C.libusb_get_container_id_descriptor(ctx, dev_cap.ptr, &desc))
+ if rc != 0 {
+ return nil, &libusb_error{rc}
diff --git a/net-p2p/trezord-go/trezord-go-2.0.33.ebuild b/net-p2p/trezord-go/trezord-go-2.0.33.ebuild
index 5861209bc..af32c7a5e 100644
--- a/net-p2p/trezord-go/trezord-go-2.0.33.ebuild
+++ b/net-p2p/trezord-go/trezord-go-2.0.33.ebuild
@@ -48,6 +48,8 @@ DEPEND="
acct-group/plugdev
"
+PATCHES=( "${FILESDIR}/${P}_libusb.patch" )
+
src_compile() {
default
go build -v -work -x -o ${PN} || die
diff --git a/profiles/package.mask b/profiles/package.mask
index 9d08653b2..e30b523b1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -18,6 +18,13 @@
# New entries go on top.
+# Takuya Wakazono <pastalian46@gmail.com> (2024-11-21)
+# SRC_URI is 410. No maintainer.
+# x11-misc/xscreensaver is available in ::gentoo and users can apply
+# patches themselves.
+# Removal on 2024-12-21.
+x11-misc/xscreensaver-anclock
+
# Nicolas PARLANT <nicolas.parhuet@parhuet.fr> (2024-11-21)
# No maintener and SRC_URI / license issue #262
# Replaced by media-fonts/ttf-ancient-fonts wich includes
@@ -27,7 +34,7 @@ media-fonts/symbola
# Julien Roy <julien@jroy.ca> (2024-11-20)
# Dependency with no revdeps
-# Removal in 30 days
+# Removal on 2024-12-20
dev-python/kurbopy
# Takuya Wakazono <pastalian46@gmail.com> (2024-11-18)
@@ -83,11 +90,6 @@ dev-util/rpi-imager
# Removal on 2024-11-30. Bug #780705.
app-editors/kitscenarist
-# Takuya Wakazono <pastalian46@gmail.com> (2024-10-19)
-# Doesn't build anymore. Unmaintained since 2022.
-# Removal on 2024-11-19. Bug #927878.
-dev-util/glsl-language-server
-
# Takuya Wakazono <pastalian46@gmail.com> (2024-10-18)
# Depends on <dev-python/tree-sitter-0.22, which has been dropped.
# Upstream does not support newer treesitter and is no longer