aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Campeanu <tiotags1@gmail.com>2022-07-27 19:12:45 +0300
committerAlexandru Campeanu <tiotags1@gmail.com>2022-07-27 19:12:45 +0300
commit5c1cac99d855b425654b9f72dc56a4c343195905 (patch)
tree20f267defd139dd3f8d58e3dcb50a63f033c6f4a /www-servers
parentapp-misc/fastfetch: drop 1.5.6 (diff)
downloadguru-5c1cac99d855b425654b9f72dc56a4c343195905.tar.gz
guru-5c1cac99d855b425654b9f72dc56a4c343195905.tar.bz2
guru-5c1cac99d855b425654b9f72dc56a4c343195905.zip
www-servers/hinsightd: add 0.9.15_p20220727, drop old
Closes: https://bugs.gentoo.org/show_bug.cgi?id=840047 Closes: https://bugs.gentoo.org/show_bug.cgi?id=860846 Signed-off-by: Alexandru Campeanu <tiotags1@gmail.com>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/hinsightd/Manifest2
-rw-r--r--www-servers/hinsightd/hinsightd-0.9.15_p20220727.ebuild (renamed from www-servers/hinsightd/hinsightd-0.9.14.ebuild)22
-rw-r--r--www-servers/hinsightd/hinsightd-9999.ebuild6
3 files changed, 20 insertions, 10 deletions
diff --git a/www-servers/hinsightd/Manifest b/www-servers/hinsightd/Manifest
index f30779379..575193850 100644
--- a/www-servers/hinsightd/Manifest
+++ b/www-servers/hinsightd/Manifest
@@ -1 +1 @@
-DIST hin9-v0.9.14.tar.gz 104520 BLAKE2B 2926450af8cd10cd12c06cf157d8815167f1c83baed543821e201947445ca02ccba12a96aa456c555d9bae31da469175680fa565ba786fef27ceb9629f0cbd52 SHA512 b2f473024570738717d16fc5be86ad91bbf79cf1886e1f61ea55fb64769bf8410943a1ae71585411053c70907ab1c4e7556135383a9d4048f516349b11ac952f
+DIST hin9-7cb278f9359a39050d254f29d361010723f2d7c1.tar.gz 114997 BLAKE2B ab66f059b20d0193a8fb2e106a8f19bb5b1e8a98bfedf74cfdd17ab46c7fcbe3a3c117ee4cd0c16a6437fa1bd87dd8b30f8f2407086cc37d2caf81b3be36abcf SHA512 be61fa439d9c8033f7f103799b14a39f773c80f33acdb5ca50b3f53b0b54ea272e45d7da1c2f5e18f00ffd8342705148a7d6217a555db77bf102a5ed4ef7e523
diff --git a/www-servers/hinsightd/hinsightd-0.9.14.ebuild b/www-servers/hinsightd/hinsightd-0.9.15_p20220727.ebuild
index 1d5a41be8..f62e4a0c1 100644
--- a/www-servers/hinsightd/hinsightd-0.9.14.ebuild
+++ b/www-servers/hinsightd/hinsightd-0.9.15_p20220727.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,20 +8,28 @@ LUA_COMPAT=( lua5-{1..4} luajit )
inherit fcaps lua-single systemd cmake linux-info
DESCRIPTION="hinsightd a http/1.1 webserver with (hopefully) minimal goals"
-HOMEPAGE="https://gitlab.com/tiotags/hin9"
+HOMEPAGE="https://tiotags.gitlab.io/hinsightd"
LICENSE="BSD"
SLOT="0"
+mycommit="7cb278f9359a39050d254f29d361010723f2d7c1"
+
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
+elif [[ ! -z "$mycommit" ]]; then
+ SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/${mycommit}/hin9-${mycommit}.tar.gz"
+ S="${WORKDIR}/hin9-${mycommit}"
else
SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v${PV}/hin9-v${PV}.tar.gz"
S="${WORKDIR}/hin9-v${PV}"
+fi
+
+if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64"
fi
-IUSE="+openssl cgi +fcgi +rproxy +ffcall"
+IUSE="+ssl cgi +fcgi +rproxy +ffcall"
REQUIRED_USE="${LUA_REQUIRED_USE}"
BDEPEND="
@@ -36,23 +44,19 @@ RDEPEND="
sys-libs/liburing
sys-libs/zlib
virtual/libcrypt
- openssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl )
ffcall? ( dev-libs/ffcall )
"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}/${PN}-defines-v4.patch"
-)
-
FILECAPS=(
cap_net_bind_service usr/sbin/${PN}
)
src_configure() {
local mycmakeargs=(
- -DUSE_OPENSSL=$(usex openssl)
+ -DUSE_OPENSSL=$(usex ssl)
-DUSE_CGI=$(usex cgi)
-DUSE_FCGI=$(usex fcgi)
-DUSE_RPROXY=$(usex rproxy)
diff --git a/www-servers/hinsightd/hinsightd-9999.ebuild b/www-servers/hinsightd/hinsightd-9999.ebuild
index d750ebe79..0a2fda199 100644
--- a/www-servers/hinsightd/hinsightd-9999.ebuild
+++ b/www-servers/hinsightd/hinsightd-9999.ebuild
@@ -15,9 +15,15 @@ SLOT="0"
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
+elif [[ ! -z "$mycommit" ]]; then
+ SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/${mycommit}/hin9-${mycommit}.tar.gz"
+ S="${WORKDIR}/hin9-${mycommit}"
else
SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v${PV}/hin9-v${PV}.tar.gz"
S="${WORKDIR}/hin9-v${PV}"
+fi
+
+if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64"
fi