aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortiotags <tiotags1@gmail.com>2021-04-23 10:21:59 +0300
committertiotags <tiotags1@gmail.com>2021-04-23 10:22:12 +0300
commit4d80cc06ee59e44ae9548ebf9a593e3f5e2dcef6 (patch)
tree9dca19114a067a914882ab4e0ae70802ba559d40 /www-servers
parentapp-misc/afetch: remove direct CC call (diff)
downloadguru-4d80cc06ee59e44ae9548ebf9a593e3f5e2dcef6.tar.gz
guru-4d80cc06ee59e44ae9548ebf9a593e3f5e2dcef6.tar.bz2
guru-4d80cc06ee59e44ae9548ebf9a593e3f5e2dcef6.zip
www-servers/hinsightd: lua-single, multiple tweaks
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexandru Campeanu <tiotags1@gmail.com>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/hinsightd/hinsightd-0.9.0.ebuild6
-rw-r--r--www-servers/hinsightd/hinsightd-9999.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/www-servers/hinsightd/hinsightd-0.9.0.ebuild b/www-servers/hinsightd/hinsightd-0.9.0.ebuild
index 744bf8aabd..7f95594b60 100644
--- a/www-servers/hinsightd/hinsightd-0.9.0.ebuild
+++ b/www-servers/hinsightd/hinsightd-0.9.0.ebuild
@@ -5,11 +5,11 @@ EAPI=7
LUA_COMPAT=( lua5-1 )
-inherit fcaps lua
+inherit fcaps lua-single
DESCRIPTION="hinsightd a http/1.1 webserver with (hopefully) minimal goals"
HOMEPAGE="https://gitlab.com/tiotags/hin9"
-SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v0.9.0/hin9-v0.9.0.tar.gz"
+SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v${PV}/hin9-v${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -51,7 +51,7 @@ src_compile() {
src_install() {
newbin "${S}/build/hin9" hinsightd
newinitd "${FILESDIR}/init.d.sh" hinsightd
- #systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
+ systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
insinto /etc/hinsightd
newins "${S}/workdir/main.lua" hinsightd.lua
diff --git a/www-servers/hinsightd/hinsightd-9999.ebuild b/www-servers/hinsightd/hinsightd-9999.ebuild
index d0fcda4239..cfc31c90f6 100644
--- a/www-servers/hinsightd/hinsightd-9999.ebuild
+++ b/www-servers/hinsightd/hinsightd-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
LUA_COMPAT=( lua5-{1..4} )
-inherit git-r3 fcaps lua
+inherit git-r3 fcaps lua-single
DESCRIPTION="hinsightd a http/1.1 webserver with (hopefully) minimal goals"
HOMEPAGE="https://gitlab.com/tiotags/hin9"
@@ -49,7 +49,7 @@ src_compile() {
src_install() {
newbin "${S}/build/hin9" hinsightd
newinitd "${FILESDIR}/init.d.sh" hinsightd
- #systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
+ systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
insinto /etc/hinsightd
newins "${S}/workdir/main.lua" hinsightd.lua