aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-12 00:27:57 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-12 00:27:57 +0200
commit38100aaf444c2945f19b8537444088861dc85157 (patch)
tree62aa8e7ed79d8bffd110769e2ffca8b8ae775cfc /www-servers
parentdev-ruby/rspec-wait: disable ruby25 (diff)
downloadguru-38100aaf444c2945f19b8537444088861dc85157.tar.gz
guru-38100aaf444c2945f19b8537444088861dc85157.tar.bz2
guru-38100aaf444c2945f19b8537444088861dc85157.zip
www-servers/thin: remove ruby25
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thin/thin-1.8.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/www-servers/thin/thin-1.8.0.ebuild b/www-servers/thin/thin-1.8.0.ebuild
index 9f43ab603..d1d45d546 100644
--- a/www-servers/thin/thin-1.8.0.ebuild
+++ b/www-servers/thin/thin-1.8.0.ebuild
@@ -1,13 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+USE_RUBY="ruby26"
inherit ruby-fakegem
@@ -56,7 +54,9 @@ all_ruby_prepare() {
sed -i -e "s/Spec::Runner/Rspec/" spec/spec_helper.rb || die
# nasty but too complex to fix up for now :(
- use doc || rm tasks/rdoc.rake
+ if ! use doc; then
+ rm tasks/rdoc.rake || die
+ fi
}
each_ruby_configure() {
@@ -76,8 +76,8 @@ all_ruby_install() {
all_fakegem_install
keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd-r4 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd-2 ${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r4" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
einfo
elog "Thin is now shipped with init scripts."