aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-09-11 08:06:11 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-09-11 08:06:11 +0300
commit04722c611088c87633695ef12c409f3bcfd1ccab (patch)
tree8ccbd6e96b43bfbad9d11ee6365090211dcd2621 /www-plugins
parentsys-boot/limine: add 8.0.11 (diff)
downloadguru-04722c611088c87633695ef12c409f3bcfd1ccab.tar.gz
guru-04722c611088c87633695ef12c409f3bcfd1ccab.tar.bz2
guru-04722c611088c87633695ef12c409f3bcfd1ccab.zip
www-plugins/firefoxpwa: fix cargo target dir
Closes: https://bugs.gentoo.org/939376 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/firefoxpwa/firefoxpwa-2.12.0-r1.ebuild10
-rw-r--r--www-plugins/firefoxpwa/firefoxpwa-2.12.1.ebuild10
-rw-r--r--www-plugins/firefoxpwa/firefoxpwa-2.12.2.ebuild10
-rw-r--r--www-plugins/firefoxpwa/firefoxpwa-2.12.3.ebuild10
4 files changed, 20 insertions, 20 deletions
diff --git a/www-plugins/firefoxpwa/firefoxpwa-2.12.0-r1.ebuild b/www-plugins/firefoxpwa/firefoxpwa-2.12.0-r1.ebuild
index ccf6601b07..adc0d6099d 100644
--- a/www-plugins/firefoxpwa/firefoxpwa-2.12.0-r1.ebuild
+++ b/www-plugins/firefoxpwa/firefoxpwa-2.12.0-r1.ebuild
@@ -467,9 +467,9 @@ src_configure() {
src_install() {
# Executables
- dobin target/*/firefoxpwa
+ dobin $(cargo_target_dir)/firefoxpwa
exeinto /usr/libexec
- doexe target/*/firefoxpwa-connector
+ doexe $(cargo_target_dir)/firefoxpwa-connector
# Manifest
local target_dirs=( /usr/lib{,64}/mozilla/native-messaging-hosts )
@@ -479,9 +479,9 @@ src_install() {
done
# Completions
- newbashcomp target/*/completions/firefoxpwa.bash firefoxpwa
- dofishcomp target/*/completions/firefoxpwa.fish
- dozshcomp target/*/completions/_firefoxpwa
+ newbashcomp $(cargo_target_dir)/completions/firefoxpwa.bash firefoxpwa
+ dofishcomp $(cargo_target_dir)/completions/firefoxpwa.fish
+ dozshcomp $(cargo_target_dir)/completions/_firefoxpwa
# UserChrome
insinto /usr/share/firefoxpwa
diff --git a/www-plugins/firefoxpwa/firefoxpwa-2.12.1.ebuild b/www-plugins/firefoxpwa/firefoxpwa-2.12.1.ebuild
index ccf6601b07..adc0d6099d 100644
--- a/www-plugins/firefoxpwa/firefoxpwa-2.12.1.ebuild
+++ b/www-plugins/firefoxpwa/firefoxpwa-2.12.1.ebuild
@@ -467,9 +467,9 @@ src_configure() {
src_install() {
# Executables
- dobin target/*/firefoxpwa
+ dobin $(cargo_target_dir)/firefoxpwa
exeinto /usr/libexec
- doexe target/*/firefoxpwa-connector
+ doexe $(cargo_target_dir)/firefoxpwa-connector
# Manifest
local target_dirs=( /usr/lib{,64}/mozilla/native-messaging-hosts )
@@ -479,9 +479,9 @@ src_install() {
done
# Completions
- newbashcomp target/*/completions/firefoxpwa.bash firefoxpwa
- dofishcomp target/*/completions/firefoxpwa.fish
- dozshcomp target/*/completions/_firefoxpwa
+ newbashcomp $(cargo_target_dir)/completions/firefoxpwa.bash firefoxpwa
+ dofishcomp $(cargo_target_dir)/completions/firefoxpwa.fish
+ dozshcomp $(cargo_target_dir)/completions/_firefoxpwa
# UserChrome
insinto /usr/share/firefoxpwa
diff --git a/www-plugins/firefoxpwa/firefoxpwa-2.12.2.ebuild b/www-plugins/firefoxpwa/firefoxpwa-2.12.2.ebuild
index 3e7c6e5c3d..c96a6fb952 100644
--- a/www-plugins/firefoxpwa/firefoxpwa-2.12.2.ebuild
+++ b/www-plugins/firefoxpwa/firefoxpwa-2.12.2.ebuild
@@ -487,9 +487,9 @@ src_configure() {
src_install() {
# Executables
- dobin target/*/firefoxpwa
+ dobin $(cargo_target_dir)/firefoxpwa
exeinto /usr/libexec
- doexe target/*/firefoxpwa-connector
+ doexe $(cargo_target_dir)/firefoxpwa-connector
# Manifest
local target_dirs=( /usr/lib{,64}/mozilla/native-messaging-hosts )
@@ -499,9 +499,9 @@ src_install() {
done
# Completions
- newbashcomp target/*/completions/firefoxpwa.bash firefoxpwa
- dofishcomp target/*/completions/firefoxpwa.fish
- dozshcomp target/*/completions/_firefoxpwa
+ newbashcomp $(cargo_target_dir)/completions/firefoxpwa.bash firefoxpwa
+ dofishcomp $(cargo_target_dir)/completions/firefoxpwa.fish
+ dozshcomp $(cargo_target_dir)/completions/_firefoxpwa
# UserChrome
insinto /usr/share/firefoxpwa
diff --git a/www-plugins/firefoxpwa/firefoxpwa-2.12.3.ebuild b/www-plugins/firefoxpwa/firefoxpwa-2.12.3.ebuild
index 3e7c6e5c3d..c96a6fb952 100644
--- a/www-plugins/firefoxpwa/firefoxpwa-2.12.3.ebuild
+++ b/www-plugins/firefoxpwa/firefoxpwa-2.12.3.ebuild
@@ -487,9 +487,9 @@ src_configure() {
src_install() {
# Executables
- dobin target/*/firefoxpwa
+ dobin $(cargo_target_dir)/firefoxpwa
exeinto /usr/libexec
- doexe target/*/firefoxpwa-connector
+ doexe $(cargo_target_dir)/firefoxpwa-connector
# Manifest
local target_dirs=( /usr/lib{,64}/mozilla/native-messaging-hosts )
@@ -499,9 +499,9 @@ src_install() {
done
# Completions
- newbashcomp target/*/completions/firefoxpwa.bash firefoxpwa
- dofishcomp target/*/completions/firefoxpwa.fish
- dozshcomp target/*/completions/_firefoxpwa
+ newbashcomp $(cargo_target_dir)/completions/firefoxpwa.bash firefoxpwa
+ dofishcomp $(cargo_target_dir)/completions/firefoxpwa.fish
+ dozshcomp $(cargo_target_dir)/completions/_firefoxpwa
# UserChrome
insinto /usr/share/firefoxpwa