aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Vu <saigon-tech@tuta.io>2024-09-07 12:12:06 +0200
committerMichal Vu <saigon-tech@tuta.io>2024-09-07 12:13:06 +0200
commit50904ddb519bd3be8689d13d642ee3d2c5e5fbae (patch)
treed91d5a463e1ee24752b2941723a03384175aa639 /www-client
parentnet-misc/gmid: update live (diff)
downloadguru-50904ddb519bd3be8689d13d642ee3d2c5e5fbae.tar.gz
guru-50904ddb519bd3be8689d13d642ee3d2c5e5fbae.tar.bz2
guru-50904ddb519bd3be8689d13d642ee3d2c5e5fbae.zip
www-client/zen-bin: add new 'alpha' 37 release
Signed-off-by: Michal Vu <saigon-tech@tuta.io>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/zen-bin/Manifest1
-rw-r--r--www-client/zen-bin/zen-bin-1.0.0_alpha37.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-client/zen-bin/Manifest b/www-client/zen-bin/Manifest
index 4c2d308e93..0159668974 100644
--- a/www-client/zen-bin/Manifest
+++ b/www-client/zen-bin/Manifest
@@ -1,2 +1,3 @@
DIST zen-bin-1.0.0_alpha34.tar.bz2 87624415 BLAKE2B e45d126415e422bb10b316da2cbe4e6a2251b8a934d6b64258c7edfc5874686f2a0def377ba746cb1a81e85a23db505b8e1c0df091ed1af2f7a17842d779c88b SHA512 8f690270641682a1768002596b323dc1a8dfe4608686e79e598f8001f4dc0d3bb32d9eb4f9dad33bbac7edb9d077f708a2b7a9913044ffb96523dbcf96c6c2cb
DIST zen-bin-1.0.0_alpha35.tar.bz2 87401631 BLAKE2B b079154b3a1b92bce2c347de77e2cf73d38b48ea55936b0cc4c5695b105af3e1140c3bfec5cffb75b61a7cb408cc1603b2eb58ff88ddbe63b0f94c4006b30ff3 SHA512 b76f632371323c22bb9a127354b4610b7ad6e13152049c1377e48224087e5d1f4224c2f6c0583a631593810d11d09dbf6a769e9726f4fa2465809afbb2ca8984
+DIST zen-bin-1.0.0_alpha37.tar.bz2 87641638 BLAKE2B f4462692bcc02827267b1abfebfc342aa17c1376036fc04a2423ee4b68d98a3c8c48145849bf8d2bd715546e00c37a14db0c83a1c8f47d019e7050fc8dc789ad SHA512 41b82350e08afb5ab3da5e5c33106bfcf85aa7395de09706eac98d91278cd1c18325efa55b4f5d951c76dff187cf79a704f785d3f604499472630a3d9306aba1
diff --git a/www-client/zen-bin/zen-bin-1.0.0_alpha37.ebuild b/www-client/zen-bin/zen-bin-1.0.0_alpha37.ebuild
new file mode 100644
index 0000000000..1310faac9d
--- /dev/null
+++ b/www-client/zen-bin/zen-bin-1.0.0_alpha37.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils desktop
+
+MY_PV="1.0.0-a.37"
+MY_P="zen"
+
+DESCRIPTION="Zen Browser - A Firefox-based browser focused on privacy"
+HOMEPAGE="https://github.com/zen-browser/desktop"
+SRC_URI="https://github.com/zen-browser/desktop/releases/download/${MY_PV}/${MY_P}.linux-specific.tar.bz2 -> ${P}.tar.bz2"
+
+S="${WORKDIR}"
+LICENSE="MPL-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+DEPEND="${RDEPEND}"
+
+QA_PREBUILT="opt/zen/*"
+
+src_install() {
+ #create dest dir
+ local destdir="/opt/zen"
+ dodir "${destdir}"
+ #copy files into dest dir
+ cp -a "${S}/zen"/* "${ED}${destdir}" || die
+ #create a symlink to the binary
+ dosym "${destdir}/zen-bin" "/usr/bin/zen-bin" || die
+ #add icons
+ local icon_dir="${ED}${destdir}/browser/chrome/icons/default"
+ if [[ -d "${icon_dir}" ]]; then
+ for size in 16 32 48 64 128; do
+ if [[ -f "${icon_dir}/default${size}.png" ]]; then
+ newicon -s ${size} "${icon_dir}/default${size}.png" zen.png
+ fi
+ done
+ else
+ ewarn "Icon directory not found, skipping icon installation"
+ fi
+ #create desktop file
+ make_desktop_entry zen-bin "Zen" zen "Network;WebBrowser"
+ #handle permissions of destdir files
+ fperms 0755 "${destdir}"/{zen-bin,updater,glxtest,vaapitest}
+ fperms 0750 "${destdir}"/pingsender
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ elog "For optimal performance and compatibility, please ensure"
+ elog "that you have the latest graphics drivers installed."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}