aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtemis Everfree <artemis@artemis.sh>2024-06-15 20:01:49 -0700
committerArtemis Everfree <artemis@artemis.sh>2024-06-15 20:02:01 -0700
commitfaca0e1ee752577ed4e220f6c2ea066563873a2b (patch)
tree490a19824355fa6ebb19d26d6fc19fba3a644323 /www-apps
parentmedia-video/gpu-screen-recorder: update DESCRIPTION (diff)
downloadguru-faca0e1ee752577ed4e220f6c2ea066563873a2b.tar.gz
guru-faca0e1ee752577ed4e220f6c2ea066563873a2b.tar.bz2
guru-faca0e1ee752577ed4e220f6c2ea066563873a2b.zip
www-apps/forgejo: add 7.0.4
Signed-off-by: Artemis Everfree <artemis@artemis.sh>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/forgejo/Manifest1
-rw-r--r--www-apps/forgejo/forgejo-7.0.4.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/www-apps/forgejo/Manifest b/www-apps/forgejo/Manifest
index 7e6b220e0..c24645d2f 100644
--- a/www-apps/forgejo/Manifest
+++ b/www-apps/forgejo/Manifest
@@ -1,2 +1,3 @@
DIST forgejo-1.21.11.1.tar.gz 58893566 BLAKE2B cf3541682de609d63f079922610cc7ae338b7736634a6bc767e310f4ea9fc21fd8c6928b2de4693be6619b49d7e0cbf3b0effd58b681a0cd5e95d4ba21c29141 SHA512 c461d8690a7d2eb3a4955487223391daac58f3236481c0b963a208184ed06fc96372fe8082fbb4a7d9a64b01b2c468d43d1559dd081ec65e65c9f9bc043f9af4
DIST forgejo-7.0.3.tar.gz 54895104 BLAKE2B a5965efaca04745fe8bfd60d18bfc68196b4a5f4b4731ee7aa8e0ee3dfeac0fb9e13193bd65df8db9202f37211b40c1a77ccbfbe018cbf0a3c7f708e77a864d8 SHA512 5d47a229cf89af44a1a36d0b873a3f0eede81b52aefe44c38f7f8a96930dd5038655c488112e4c945b8e71e8aa1e6d092fe51917535463d3228e0dfc0c974474
+DIST forgejo-7.0.4.tar.gz 54935871 BLAKE2B 3333c3d0ddd4021b0ca28765dd5a97fba1d77d538e8297852f2a541cad181a401bd3a1650cce10e746adbd54a3731219f0b8bc2c35612524532b2724d1f6310e SHA512 adba79ea5f49a36f399f8cbfb42a8ff2197f57ec74cbf195d1778a9634b51be6da88683c78355c9f04654c8bc3c77c7198751fc4685ff469d115c50d7e05cdfa
diff --git a/www-apps/forgejo/forgejo-7.0.4.ebuild b/www-apps/forgejo/forgejo-7.0.4.ebuild
new file mode 100644
index 000000000..2b2357dce
--- /dev/null
+++ b/www-apps/forgejo/forgejo-7.0.4.ebuild
@@ -0,0 +1,139 @@
+# Copyright 2016-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd flag-o-matic
+
+DESCRIPTION="A self-hosted lightweight software forge"
+HOMEPAGE="https://forgejo.org/ https://codeberg.org/forgejo/forgejo"
+
+SRC_URI="https://codeberg.org/forgejo/forgejo/releases/download/v${PV}/forgejo-src-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-src-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+IUSE="+acct pam sqlite pie"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ !www-apps/gitea" # until acct-user/git[forgejo]
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/forgejo
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/forgejo#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
+src_compile() {
+ local forgejo_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local forgejo_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/forgejo/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ DRONE_TAG="${PV}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${forgejo_settings[*]}"
+ TAGS="${forgejo_tags[*]}"
+ )
+
+ GOFLAGS=""
+ if use pie ; then
+ GOFLAGS+="-buildmode=pie"
+ fi
+
+ # need to set -j1 or build fails due to a race condition between MAKE jobs.
+ # this does not actually impact build parallelism, because the go compiler
+ # will still build everything in parallel when it's invoked.
+ env "${makeenv[@]}" emake -j1 EXTRA_GOFLAGS="${GOFLAGS}" backend
+}
+
+src_install() {
+ cp gitea forgejo
+ dobin forgejo
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/forgejo.confd-r1" forgejo
+ newinitd "${FILESDIR}/forgejo.initd-r3" forgejo
+ newtmpfiles - forgejo.conf <<-EOF
+ d /run/forgejo 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/forgejo.service-r3 forgejo.service
+
+ insinto /etc/forgejo
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/forgejo/{,app.ini}
+ fperms g+w,o-rwx /etc/forgejo/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/forgejo
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process forgejo.conf
+
+ ewarn "${PN} ${PV} will continue to use /var/lib/gitea as the default home,"
+ ewarn "as acct-user/git[gitea] depends on it, and acct-user[forgejo] does not"
+ ewarn "exist yet."
+ ewarn ""
+ ewarn "7.x includes changes that may require manual intervention when"
+ ewarn "upgrading from 1.21.x, most prominently:"
+ ewarn ""
+ ewarn "> MySQL 8.0 or PostgreSQL 12 are the minimum supported versions. The"
+ ewarn "> database must be migrated before upgrading. The requirements"
+ ewarn "> regarding SQLite did not change."
+ ewarn ">"
+ ewarn "> The Gitea themes were renamed and the [ui].THEMES setting must be changed as follows:"
+ ewarn "> - gitea is replaced by gitea-light"
+ ewarn "> - arc-green is replaced by gitea-dark"
+ ewarn "> - auto is replaced by gitea-auto"
+ ewarn ""
+ ewarn "See https://codeberg.org/forgejo/forgejo/src/branch/forgejo/RELEASE-NOTES.md#7-0-0"
+ ewarn "for more information"
+}