aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-02-07 23:51:27 +0800
committerHuang Rui <vowstar@gmail.com>2022-02-07 23:51:27 +0800
commitdc540a68d43af328ff42494c3f18a42d5fb6aece (patch)
treea49e82e9a1ffe3366227ff2e1dca1de2c774587d /sys-process
parentdev-util/reuse: initial import (diff)
downloadguru-dc540a68d43af328ff42494c3f18a42d5fb6aece.tar.gz
guru-dc540a68d43af328ff42494c3f18a42d5fb6aece.tar.bz2
guru-dc540a68d43af328ff42494c3f18a42d5fb6aece.zip
sys-process/nvtop: EAPI=8 and happy new year 2022
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/nvtop/nvtop-1.2.2.ebuild13
-rw-r--r--sys-process/nvtop/nvtop-9999.ebuild29
2 files changed, 13 insertions, 29 deletions
diff --git a/sys-process/nvtop/nvtop-1.2.2.ebuild b/sys-process/nvtop/nvtop-1.2.2.ebuild
index 7df8c6766..0dc4d9851 100644
--- a/sys-process/nvtop/nvtop-1.2.2.ebuild
+++ b/sys-process/nvtop/nvtop-1.2.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -27,7 +27,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug unicode"
+IUSE="unicode"
RDEPEND="
sys-libs/ncurses:0=
@@ -41,15 +41,10 @@ BDEPEND="
"
src_configure() {
- local CMAKE_CONF="
- !debug? ( -DCMAKE_BUILD_TYPE=Release )
- debug? ( -DCMAKE_BUILD_TYPE=Debug )
- unicode? ( -DCURSES_NEED_WIDE=TRUE )
- "
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DNVML_INCLUDE_DIRS="${S}/include"
- ${CMAKE_CONF}
+ -DCURSES_NEED_WIDE=$(usex unicode)
)
cp "${WORKDIR}/nvidia-settings-${NVIDIA_PV}/src/nvml.h" "${S}/include/nvml.h" || die
diff --git a/sys-process/nvtop/nvtop-9999.ebuild b/sys-process/nvtop/nvtop-9999.ebuild
index 7df8c6766..128d6f80e 100644
--- a/sys-process/nvtop/nvtop-9999.ebuild
+++ b/sys-process/nvtop/nvtop-9999.ebuild
@@ -1,33 +1,25 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-NVIDIA_PV="455.38"
-
DESCRIPTION="NVIDIA GPUs htop like monitoring tool"
HOMEPAGE="https://github.com/Syllo/nvtop"
if [[ "${PV}" == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Syllo/${PN}.git"
inherit git-r3
- SRC_URI="
- https://download.nvidia.com/XFree86/nvidia-settings/nvidia-settings-${NVIDIA_PV}.tar.bz2
- "
else
- SRC_URI="
- https://github.com/Syllo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://download.nvidia.com/XFree86/nvidia-settings/nvidia-settings-${NVIDIA_PV}.tar.bz2
- "
+ SRC_URI="https://github.com/Syllo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug unicode"
+IUSE="unicode"
RDEPEND="
sys-libs/ncurses:0=
@@ -40,19 +32,16 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.0-add-nvml.patch
+)
+
src_configure() {
- local CMAKE_CONF="
- !debug? ( -DCMAKE_BUILD_TYPE=Release )
- debug? ( -DCMAKE_BUILD_TYPE=Debug )
- unicode? ( -DCURSES_NEED_WIDE=TRUE )
- "
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DNVML_INCLUDE_DIRS="${S}/include"
- ${CMAKE_CONF}
+ -DCURSES_NEED_WIDE=$(usex unicode)
)
- cp "${WORKDIR}/nvidia-settings-${NVIDIA_PV}/src/nvml.h" "${S}/include/nvml.h" || die
-
cmake_src_configure
}