aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2023-12-24 15:36:13 -0600
committerZen <z@pyl.onl>2023-12-24 15:36:13 -0600
commitc391385d39832b4a43504292ccb256d0a558a04a (patch)
tree038e28bee1d443e430c6182a39234593fd085260 /sys-kernel
parentdev-python/pycpio: Removed 0.6.0, added 0.7.0 (diff)
downloadguru-c391385d39832b4a43504292ccb256d0a558a04a.tar.gz
guru-c391385d39832b4a43504292ccb256d0a558a04a.tar.bz2
guru-c391385d39832b4a43504292ccb256d0a558a04a.zip
sys-kernel/ugrd: Added 0.15.5
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-0.15.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index cbfc0e298..f6a90a1bc 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -1,2 +1,3 @@
DIST ugrd-0.12.1.tar.gz 39929 BLAKE2B d4d2788c0d23907b87ea6c98607f3d36e25c895618668123089c2cb96dc8895be411c7c5865522b58a53a90c51e77f874ee13324c5602bceb325bb680dccf63b SHA512 3dec60f8535bb63525a0da07583d35c539de27e0d4ab2c79c033ce49a1b745b262a245e58224f5fabb1450af76d750578e47d60eb0961ac842eaed6e5f212c7d
DIST ugrd-0.15.4.tar.gz 42064 BLAKE2B ceaa6ac8f0dc992eb32ad027989701e9f2fccb61d167ccf7c7fd645c4e43b843905b5c80729ebf88a6a0f74535fe399884e1f03a27276e259f3a37f1067422db SHA512 584a2b64a98b3ef5179692d20f4d79fb36462a5882b25eb88af9211fd9f4c9107aefa395673290e67470b8a9724c1a226c13fb1f70e457d00e83254be1837f11
+DIST ugrd-0.15.5.tar.gz 42150 BLAKE2B a5eaa456323a5868cc5ab31f4e6fb45fa016777afe7a38fd0b9538879a8da4b1633c2bc27bad4ab7b269ef595962df133fc5e63a957a1545ed3a1b3445dc30ee SHA512 e03e0775b992bd853ff019c9f4405674120f98b3579421bb6be21a85c3859429313ef6585d4ea00ea2f2bfd5c77ab76fe1062bffeed5ee9109904f320612596e
diff --git a/sys-kernel/ugrd/ugrd-0.15.5.ebuild b/sys-kernel/ugrd/ugrd-0.15.5.ebuild
new file mode 100644
index 000000000..3d5fc2520
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-0.15.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-misc/pax-utils"
+DEPEND=">=dev-python/zenlib-1.2.0
+ >=dev-python/pycpio-0.6.1
+ sys-apps/pciutils"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/config_kmod.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ keepdir /etc/kernel/preinst.d
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/51-ugrd.install
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+}