aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-10 00:34:13 +1300
committerTheo Anderson <telans@posteo.de>2020-12-10 00:34:13 +1300
commit8b5716b329f2cfe26f92f48a4b361ce7289c1979 (patch)
tree54f61e902f24f2f22e38d3a34269a4db7b7d1c1e /sys-block/systemd-swap/systemd-swap-9999.ebuild
parentsys-block/systemd-swap: add as maintainer (diff)
downloadguru-8b5716b329f2cfe26f92f48a4b361ce7289c1979.tar.gz
guru-8b5716b329f2cfe26f92f48a4b361ce7289c1979.tar.bz2
guru-8b5716b329f2cfe26f92f48a4b361ce7289c1979.zip
sys-block/systemd-swap: bump to 4.4.0; add 9999
Closes: https://github.com/gentoo/guru/pull/21 Closes: https://github.com/gentoo/guru/issues/20 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'sys-block/systemd-swap/systemd-swap-9999.ebuild')
-rw-r--r--sys-block/systemd-swap/systemd-swap-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-block/systemd-swap/systemd-swap-9999.ebuild b/sys-block/systemd-swap/systemd-swap-9999.ebuild
new file mode 100644
index 000000000..e8951d7c8
--- /dev/null
+++ b/sys-block/systemd-swap/systemd-swap-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CONFIG_CHECK="~ZRAM ~ZSWAP"
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit linux-info python-any-r1
+
+DESCRIPTION="Script for creating swap space from zram swaps, swap files and swap partitions."
+HOMEPAGE="https://github.com/Nefelim4ag/systemd-swap/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nefelim4ag/${PN}.git"
+else
+ SRC_URI="https://github.com/Nefelim4ag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ $(python_gen_any_dep '
+ dev-python/python-systemd[${PYTHON_USEDEP}]
+ dev-python/sysv_ipc[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ default
+ keepdir /var/lib/systemd-swap
+}