aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Roche <groche97@gmail.com>2024-07-16 18:01:21 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-07-16 18:26:41 +0200
commite00f1d337d408a87c8c7843f511423f2064c19d1 (patch)
tree802f6c349fe194c0ca9a131aa4a2af404df92a7a /sys-apps
parentsys-apps/pnpm-bin: fix distdir and remove the -bin (diff)
downloadguru-e00f1d337d408a87c8c7843f511423f2064c19d1.tar.gz
guru-e00f1d337d408a87c8c7843f511423f2064c19d1.tar.bz2
guru-e00f1d337d408a87c8c7843f511423f2064c19d1.zip
sys-apps/pnpm-bin: add 9.5.0
Signed-off-by: Guillermo Roche <groche97@gmail.com> Closes: https://github.com/gentoo/guru/pull/216 Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pnpm-bin/Manifest1
-rw-r--r--sys-apps/pnpm-bin/pnpm-bin-9.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/pnpm-bin/Manifest b/sys-apps/pnpm-bin/Manifest
index 7ff5879e2..718652e1f 100644
--- a/sys-apps/pnpm-bin/Manifest
+++ b/sys-apps/pnpm-bin/Manifest
@@ -1 +1,2 @@
DIST pnpm-bin-9.0.6 58732810 BLAKE2B 78647187661a3ca4174e33c32b35fc4cd002d60fc84afda6de3bf69c40ebb7cd98f6daea7395b32610493fa1d18ece770148739b8918f9ba5f71dee274eb7444 SHA512 c9a7ecaf51aaf48b68292c7d554864efd0d3e6f1c2a434b09df0b951589a71f14ed3e72f83e0c16e54b3c9cb7c819712b58e291b38297fdf26325316632fd167
+DIST pnpm-bin-9.5.0 59513182 BLAKE2B 3fc1e81784a7bf4f177b504cd9941cc9ffb9b50a4a47ea14b76dfcd200f2322e57fed0f1087e17a85bcf62d6d7e179324c6c2c449a34694b12e72b7815c03e0e SHA512 c32c103cb32111617f2401bbd785f796c44516929b389a82728b3b831a6ed72073f1fc87af918d501f5a93422687bccc322ae30a001f22bc3e2a39d736c9a95e
diff --git a/sys-apps/pnpm-bin/pnpm-bin-9.5.0.ebuild b/sys-apps/pnpm-bin/pnpm-bin-9.5.0.ebuild
new file mode 100644
index 000000000..82c1dea50
--- /dev/null
+++ b/sys-apps/pnpm-bin/pnpm-bin-9.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fast, disk space efficient package manager, alternative to npm and yarn"
+HOMEPAGE="https://pnpm.io"
+SRC_URI="https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-x64 -> ${P}"
+
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+
+QA_PREBUILT="usr/bin/pnpm"
+
+src_install() {
+ newbin "${DISTDIR}/${P}" pnpm
+}