aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-05-06 11:36:58 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-05-06 11:38:19 +0200
commitd566b14ee79d5f601821b622b5435342edd903e9 (patch)
treebe645f49e7dbc9d55c9efbea4d416f8782c4129e /sys-apps
parentapp-crypt/sac-core: add new ebuild (diff)
downloadguru-d566b14ee79d5f601821b622b5435342edd903e9.tar.gz
guru-d566b14ee79d5f601821b622b5435342edd903e9.tar.bz2
guru-d566b14ee79d5f601821b622b5435342edd903e9.zip
sys-apps/dool: add 1.3.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dool/Manifest1
-rw-r--r--sys-apps/dool/dool-1.3.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/dool/Manifest b/sys-apps/dool/Manifest
index c627d0a66..3d056cb41 100644
--- a/sys-apps/dool/Manifest
+++ b/sys-apps/dool/Manifest
@@ -1,2 +1,3 @@
DIST dool-1.0.0-fix-proc-diskstats-parsing.patch 7784 BLAKE2B 0c819c124ad5ec66800f2b8700f1b6d533311e91f978c0db16909ef089997605fe4660de8042533f3a8130db521671fbbe7c9064f1a08f108f39f4472d4720ce SHA512 8611cfc39eb1b3b7353c72234b28d13501f9bff544815ae7d939f37b2c1c18ec8b26f7e72db592d6c55481397b31ba0cd5929e0ad80547d3457dca685e9b589d
DIST dool-1.1.0.tar.gz 141224 BLAKE2B 9c1d733b340b3f1d51798ce85698e7fc526aea349b500431d348d413c1fd93d07d8ccb8241e671a40363275b8c4025ed2f4983b4dfc70f5e166178635935337e SHA512 5204eb1c0a37b225d447830048e5f2372dd3973d50cbd3fbc42972782a4853b809e566550e752c857502f86ceed7ea31620ea27059f9f334d27f28cc61abd968
+DIST dool-1.3.1.tar.gz 150933 BLAKE2B 9aadd4e196cfb7c57fc5fd539f1211b3249b0da955aa2869c43c66b2c2a63816f5cb3e5bcffefada47269f8bd4e3f4b0ace8512f6b0de07e66e0e830ae50c0c2 SHA512 20cabbcbe09152c1ebcaed08bd182586e20d0bae297b61031f1cc52bfce3b9827cc84843e5e5a3dc0d3e790ef2d6da5eb5925d287647f80023925611eb9b04ee
diff --git a/sys-apps/dool/dool-1.3.1.ebuild b/sys-apps/dool/dool-1.3.1.ebuild
new file mode 100644
index 000000000..eff98f06f
--- /dev/null
+++ b/sys-apps/dool/dool-1.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat (clone of dstat)"
+HOMEPAGE="https://github.com/scottchiefbaker/dool"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/scottchiefbaker/dool.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/scottchiefbaker/dool/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+fi
+
+if [[ "${PV}" != "9999" ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+
+ insinto "/usr/share/${PN}"
+ newins "${PN}" "${PN}.py"
+ doins plugins/${PN}_*.py
+
+ doman "docs/${PN}.1"
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}
+
+src_test() {
+ python_foreach_impl emake test
+}