aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-09-13 20:29:02 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-09-13 20:29:02 +0400
commitaa44a50352ff3e244ea2d7cacafa8a4cabe617e5 (patch)
tree806972b24fa911f8f772f0f70b8659ff42a7b900 /sys-apps
parentgames-puzzle/aaaaxy: add 1.4.45, drop 1.4.8 (diff)
downloadguru-aa44a50352ff3e244ea2d7cacafa8a4cabe617e5.tar.gz
guru-aa44a50352ff3e244ea2d7cacafa8a4cabe617e5.tar.bz2
guru-aa44a50352ff3e244ea2d7cacafa8a4cabe617e5.zip
sys-apps/pnpm-bin: new package, add 8.7.5
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pnpm-bin/Manifest1
-rw-r--r--sys-apps/pnpm-bin/metadata.xml37
-rw-r--r--sys-apps/pnpm-bin/pnpm-bin-8.7.5.ebuild21
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/pnpm-bin/Manifest b/sys-apps/pnpm-bin/Manifest
new file mode 100644
index 000000000..76eb5584c
--- /dev/null
+++ b/sys-apps/pnpm-bin/Manifest
@@ -0,0 +1 @@
+DIST pnpm-linux-x64 57620299 BLAKE2B 4f9b27871be08b2d1e656ce2388af8117401a30c5bc9f963d5fb6284989e2513540e08de4b2196b597718904f0804833053e5d004fc413186e52c573c6bb6eae SHA512 5ecec3b3c3f2400ab66da81f943f8e97d6f6d006c1a213d9fc876c31f6108e1bbf900ac4f1f2515f41f65b87461e1be52d2dca06f3cadf17a5482c5ae8ad4713
diff --git a/sys-apps/pnpm-bin/metadata.xml b/sys-apps/pnpm-bin/metadata.xml
new file mode 100644
index 000000000..7d16a80ee
--- /dev/null
+++ b/sys-apps/pnpm-bin/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <longdescription lang="en">
+ * Fast. Up to 2x faster than the alternatives.
+
+ * Efficient. Files inside node_modules are linked from a single content-addressable storage
+
+ * Great for monorepos.
+
+ * Strict. A package can access only dependencies that are specified in its package.json.
+
+ * Deterministic. Has a lockfile called pnpm-lock.yaml.
+
+ * Works as a Node.js version manager.
+
+ * Battle-tested. Used in production by teams of all sizes since 2016.
+
+To quote the Rush team "Microsoft uses pnpm in Rush repos with hundreds of projects and hundreds of PRs per day, and we’ve found it to be very fast and reliable".
+
+pnpm uses a content-addressable filesystem to store all files from all module directories on a disk. When using npm, if you have 100 projects using lodash, you will have 100 copies of lodash on disk. With pnpm, lodash will be stored in a content-addressable storage, so:
+
+* If you depend on different versions of lodash, only the files that differ are added to the store. If lodash has 100 files, and a new version has a change only in one of those files, pnpm update will only add 1 new file to the storage.
+
+* All the files are saved in a single place on the disk. When packages are installed, their files are linked from that single place consuming no additional disk space. Linking is performed using either hard-links or reflinks (copy-on-write).
+
+As a result, you save gigabytes of space on your disk and you have a lot faster installations!
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pnpm/pnpm</remote-id>
+ <bugs-to>https://github.com/pnpm/pnpm/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/pnpm-bin/pnpm-bin-8.7.5.ebuild b/sys-apps/pnpm-bin/pnpm-bin-8.7.5.ebuild
new file mode 100644
index 000000000..67a0d55f6
--- /dev/null
+++ b/sys-apps/pnpm-bin/pnpm-bin-8.7.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fast, disk space efficient package manager, alternative to npm and yarn"
+HOMEPAGE="https://pnpm.io"
+
+SRC_URI="https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-x64"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ newbin "${DISTDIR}/pnpm-linux-x64" ${PN}
+}