aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-11 21:23:02 -0600
committerLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-11 21:43:17 -0600
commit6004504f6cb96bac7f284e166c513999f1db67ee (patch)
treecbae556b0fd080ab0013234ec10416d00c478231 /sys-apps
parentsys-apps/bat-extras: bump to 2023.09.19, remove sys-apps/exa (diff)
downloadguru-6004504f6cb96bac7f284e166c513999f1db67ee.tar.gz
guru-6004504f6cb96bac7f284e166c513999f1db67ee.tar.bz2
guru-6004504f6cb96bac7f284e166c513999f1db67ee.zip
sys-apps/bat-extras: tidy up ebuilds
- fix typo - remove a useless RESTRICT - do not set S, the default is fine - remove IUSE=man, it does not require any other dep and we should ship them per policy: https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0305 - fix dependency for clang, it requires clang-format (installed with USE=extra) Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bat-extras/bat-extras-2023.09.19.ebuild27
-rw-r--r--sys-apps/bat-extras/bat-extras-9999.ebuild27
2 files changed, 18 insertions, 36 deletions
diff --git a/sys-apps/bat-extras/bat-extras-2023.09.19.ebuild b/sys-apps/bat-extras/bat-extras-2023.09.19.ebuild
index f0c500214..3071ef621 100644
--- a/sys-apps/bat-extras/bat-extras-2023.09.19.ebuild
+++ b/sys-apps/bat-extras/bat-extras-2023.09.19.ebuild
@@ -1,23 +1,22 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Bash scripts that integrate bat with various command line tools."
HOMEPAGE="https://github.com/eth-p/bat-extras"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/eth-p/bat-extras.git"
- RESTRICT="mirror fetch"
else
- SRC_URI="https://github.com/eth-p/bat-extras/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- RESTRICT="mirror test"
+ SRC_URI="https://github.com/eth-p/bat-extras/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ # Requires test dir to be a git repo
+ RESTRICT="test"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+man"
DEPEND="
app-shells/bash
@@ -33,13 +32,11 @@ RDEPEND="
dev-vcs/git
sys-apps/eza
sys-apps/ripgrep
- sys-devel/clang
+ sys-devel/clang[extra(+)]
sys-libs/ncurses
virtual/rust[rustfmt(+)]
"
-S="${WORKDIR}/${P}"
-
src_unpack() {
default
if [[ ${PV} == *9999 ]]; then
@@ -56,11 +53,7 @@ src_prepare() {
}
src_compile() {
- if use man; then
- ./build.sh --compress --minify=all --manuals --no-verify || die "build failed"
- else
- ./build.sh --compress --minify=all --no-verify || die "build failed"
- fi
+ ./build.sh --compress --minify=all --manuals --no-verify || die "build failed"
}
src_test() {
@@ -69,14 +62,12 @@ src_test() {
src_install() {
dobin bin/*
- if use man; then
- doman man/*
- fi
+ doman man/*
}
pkg_postinst() {
einfo "To enable additional code formatting for 'prettybat' script, ensure"
einfo "'net-libs/nodejs' is installed in your system, and use 'npm' to install"
einfo "'prettier' (npm i -g prettier). Once 'prettier' is properly installed in"
- einfo "your system, remerge this pacakge."
+ einfo "your system, remerge this package."
}
diff --git a/sys-apps/bat-extras/bat-extras-9999.ebuild b/sys-apps/bat-extras/bat-extras-9999.ebuild
index f0c500214..3071ef621 100644
--- a/sys-apps/bat-extras/bat-extras-9999.ebuild
+++ b/sys-apps/bat-extras/bat-extras-9999.ebuild
@@ -1,23 +1,22 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Bash scripts that integrate bat with various command line tools."
HOMEPAGE="https://github.com/eth-p/bat-extras"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/eth-p/bat-extras.git"
- RESTRICT="mirror fetch"
else
- SRC_URI="https://github.com/eth-p/bat-extras/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- RESTRICT="mirror test"
+ SRC_URI="https://github.com/eth-p/bat-extras/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ # Requires test dir to be a git repo
+ RESTRICT="test"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+man"
DEPEND="
app-shells/bash
@@ -33,13 +32,11 @@ RDEPEND="
dev-vcs/git
sys-apps/eza
sys-apps/ripgrep
- sys-devel/clang
+ sys-devel/clang[extra(+)]
sys-libs/ncurses
virtual/rust[rustfmt(+)]
"
-S="${WORKDIR}/${P}"
-
src_unpack() {
default
if [[ ${PV} == *9999 ]]; then
@@ -56,11 +53,7 @@ src_prepare() {
}
src_compile() {
- if use man; then
- ./build.sh --compress --minify=all --manuals --no-verify || die "build failed"
- else
- ./build.sh --compress --minify=all --no-verify || die "build failed"
- fi
+ ./build.sh --compress --minify=all --manuals --no-verify || die "build failed"
}
src_test() {
@@ -69,14 +62,12 @@ src_test() {
src_install() {
dobin bin/*
- if use man; then
- doman man/*
- fi
+ doman man/*
}
pkg_postinst() {
einfo "To enable additional code formatting for 'prettybat' script, ensure"
einfo "'net-libs/nodejs' is installed in your system, and use 'npm' to install"
einfo "'prettier' (npm i -g prettier). Once 'prettier' is properly installed in"
- einfo "your system, remerge this pacakge."
+ einfo "your system, remerge this package."
}