aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-06-30 13:34:17 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-06-30 13:34:17 +0500
commite805b2ca1531c387338a1aa1d64135a66b36286d (patch)
tree44f0f5e070752d80a622e04e1ed422f8f414ffb1 /phosh-base/phosh-mobile-settings
parentphosh-base/phosh-shell: add 0.40.0 (diff)
downloadguru-e805b2ca1531c387338a1aa1d64135a66b36286d.tar.gz
guru-e805b2ca1531c387338a1aa1d64135a66b36286d.tar.bz2
guru-e805b2ca1531c387338a1aa1d64135a66b36286d.zip
phosh-base/phosh-mobile-settings: add 0.40.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'phosh-base/phosh-mobile-settings')
-rw-r--r--phosh-base/phosh-mobile-settings/Manifest2
-rw-r--r--phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.40.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/phosh-base/phosh-mobile-settings/Manifest b/phosh-base/phosh-mobile-settings/Manifest
index c14b8ee1c..6e9c9b7ec 100644
--- a/phosh-base/phosh-mobile-settings/Manifest
+++ b/phosh-base/phosh-mobile-settings/Manifest
@@ -2,3 +2,5 @@ DIST phosh-mobile-settings-0.36.0.tar.xz 185628 BLAKE2B bed3c8dcd278e44e9beaec29
DIST phosh-mobile-settings-0.36.0.tar.xz.asc 833 BLAKE2B 749625bae2a1bafc77ad5867b65a0a526dd5c9da25eebe9967fea816e30855f98e5bfec61c7cfcad3019fcb32290a262dbc108902bc969787e02d9be11e405f6 SHA512 bbe173ae4f34757963637c9e26bc0dd8d0ee60ea789a894b4732e572eaa25762605d79351f6e0e1b330e51dcc3dc9538b2e70ee98b679f46ea9d95df0e0906c0
DIST phosh-mobile-settings-0.38.0.tar.xz 197692 BLAKE2B df92c780943fcd441b6709e5a9722e02e0b08f27b3355b0621ff3ee626276af53988b9a2bf8047bc3cf14c73691a01b8502c1952795e2388fe29652c16cef3be SHA512 7406ca631d0bb2d51bf405ffb1820496bbd3349927b677b208d623d7a792dbfbd5f6bfd6edc31bb3009490e4ea6c860660df5d983861d929b7b9300d69c8f9e8
DIST phosh-mobile-settings-0.38.0.tar.xz.asc 833 BLAKE2B baab43631489a35bcea287b096dfcbaa0379bb7499c0f50006372c4e1138b545f7253cd9172eae3598840c5f9eb8be5590cc7d7b506e6c148705a04c9ff3fe54 SHA512 9af93755cd5aa0e265b97e999d692dd00ad923c4a676da33d72248cb352c2d818fe299926c8bea0799255156cc29bb2bb6c7bc7efc31202aacf29124f7f9ad1b
+DIST phosh-mobile-settings-0.40.0.tar.xz 206976 BLAKE2B ff21e9672c9b849f1fb423c8305c1ed57164022684c188ef98f27100c5b08d9a3e2d3bb28b7f22046616ce7e277f4061db17d2af127af12bfe08c3ba63c1f51e SHA512 f379df314ef885161842cb03c6f116c1243a9bffc6e56ad1ad8b2e52bf81aad89f687112732a80ae50d20ec9ec123621d5a6ae0945ddab6ba1b8e0de932532ff
+DIST phosh-mobile-settings-0.40.0.tar.xz.asc 833 BLAKE2B 43e8e329a8b0850a9b2859b39b4c440a8b945bee0c5cd7e8e1409b1f2b766bb1ceb02de2344b59c7b2da57139c2ec98a5f39557609c4367eacb2cbd057a7c538 SHA512 3683bb77400f3bd5c2b21cad645bbf5aa7ee578cf0a2ee81b27cd60162ee942ddcf22f2f8dc6f844a8724d9b1ae78935e90de4608738f156b76684c71cd2220a
diff --git a/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.40.0.ebuild b/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.40.0.ebuild
new file mode 100644
index 000000000..a42cf981a
--- /dev/null
+++ b/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.40.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson verify-sig xdg
+
+DESCRIPTION="Mobile Settings App for phosh and related components"
+HOMEPAGE="https://gitlab.gnome.org/guidog/phosh-mobile-settings"
+SRC_URI="https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz
+ verify-sig? ( https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz.asc )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.74:2
+ dev-libs/gmobile
+ >=dev-libs/wayland-1.14
+ >=gui-libs/gtk-4.12.5:4[wayland]
+ >=gui-libs/libadwaita-1.4:1
+ media-libs/gsound
+ >=phosh-base/phosh-shell-0.37.0
+ sys-apps/lm-sensors:=
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/wayland-protocols-1.12
+"
+BDEPEND="
+ dev-libs/glib:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/wayland-scanner
+ sys-devel/gettext
+ verify-sig? ( sec-keys/openpgp-keys-phosh )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/phosh.asc"
+
+QA_DESKTOP_FILE="usr/share/applications/mobi.phosh.MobileSettings.desktop"
+
+src_test() {
+ # No useful tests
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}