aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-17 13:21:42 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-17 13:21:42 +0500
commitf8414f1f7856d8237fd9ce539afabd8bf4b5888a (patch)
treeee49318e6a237d438fae1800d1b64db01000ccca /net-im/mastoposter
parentprofiles: mask dev-python/mkdocs-swagger-ui-tag (diff)
downloadguru-f8414f1f7856d8237fd9ce539afabd8bf4b5888a.tar.gz
guru-f8414f1f7856d8237fd9ce539afabd8bf4b5888a.tar.bz2
guru-f8414f1f7856d8237fd9ce539afabd8bf4b5888a.zip
net-im/mastoposter: add 0.2
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-im/mastoposter')
-rw-r--r--net-im/mastoposter/Manifest1
-rw-r--r--net-im/mastoposter/mastoposter-0.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-im/mastoposter/Manifest b/net-im/mastoposter/Manifest
index e32696a75..4ea23c6bf 100644
--- a/net-im/mastoposter/Manifest
+++ b/net-im/mastoposter/Manifest
@@ -1 +1,2 @@
DIST mastoposter-0.1.tar.gz 36352 BLAKE2B e0710ce461f3d2b21ea7e3aee0e698a9db90523f9ab598868b602f028951251e6ac69cca9f1dfe9b6a66432a8c0f01d32871327b4e064eed2c3b530ae3c4c153 SHA512 77d834503e25f41b4c92ef2538ee8b3a1143d4927e5f96c0ce53d3a3f5c4a004f05c3392d43d8c4af187fc91a044ccec22f9083ccffb31ba5902f254723577ec
+DIST mastoposter-0.2.tar.gz 39036 BLAKE2B 33ba25e6374337050cbf150603d38121ac2701ffbaf969344e296643854ee30709eb51b3044b46ca675cc01ce3bd7f35360e6cc4a0c081f6566ffcca50604d34 SHA512 4ed5327243520c2b7884fb80eaef76f88d3f605fab92fb9b13db0c4c3dbce3fab03338f9582d7cc3ad89a0bd9e6441de23dc4e5d264d8d8cf046b57bba4aed87
diff --git a/net-im/mastoposter/mastoposter-0.2.ebuild b/net-im/mastoposter/mastoposter-0.2.ebuild
new file mode 100644
index 000000000..813ff8f4b
--- /dev/null
+++ b/net-im/mastoposter/mastoposter-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1 pypi systemd
+
+DESCRIPTION="Configurable reposter from Mastodon-compatible Fediverse servers"
+HOMEPAGE="
+ https://pypi.org/project/mastoposter/
+ https://github.com/hatkidchan/mastoposter
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/mastoposter
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/emoji[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ systemd_dounit "${FILESDIR}"/mastoposter.service
+ newinitd "${FILESDIR}"/mastoposter.initd mastoposter
+ newconfd "${FILESDIR}"/mastoposter.confd mastoposter
+
+ insinto /etc/mastoposter
+ insopts --mode=600 --owner=${PN} --group=${PN}
+ doins config.ini
+}