aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2023-06-11 11:11:11 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2023-06-11 11:11:11 +0200
commit6ed82a57c9d4484fd55be3991bd9b31b57ec19e5 (patch)
treea025dbd3b469580eb68512820408f1e562924ef6 /net-dialup
parent*/*: fix UnknownKeywords (diff)
downloadguru-6ed82a57c9d4484fd55be3991bd9b31b57ec19e5.tar.gz
guru-6ed82a57c9d4484fd55be3991bd9b31b57ec19e5.tar.bz2
guru-6ed82a57c9d4484fd55be3991bd9b31b57ec19e5.zip
net-dialup/tio: add 2.6
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-2.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 32a4ce46e..5231b62a8 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.5.tar.xz 3418016 BLAKE2B c89765e568122657ee6da1b7a7cc5cfecd4cb44dd1072b79eab1170eba8ff9de5a4797beef122a69e1df46d733ff96973a3ccc0a84b74111e8d528ec50c95d0d SHA512 874fcaa82a182202da0a58ecd41402bb12f3ccb247a21fa77d08283796fd89cf10d8163399f53edd8d675d6c3b21842016066ed976e1855f3e94bf315a686bd1
+DIST tio-2.6.tar.xz 3429792 BLAKE2B d0aa262e663eea416c696511e2441ce4b59ff3449ff4a743ffa21653442305c7417e941640239f21717c57d5a2a63d08959cfd3d3f7119f9263a8c0bfc75bf1c SHA512 6ff7a0492ea2bffd6f4cfb2745e0a3be2825e2a5c78fb0a35887cbe461472ffe0707c91a7eabd8744f7b52a8ee059b2e9a51e81fa426be2ffab6cf546e5ddd23
diff --git a/net-dialup/tio/tio-2.6.ebuild b/net-dialup/tio/tio-2.6.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}