aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-05-13 22:18:33 +0200
committerJulien Roy <julien@jroy.ca>2024-05-14 16:37:54 -0400
commitca955ebe02e6b563603f3fefd27c8034e2d1ab90 (patch)
tree504a4e24641d91f8e98a710b5def2164d7e3b3db /media-plugins
parentmedia-libs/*: fix variable order (diff)
downloadguru-ca955ebe02e6b563603f3fefd27c8034e2d1ab90.tar.gz
guru-ca955ebe02e6b563603f3fefd27c8034e2d1ab90.tar.bz2
guru-ca955ebe02e6b563603f3fefd27c8034e2d1ab90.zip
media-plugins/*: fix variable order
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net> Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/argotlunar-bin/argotlunar-bin-2.06-r1.ebuild15
-rw-r--r--media-plugins/whysynth/whysynth-20170701_p20180323.ebuild4
2 files changed, 11 insertions, 8 deletions
diff --git a/media-plugins/argotlunar-bin/argotlunar-bin-2.06-r1.ebuild b/media-plugins/argotlunar-bin/argotlunar-bin-2.06-r1.ebuild
index bfd917be3..e6b19cf3e 100644
--- a/media-plugins/argotlunar-bin/argotlunar-bin-2.06-r1.ebuild
+++ b/media-plugins/argotlunar-bin/argotlunar-bin-2.06-r1.ebuild
@@ -5,13 +5,14 @@ EAPI="7"
DESCRIPTION="Argotlunar is a sound granulator. Binary Linux VST"
HOMEPAGE="https://mourednik.github.io/argotlunar/"
-SLOT="0"
-KEYWORDS="~amd64"
-
-QA_PRESTRIPPED="/usr/lib64/vst/${PN}/argotlunar.so"
-SRC_URI="https://www.dropbox.com/s/fwtg6jfkzakj7is/argotlunar-2.06-linux_64.tar.gz -> ${P}.tar.gz"
#It's impossible to obtain package directly from DROPBOX, so I've just uploaded it to my own webserver
+SRC_URI="https://www.dropbox.com/s/fwtg6jfkzakj7is/argotlunar-2.06-linux_64.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/argotlunar-${PV}-linux_64"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
RDEPEND="
app-arch/bzip2
@@ -28,7 +29,9 @@ RDEPEND="
x11-libs/libxcb
"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/argotlunar-${PV}-linux_64"
+
+QA_PRESTRIPPED="/usr/lib64/vst/${PN}/argotlunar.so"
+
src_install(){
into "/usr/$(get_libdir)/vst/${PN}"
dolib.so argotlunar.so
diff --git a/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild b/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild
index 181fdab7a..62a8ae840 100644
--- a/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild
+++ b/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild
@@ -10,6 +10,8 @@ HOMEPAGE="http://smbolton.com/whysynth.html https://github.com/smbolton/whysynth
WHYSYNTH_COMMIT="32e4bc73baa554bb1844b3165e657911f43f3568"
SRC_URI="https://github.com/smbolton/${PN}/archive/${WHYSYNTH_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${WHYSYNTH_COMMIT}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -23,8 +25,6 @@ DEPEND="media-libs/dssi
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${PN}-${WHYSYNTH_COMMIT}"
-
src_prepare() {
./autogen.sh
default