aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2022-06-18 13:00:05 +0600
committerNickolas Raymond Kaczynski <nrk@disroot.org>2022-06-18 13:00:05 +0600
commita7692d7ed96a8c96379fc184fd5dffd4db93b363 (patch)
tree98a06d974b386a19f9f93d4ca83d2227896ba0a2 /media-gfx
parentmpv-plugin/mpv-mpris: add 0.8.1 (diff)
downloadguru-a7692d7ed96a8c96379fc184fd5dffd4db93b363.tar.gz
guru-a7692d7ed96a8c96379fc184fd5dffd4db93b363.tar.bz2
guru-a7692d7ed96a8c96379fc184fd5dffd4db93b363.zip
media-gfx/nsxiv: bump to v30
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/nsxiv/Manifest1
-rw-r--r--media-gfx/nsxiv/nsxiv-30.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/media-gfx/nsxiv/Manifest b/media-gfx/nsxiv/Manifest
index 420b5ad97..28b502a3d 100644
--- a/media-gfx/nsxiv/Manifest
+++ b/media-gfx/nsxiv/Manifest
@@ -1 +1,2 @@
DIST nsxiv-29.tar.gz 64012 BLAKE2B 1b964736619a56cc8fb4092979f12749389fa347e3fda7a40fcfdc1b07a72e101c61d99fb12b10f4ea7ab6459c8068d5c64d754e3e988ec6bfd4504813bcc485 SHA512 d891fc0885f280a622401e105dc1ed9ba39e40f3e760e3e0cd34ae79fdb32187b1d3dc15590bbefd68a18db2aa12795433907e6e744561cc891fc03e7a1f1e94
+DIST nsxiv-30.tar.gz 65642 BLAKE2B 910d1afe2c32e729bf5f848255d5b5d31658b4027f1a44d0e9812e5aac992fe3bb5bc0662aa70aca4f49fba5f3d769c83d5afb098d3ab662883c0b0ccffdb6b0 SHA512 2c852790c5940a8995a5c8a152b6f74198de4640e3827164c8e99855dc06b921c4601ac712a16c801071c656da4a6cd839a6590894f6ab86af35e90b30a8f5af
diff --git a/media-gfx/nsxiv/nsxiv-30.ebuild b/media-gfx/nsxiv/nsxiv-30.ebuild
new file mode 100644
index 000000000..0b27fee7f
--- /dev/null
+++ b/media-gfx/nsxiv/nsxiv-30.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils savedconfig toolchain-funcs linux-info
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://codeberg.org/nsxiv/nsxiv.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nsxiv/nsxiv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Neo (or New or Not) Simple (or Small or Suckless) X Image Viewer"
+HOMEPAGE="https://codeberg.org/nsxiv/nsxiv"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+statusbar exif +inotify +gif webp"
+
+RDEPEND="
+ x11-libs/libX11
+ media-libs/imlib2[X]
+ statusbar? ( x11-libs/libXft )
+ exif? ( media-libs/libexif )
+ gif? ( media-libs/giflib:0= )
+ webp? ( media-libs/libwebp )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use inotify; then
+ CONFIG_CHECK+=" ~INOTIFY_USER"
+ ERROR_INOTIFY_USER="${P} requires inotify in-kernel support."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+}
+
+src_configure() {
+ sed -i -e '/^install: / s|: all|:|' Makefile || die "sed failed"
+ sed -i -e 's|^CFLAGS =|CFLAGS +=|' config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT_DEP_DEFAULT=0 \
+ HAVE_INOTIFY="$(usex inotify 1 0)" \
+ HAVE_LIBFONTS="$(usex statusbar 1 0)" \
+ HAVE_LIBGIF="$(usex gif 1 0)" \
+ HAVE_LIBWEBP="$(usex webp 1 0)" \
+ HAVE_LIBEXIF="$(usex exif 1 0)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ PREFIX="/usr" \
+ EGPREFIX="/usr/share/doc/${P}/examples" \
+ install install-icon
+ dodoc README.md
+ domenu nsxiv.desktop
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ einfo "${PN} uses media-libs/imlib2 for loading images."
+ einfo "To enable/disable support for specific image formats,"
+ einfo "toggle the necessary USE flag for imlib2."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}