aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@outlook.com>2022-11-12 00:24:22 -0600
committerLeonardo Hernández Hernández <leohdz172@outlook.com>2022-12-02 11:30:51 -0600
commit8caddf8fe26a9b60b70345d3632bfe957842f5ab (patch)
tree30399a14d36dee06dfc5449021f4874a70b46b95 /gui-wm
parentwww-apps/code-server-bin: drop 4.6.1, 4.7.0 (diff)
downloadguru-8caddf8fe26a9b60b70345d3632bfe957842f5ab.tar.gz
guru-8caddf8fe26a9b60b70345d3632bfe957842f5ab.tar.bz2
guru-8caddf8fe26a9b60b70345d3632bfe957842f5ab.zip
gui-wm/dwl: update EAPI 7 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@outlook.com>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
index d44eaaac2..b06ca0afe 100644
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit savedconfig git-r3
+inherit flag-o-matic git-r3 savedconfig toolchain-funcs
DESCRIPTION="dwm for Wayland"
HOMEPAGE="https://github.com/djpohly/dwl"
@@ -15,11 +15,11 @@ KEYWORDS=""
IUSE="X"
RDEPEND="
- dev-libs/libinput
+ dev-libs/libinput:=
dev-libs/wayland
x11-libs/libxkbcommon
gui-libs/wlroots:0/15[X(-)?]
- X? ( x11-libs/libxcb )
+ X? ( x11-libs/libxcb:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -35,13 +35,13 @@ src_prepare() {
}
src_configure() {
- sed -i "s/\/local//" config.mk || die
+ sed -i "s:/local::g" config.mk || die
+
+ sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" config.mk || die
if use X; then
- sed -i \
- -e "s/^#XWAYLAND/XWAYLAND/" \
- -e "s/^#XLIBS/XLIBS/" \
- config.mk || die
+ append-cppflags '-DXWAYLAND'
+ append-libs '-lxcb'
fi
}