aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-10-31 13:39:35 +0100
committerFilip Kobierski <fkobi@pm.me>2024-10-31 13:39:35 +0100
commitf8f43ea166cdc764b87b33b519f75e7dcd1d76e3 (patch)
tree955cbb787feee20349adea66bda1bdd9ae001459 /gui-libs
parentapp-text/lizard: add 1.17.13 (diff)
downloadguru-f8f43ea166cdc764b87b33b519f75e7dcd1d76e3.tar.gz
guru-f8f43ea166cdc764b87b33b519f75e7dcd1d76e3.tar.bz2
guru-f8f43ea166cdc764b87b33b519f75e7dcd1d76e3.zip
gui-libs/xdg-desktop-portal-hyprland: drop 1.3.3-r2
I have added the r3 yesterday and now I noticed that portage wants to upgrade hyprlock and downlgrade the desktop portal. That is unacceptable as r2 does not build so I remove it to not allow that. Closes: https://bugs.gentoo.org/942404 Signed-off-by: Filip Kobierski <fkobi@pm.me>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.3-r2.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.3-r2.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.3-r2.ebuild
deleted file mode 100644
index f49c02593..000000000
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.3-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="xdg-desktop-portal backend for hyprland"
-HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/hyprwm/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=media-video/pipewire-1.2.0:=
- dev-cpp/sdbus-c++
- dev-libs/hyprlang:=
- dev-libs/inih
- dev-libs/wayland
- dev-qt/qtbase:6[gui,widgets]
- dev-qt/qtwayland:6
- media-libs/mesa
- sys-apps/util-linux
- x11-libs/libdrm
- || (
- systemd? ( >=sys-apps/systemd-237 )
- elogind? ( >=sys-auth/elogind-237 )
- sys-libs/basu
- )
-"
-
-RDEPEND="
- ${DEPEND}
- sys-apps/xdg-desktop-portal
-"
-
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- dev-libs/hyprland-protocols
- virtual/pkgconfig
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-17:* )
-"
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
- eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
- eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
- die "GCC version is too old to compile XDPH!"
- elif tc-is-clang && ver_test $(clang-version) -lt 17 ; then
- eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
- die "Clang version is too old to compile XDPH!"
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}/xdg-desktop-portal-hyprland-1.3.2_use_sys_sdbus-c++.patch"
- sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
- cmake_src_prepare
-}