aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-22 10:31:36 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-22 10:53:44 -0700
commita13067c1f87f9c23b656235adbfb14ed7a9c2975 (patch)
tree93f02ff3cdcfa32ae4ee988194b41006d1836a84 /gui-libs
parentgui-libs/xdg-desktop-portal-hyprland: drop 1.3.1-r2, 1.3.2-r1 (diff)
downloadguru-a13067c1f87f9c23b656235adbfb14ed7a9c2975.tar.gz
guru-a13067c1f87f9c23b656235adbfb14ed7a9c2975.tar.bz2
guru-a13067c1f87f9c23b656235adbfb14ed7a9c2975.zip
gui-libs/aquamarine: new package, add 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/aquamarine/aquamarine-9999.ebuild51
-rw-r--r--gui-libs/aquamarine/metadata.xml13
2 files changed, 64 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/aquamarine-9999.ebuild b/gui-libs/aquamarine/aquamarine-9999.ebuild
new file mode 100644
index 000000000..80acaec62
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ gui-libs/egl-gbm
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}
diff --git a/gui-libs/aquamarine/metadata.xml b/gui-libs/aquamarine/metadata.xml
new file mode 100644
index 000000000..14f100295
--- /dev/null
+++ b/gui-libs/aquamarine/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/hyprwm/aquamarine/releases</changelog>
+ <bugs-to>https://github.com/hyprwm/aquamarine/issues</bugs-to>
+ <remote-id type="github">hyprwm/aquamarine</remote-id>
+ </upstream>
+</pkgmetadata>