aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ruhier <aruhier@mailbox.org>2024-04-22 00:10:01 +0200
committerAnthony Ruhier <aruhier@mailbox.org>2024-04-22 00:10:01 +0200
commit41b304c25c983bbe251cf791bc3336b7c06a27ec (patch)
treef7cfeb09d297401ebe45af436dede14072a3e34c /gui-libs
parentsys-libs/nss-tls: remove systemd eclass (diff)
downloadguru-41b304c25c983bbe251cf791bc3336b7c06a27ec.tar.gz
guru-41b304c25c983bbe251cf791bc3336b7c06a27ec.tar.bz2
guru-41b304c25c983bbe251cf791bc3336b7c06a27ec.zip
gui-libs/xdg-desktop-portal-hyprland: fix systemd path
Add patch from https://github.com/hyprwm/xdg-desktop-portal-hyprland/commit/24fa87b939539a1d13696718490ff5642ab12509 to fix the path of systemd service from /usr/lib64/systemd to /usr/lib/systemd. Signed-off-by: Anthony Ruhier <aruhier@mailbox.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-1.3.1_fix_systemd_path.patch21
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.1-r1.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-1.3.1_fix_systemd_path.patch b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-1.3.1_fix_systemd_path.patch
new file mode 100644
index 000000000..36d0b2ba8
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-1.3.1_fix_systemd_path.patch
@@ -0,0 +1,21 @@
+From 24fa87b939539a1d13696718490ff5642ab12509 Mon Sep 17 00:00:00 2001
+From: Pavel Solovev <daron439@gmail.com>
+Date: Sun, 7 Jan 2024 22:17:24 +0300
+Subject: [PATCH] Cmake: Do not use CMAKE_INSTALL_LIBDIR for the systemd
+ service
+
+In some distros CMAKE_INSTALL_LIBDIR is lib64, but systemd services are always in lib (not lib64)
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 73f429b..2eb7cfb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -104,4 +104,4 @@ install(TARGETS xdg-desktop-portal-hyprland DESTINATION ${CMAKE_INSTALL_LIBEXECD
+
+ install(FILES hyprland.portal DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/xdg-desktop-portal/portals")
+ install(FILES ${CMAKE_BINARY_DIR}/org.freedesktop.impl.portal.desktop.hyprland.service DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/dbus-1/services")
+-install(FILES ${CMAKE_BINARY_DIR}/contrib/systemd/xdg-desktop-portal-hyprland.service DESTINATION "${CMAKE_INSTALL_LIBDIR}/systemd/user")
++install(FILES ${CMAKE_BINARY_DIR}/contrib/systemd/xdg-desktop-portal-hyprland.service DESTINATION "lib/systemd/user")
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.1-r1.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.1-r1.ebuild
index f09bf0c35..85d3f8f44 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.1-r1.ebuild
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.3.1-r1.ebuild
@@ -89,6 +89,7 @@ src_unpack() {
src_prepare() {
eapply "${FILESDIR}/xdg-desktop-portal-hyprland-1.3.1_use_sys_sdbus-c++.patch"
+ eapply "${FILESDIR}/xdg-desktop-portal-hyprland-1.3.1_fix_systemd_path.patch"
sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
cmake_src_prepare
}