aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-14 15:22:39 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-14 15:22:55 +0100
commit174629c695641891c65572c4de5c35864702a366 (patch)
tree035f523571692875443612958c817643e101be8a /gui-libs
parentapp-emulation/LookingGlass: new package, add 1_beta6, 9999 (diff)
downloadguru-174629c695641891c65572c4de5c35864702a366.tar.gz
guru-174629c695641891c65572c4de5c35864702a366.tar.bz2
guru-174629c695641891c65572c4de5c35864702a366.zip
gui-libs/libdecor: new package, add 0.1.1, 9999
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libdecor/Manifest1
-rw-r--r--gui-libs/libdecor/libdecor-0.1.1.ebuild42
-rw-r--r--gui-libs/libdecor/libdecor-9999.ebuild41
-rw-r--r--gui-libs/libdecor/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/gui-libs/libdecor/Manifest b/gui-libs/libdecor/Manifest
new file mode 100644
index 000000000..c0eb0f853
--- /dev/null
+++ b/gui-libs/libdecor/Manifest
@@ -0,0 +1 @@
+DIST libdecor-0.1.1.tar.bz2 37286 BLAKE2B 32a0ef9711fc0b830f2b2997a05e2ac8ce60ef6f972d8a4c17cebe987b49828c81f3888e42dde0627ce71dbc825ddfd336be3f591ca1f76168c3efd13c2e24ae SHA512 3a5a293a58d40a1d5377912c90ede7670caffbb6b4539ffb00f33667fd84ecaf8a90e05100ddc22c4af34482aac8d2deb67ba25ddbede67e7952b1054e359409
diff --git a/gui-libs/libdecor/libdecor-0.1.1.ebuild b/gui-libs/libdecor/libdecor-0.1.1.ebuild
new file mode 100644
index 000000000..031c89080
--- /dev/null
+++ b/gui-libs/libdecor/libdecor-0.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A client-side decorations library for Wayland clients"
+HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
+SRC_URI="https://gitlab.freedesktop.org/libdecor/libdecor/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+dbus examples"
+
+DEPEND="
+ >=dev-libs/wayland-1.18
+ >=dev-libs/wayland-protocols-1.15
+ x11-libs/pango
+ dbus? ( sys-apps/dbus )
+ examples? (
+ virtual/opengl
+ media-libs/mesa[egl(+)]
+ x11-libs/libxkbcommon
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ # Avoid auto-magic, built-in feature of meson
+ -Dauto_features=disabled
+
+ $(meson_feature dbus)
+ $(meson_use examples demo)
+ -Dinstall_demo=true
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/libdecor/libdecor-9999.ebuild b/gui-libs/libdecor/libdecor-9999.ebuild
new file mode 100644
index 000000000..3dcc9ad2c
--- /dev/null
+++ b/gui-libs/libdecor/libdecor-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson git-r3
+
+DESCRIPTION="A client-side decorations library for Wayland clients"
+HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/libdecor/libdecor.git"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+dbus examples"
+
+DEPEND="
+ >=dev-libs/wayland-1.18
+ >=dev-libs/wayland-protocols-1.15
+ x11-libs/pango
+ dbus? ( sys-apps/dbus )
+ examples? (
+ virtual/opengl
+ media-libs/mesa[egl(+)]
+ x11-libs/libxkbcommon
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ # Avoid auto-magic, built-in feature of meson
+ -Dauto_features=disabled
+
+ $(meson_feature dbus)
+ $(meson_use examples demo)
+ -Dinstall_demo=true
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/libdecor/metadata.xml b/gui-libs/libdecor/metadata.xml
new file mode 100644
index 000000000..fce105305
--- /dev/null
+++ b/gui-libs/libdecor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="dbus">Enable dbus to query current cursor theme </flag>
+ <flag name="examples">Build and install examples</flag>
+ </use>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">libdecor/libdecor</remote-id>
+ </upstream>
+</pkgmetadata> \ No newline at end of file