aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-01 18:59:00 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-01 19:22:47 -0700
commit0fb11def132ca25f54432be9fb55863e18f9d0c5 (patch)
tree3ce0b4b56b457640813c47f360c21e9a4ff2942d /gui-libs
parentgui-apps/hyprlock: Remove pam patch, 9999 (diff)
downloadguru-0fb11def132ca25f54432be9fb55863e18f9d0c5.tar.gz
guru-0fb11def132ca25f54432be9fb55863e18f9d0c5.tar.bz2
guru-0fb11def132ca25f54432be9fb55863e18f9d0c5.zip
gui-libs/xdg-desktop-portal-hyprland: Update sys sdbus-c++ patch
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
index c86c5c2c1..f1de7ec54 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
+++ b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
@@ -1,15 +1,15 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 73f429b..e760098 100644
+index f98bafd..2ef5aaf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -38,17 +38,12 @@ add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value
+@@ -41,17 +41,12 @@ add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value
message(STATUS "Checking deps...")
add_subdirectory(hyprland-share-picker)
+find_package(sdbus-c++ REQUIRED)
find_package(Threads REQUIRED)
find_package(PkgConfig REQUIRED)
- pkg_check_modules(deps REQUIRED IMPORTED_TARGET wayland-client wayland-protocols libpipewire-0.3 libspa-0.2 libdrm gbm hyprlang>=0.2.0)
+ pkg_check_modules(deps REQUIRED IMPORTED_TARGET wayland-client wayland-protocols wayland-scanner libpipewire-0.3 libspa-0.2 libdrm gbm hyprlang>=0.2.0)
# check whether we can find sdbus-c++ through pkg-config
-pkg_check_modules(SDBUS IMPORTED_TARGET sdbus-c++)
@@ -21,7 +21,7 @@ index 73f429b..e760098 100644
# same for hyprland-protocols
pkg_check_modules(HYPRLAND_PROTOS IMPORTED_TARGET hyprland-protocols)
-@@ -60,7 +55,7 @@ endif()
+@@ -63,7 +58,7 @@ endif()
file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
add_executable(xdg-desktop-portal-hyprland ${SRCFILES})
@@ -29,4 +29,4 @@ index 73f429b..e760098 100644
+target_link_libraries(xdg-desktop-portal-hyprland PRIVATE rt sdbus-c++ Threads::Threads PkgConfig::deps)
# protocols
- find_program(WaylandScanner NAMES wayland-scanner)
+ pkg_get_variable(WaylandScanner wayland-scanner wayland_scanner)