aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2024-02-09 14:57:25 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2024-02-09 14:58:35 +0100
commitcd550ba6da8b975f452778974fd06af5431a91e6 (patch)
treefc2ddceb69ea4fbde490eeb9d620182bd466f77f /games-rpg
parentnet-misc/warp: drop 0.5.4 (diff)
downloadguru-cd550ba6da8b975f452778974fd06af5431a91e6.tar.gz
guru-cd550ba6da8b975f452778974fd06af5431a91e6.tar.bz2
guru-cd550ba6da8b975f452778974fd06af5431a91e6.zip
games-rpg/open-adventure: ignore code quality checks
Closes: https://bugs.gentoo.org/924149 Closes: https://bugs.gentoo.org/924113 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/open-adventure/open-adventure-1.18.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-rpg/open-adventure/open-adventure-1.18.ebuild b/games-rpg/open-adventure/open-adventure-1.18.ebuild
index 1975dd167..e4f10f550 100644
--- a/games-rpg/open-adventure/open-adventure-1.18.ebuild
+++ b/games-rpg/open-adventure/open-adventure-1.18.ebuild
@@ -26,10 +26,6 @@ DEPEND="dev-libs/libedit"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]' )
- test? (
- dev-util/cppcheck
- $(python_gen_any_dep 'dev-python/pylint[${PYTHON_USEDEP}]')
- )
doc? ( dev-ruby/asciidoctor )
"
@@ -37,7 +33,6 @@ DOCS=( NEWS.adoc hints.adoc history.adoc README.adoc notes.adoc )
python_check_deps() {
python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
- use test && python_has_version "dev-python/pylint[${PYTHON_USEDEP}]"
}
src_prepare() {
@@ -74,6 +69,9 @@ src_install() {
}
src_test() {
+ emake cheat
+ pushd tests || die
# parallel tests often fail
- emake -j1 check
+ emake -j1
+ popd || die
}