aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-25 18:51:33 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-25 18:51:33 +0400
commitac114ffa3028a6d64188eda0a965a0834d9f5887 (patch)
tree4d6cc5f2273a8ee79ee485128e5f1d8b3344b860 /games-rpg
parentnet-misc/megasync: drop useless USE flags (diff)
downloadguru-ac114ffa3028a6d64188eda0a965a0834d9f5887.tar.gz
guru-ac114ffa3028a6d64188eda0a965a0834d9f5887.tar.bz2
guru-ac114ffa3028a6d64188eda0a965a0834d9f5887.zip
games-rpg/kings-bounty-the-legend-demo: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/kings-bounty-the-legend-demo/Manifest1
-rw-r--r--games-rpg/kings-bounty-the-legend-demo/kings-bounty-the-legend-demo-1.ebuild66
-rw-r--r--games-rpg/kings-bounty-the-legend-demo/metadata.xml8
3 files changed, 75 insertions, 0 deletions
diff --git a/games-rpg/kings-bounty-the-legend-demo/Manifest b/games-rpg/kings-bounty-the-legend-demo/Manifest
new file mode 100644
index 000000000..74fd343c1
--- /dev/null
+++ b/games-rpg/kings-bounty-the-legend-demo/Manifest
@@ -0,0 +1 @@
+DIST kings-bounty-the-legend-demo.tar.xz 725866420 BLAKE2B 574ece862678e5a998a307fef2ade9a2a733ab922f8b81c3927c9d6879437341c49c5342563070e17d1368282623b7efe76677ea5f51c77a11c8300bfd2a9c9f SHA512 38d7f03f3e6f8c2b7567659259ca8a6e9e02e151d18d4e3e93aff68e8e0c2c4aeaaa742632f09f56501c5f60e7ae0cdb371c65558872bf3f37b3fca947c7d7f2
diff --git a/games-rpg/kings-bounty-the-legend-demo/kings-bounty-the-legend-demo-1.ebuild b/games-rpg/kings-bounty-the-legend-demo/kings-bounty-the-legend-demo-1.ebuild
new file mode 100644
index 000000000..3170a42e7
--- /dev/null
+++ b/games-rpg/kings-bounty-the-legend-demo/kings-bounty-the-legend-demo-1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="With battles like in Heroes of Might and Magic (HoMM)"
+HOMEPAGE="https://en.wikipedia.org/wiki/King%27s_Bounty:_The_Legend"
+
+SRC_URI="https://archive.org/download/$PN.tar.xz/$PN.tar.xz"
+
+KEYWORDS="~amd64"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="
+ virtual/wine
+ app-emulation/dxvk
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+
+ mkdir -p "$ED$/opt"
+
+ mkdir "$ED/opt" || die
+ mkdir -p "$ED/usr/bin/" || die
+ cp -r "$PN" "$ED/opt/$PN" || die
+
+ echo "wine /opt/$PN/kb.exe" > "$ED/usr/bin/$PN"
+ fperms +x "/usr/bin/$PN"
+ # I tried this but on run error: "Problems during decoding OGG files" -
+ # because I need to run from the directory of the game,
+ # but cd does not works with exec
+ # make_wrapper "$PN" "$conty wine /opt/$PN/man2.exe /d /opt/$PN"
+
+}
+
+pkg_postinst() {
+ einfo "DXVK increase FPS, so try setup_dxvk.sh install --symlink"
+ einfo "Downloaded from https://www.moddb.com/games/kings-bounty-the-legend/downloads/king-s-bounty-the-legend-updated-demo, installed, archived"
+ einfo ""
+ einfo "More about the game:"
+ einfo "https://www.wikidata.org/wiki/Q2442910"
+ einfo "https://www.twitch.tv/directory/category/kings-bounty-the-legend/videos/all"
+ einfo "https://www.metacritic.com/game/kings-bounty-the-legend"
+ einfo "http://www.lki.ru/games.php?Game=KB2_battlelord"
+ einfo "https://www.pcgamingwiki.com/wiki/King's_Bounty:_The_Legend"
+ einfo "https://www.mobygames.com/game/34196/kings-bounty-the-legend"
+ einfo "https://howlongtobeat.com/game/5020"
+ einfo "https://www.igdb.com/games/king-s-bounty-the-legend"
+ einfo "https://kingsbounty.fandom.com/ru/wiki/King's_Bounty:_Легенда_о_Рыцаре"
+ einfo "https://appdb.winehq.org/appview.php?iAppId=7301"
+ einfo "https://lutris.net/games/kings-bounty-the-legend"
+ einfo ""
+ einfo "Buy the full game at https://www.gog.com/en/game/kings_bounty_the_legend"
+ einfo "https://store.steampowered.com/app/25900/Kings_Bounty_The_Legend"
+ einfo "https://www.greenmangaming.com/games/kings-bounty-the-legend"
+ einfo "https://store.epicgames.com/en-US/p/kings-bounty-the-legend-b69320"
+ einfo "https://www.humblebundle.com/store/kings-bounty-the-legend"
+ einfo ""
+ einfo "The game is installed to /opt/$PN - if you want to run it by another Wine or operating system"
+}
diff --git a/games-rpg/kings-bounty-the-legend-demo/metadata.xml b/games-rpg/kings-bounty-the-legend-demo/metadata.xml
new file mode 100644
index 000000000..812e586b9
--- /dev/null
+++ b/games-rpg/kings-bounty-the-legend-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+</pkgmetadata>