aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-10 13:22:34 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-10 13:22:34 +0400
commitc886d9c89d64c55614076b2224376d86e956ba6d (patch)
tree3d7f79af4b6dd6433542afa27582a260ab68f3e1 /games-emulation
parentdosym: fix absolute path (diff)
downloadguru-c886d9c89d64c55614076b2224376d86e956ba6d.tar.gz
guru-c886d9c89d64c55614076b2224376d86e956ba6d.tar.bz2
guru-c886d9c89d64c55614076b2224376d86e956ba6d.zip
games-emulation/conty: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/conty/Manifest1
-rw-r--r--games-emulation/conty/conty-1.25.1.ebuild36
-rw-r--r--games-emulation/conty/metadata.xml27
3 files changed, 64 insertions, 0 deletions
diff --git a/games-emulation/conty/Manifest b/games-emulation/conty/Manifest
new file mode 100644
index 0000000000..aebbe62200
--- /dev/null
+++ b/games-emulation/conty/Manifest
@@ -0,0 +1 @@
+DIST conty_lite_dwarfs.sh 1406491989 BLAKE2B 5106200f9b9e565044b8c525fb53349235ba78207e00b69dfdd0071439fef1eac55f204c89a9f0949b416c5d07d7e22f589062de57ba34b5a106cd0723b345e6 SHA512 3f74ac40583e362ee7bc05684aa7d2f77f7d2b908f98d179539a714cd9a83cc58948c12352fd948df9b446bb9119c078c6ffae874a9bdbf726167fb1e45ed8ee
diff --git a/games-emulation/conty/conty-1.25.1.ebuild b/games-emulation/conty/conty-1.25.1.ebuild
new file mode 100644
index 0000000000..45b0f880d3
--- /dev/null
+++ b/games-emulation/conty/conty-1.25.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Easy to use unprivileged Linux container packed in a single portable executable"
+HOMEPAGE="https://github.com/Kron4ek/Conty"
+
+inherit linux-info
+
+SRC_URI="https://github.com/Kron4ek/Conty/releases/download/${PV}/${PN}_lite_dwarfs.sh"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="sys-fs/fuse:0"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+CONFIG_CHECK="IA32_EMULATION"
+
+src_install() {
+ dobin "${DISTDIR}/${PN}_lite_dwarfs.sh"
+}
+
+pkg_postinst() {
+ einfo "How to use: $ ./conty.sh [command] [command_arguments]"
+ einfo "For example: ./conty.sh steam"
+ einfo "or"
+ einfo "WINEPREFIX=$HOME/wine-conty ./conty.sh gamescope -f -- wine ./game.exe"
+
+}
diff --git a/games-emulation/conty/metadata.xml b/games-emulation/conty/metadata.xml
new file mode 100644
index 0000000000..c1ffd91500
--- /dev/null
+++ b/games-emulation/conty/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <longdescription>
+This is an easy to use compressed unprivileged Linux container packed into a single executable. It is designed to be as simple and user-friendly as possible. You can use it to run any applications, including games (Vulkan and OpenGL).
+
+Includes, among others, these apps: Wine-GE, Steam, Lutris, PlayOnLinux, GameHub, Minigalaxy, Legendary, Bottles, MultiMC, MangoHud, Gamescope, RetroArch, Sunshine.
+
+Based on Arch Linux.
+
+All applications that you run with Conty read and store their configs in your HOME directory as if you weren't using the container at all.
+
+No performance overhead. Since it's just a container, there is virtually no performance overhead, all applications will run at full speed. Regarding memory usage, Conty uses a bit more memory due to compression and because applications from the container can't share libraries with your system apps.
+
+Supports Xorg, Wayland and XWayland.
+
+Supports Chaotic-AUR and ALHP repositories. AUR is also supported.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Kron4ek/Conty</remote-id>
+ <bugs-to>https://github.com/Kron4ek/Conty/issues</bugs-to>
+ </upstream>
+</pkgmetadata>