aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2023-08-23 00:49:15 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2023-08-23 00:49:15 +0200
commitb92ba1a6a46ad13dfa03f91febadd5e6d8dceaa8 (patch)
tree48fbf88f8429568e192f158188a99114ad8a086c /games-emulation
parentmedia-sound/helvum: add exe to QA_FLAGS_IGNORED (diff)
downloadguru-b92ba1a6a46ad13dfa03f91febadd5e6d8dceaa8.tar.gz
guru-b92ba1a6a46ad13dfa03f91febadd5e6d8dceaa8.tar.bz2
guru-b92ba1a6a46ad13dfa03f91febadd5e6d8dceaa8.zip
games-emulation/citra: upstream fixed boost detection
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/citra/citra-9999.ebuild12
1 files changed, 0 insertions, 12 deletions
diff --git a/games-emulation/citra/citra-9999.ebuild b/games-emulation/citra/citra-9999.ebuild
index a197c09e9..b090f31b8 100644
--- a/games-emulation/citra/citra-9999.ebuild
+++ b/games-emulation/citra/citra-9999.ebuild
@@ -39,7 +39,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-cpp/cpp-httplib
dev-cpp/cpp-jwt
dev-cpp/robin-map
dev-util/spirv-headers
@@ -76,13 +75,6 @@ src_prepare() {
-e '/target_link_libraries/s/inih/${INIH_LIBRARIES}/' src/citra/CMakeLists.txt || die
sed -i -e 's:inih/cpp/::' src/citra/config.cpp || die
- # Fix boost unbundling
- sed -i -e '/(-DBOOST_ERROR_CODE_HEADER_ONLY/,/)/d' CMakeLists.txt || die
- sed -i -e '/^# Boost/,/boost_iostreams PUBLIC/d' externals/CMakeLists.txt || die
- sed -i -e '/^#define BOOST_STACKTRACE_USE_BACKTRACE/d' \
- src/common/logging/backend.cpp || die
- sed -i -e 's/ backtrace//' src/common/CMakeLists.txt || die
-
# Unbundle libfmt
if use system-libfmt; then
sed -i -e '/fmt/d' externals/CMakeLists.txt || die
@@ -119,10 +111,6 @@ src_prepare() {
if use cubeb; then
sed -i -e '$afind_package(cubeb REQUIRED)\n' CMakeLists.txt || die
fi
-
- # Unbundle cpp-httplib
- sed -i -e '/# httplib/,/target_link_libraries(httplib/d' externals/CMakeLists.txt || die
-
# Unbundle cpp-jwt
sed -i -e '/cpp-jwt/d' externals/CMakeLists.txt || die
sed -i -e 's/ cpp-jwt/ ssl crypto/' src/web_service/CMakeLists.txt || die