aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-11-26 10:57:08 +1300
committerTheo Anderson <telans@posteo.de>2020-11-26 10:57:08 +1300
commitb6f8d947e3ffb7c79cfcc9da9d2253536df4636d (patch)
treeeb04ac33540026e1028db2704cf97eafaa7be506 /games-emulation
parentnet-misc/purritobin: drop old version (diff)
downloadguru-b6f8d947e3ffb7c79cfcc9da9d2253536df4636d.tar.gz
guru-b6f8d947e3ffb7c79cfcc9da9d2253536df4636d.tar.bz2
guru-b6f8d947e3ffb7c79cfcc9da9d2253536df4636d.zip
*/*: don't explicitly call xdg-utils functions
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/melonds-0.8.3.ebuild9
-rw-r--r--games-emulation/melonds/melonds-0.9.ebuild8
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild8
3 files changed, 4 insertions, 21 deletions
diff --git a/games-emulation/melonds/melonds-0.8.3.ebuild b/games-emulation/melonds/melonds-0.8.3.ebuild
index ddd580738..ee8013753 100644
--- a/games-emulation/melonds/melonds-0.8.3.ebuild
+++ b/games-emulation/melonds/melonds-0.8.3.ebuild
@@ -36,8 +36,8 @@ RDEPEND="
"
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
+
elog "You need the following files in order to run melonDS:"
elog "- bios7.bin"
elog "- bios9.bin"
@@ -47,8 +47,3 @@ pkg_postinst() {
elog "The romlist.bin file can be found in the /usr/share/melonDS directory"
elog "The rest of those files can be found somewhere in the internet ;-)"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
diff --git a/games-emulation/melonds/melonds-0.9.ebuild b/games-emulation/melonds/melonds-0.9.ebuild
index d7c1be9b7..940706ef1 100644
--- a/games-emulation/melonds/melonds-0.9.ebuild
+++ b/games-emulation/melonds/melonds-0.9.ebuild
@@ -41,8 +41,7 @@ RDEPEND="
"
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
elog "You need the following files in order to run melonDS:"
elog "- bios7.bin"
@@ -52,8 +51,3 @@ pkg_postinst() {
elog "Place them in ~/.config/melonDS"
elog "Those files can be found somewhere on the Internet ;-)"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index d7c1be9b7..940706ef1 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -41,8 +41,7 @@ RDEPEND="
"
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
elog "You need the following files in order to run melonDS:"
elog "- bios7.bin"
@@ -52,8 +51,3 @@ pkg_postinst() {
elog "Place them in ~/.config/melonDS"
elog "Those files can be found somewhere on the Internet ;-)"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}