aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-11 01:59:14 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-11 02:05:52 +0200
commitea10a7cc4945adee6477bf5ff070a3492b0a4fbd (patch)
tree8d904384ceba056ddd9a6adcb6deaa737ec718f0 /games-arcade
parentdev-games/surgescript: Version clean, 0.5.4 (diff)
downloadguru-ea10a7cc4945adee6477bf5ff070a3492b0a4fbd.tar.gz
guru-ea10a7cc4945adee6477bf5ff070a3492b0a4fbd.tar.bz2
guru-ea10a7cc4945adee6477bf5ff070a3492b0a4fbd.zip
games-arcade/opensurge: Version bump, 0.5.1.2
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opensurge/Manifest1
-rw-r--r--games-arcade/opensurge/files/opensurge-0.5.1.2-fix_executable_install_path.patch23
-rw-r--r--games-arcade/opensurge/opensurge-0.5.1.2.ebuild44
-rw-r--r--games-arcade/opensurge/opensurge-9999.ebuild7
4 files changed, 70 insertions, 5 deletions
diff --git a/games-arcade/opensurge/Manifest b/games-arcade/opensurge/Manifest
index 0a58f0cd7..f46405aba 100644
--- a/games-arcade/opensurge/Manifest
+++ b/games-arcade/opensurge/Manifest
@@ -1 +1,2 @@
DIST opensurge-0.5.0-1.tar.gz 26292706 BLAKE2B 6643e2c9763df671e451da75a1c2f775e2469be8c576c7457a762a125cc02f12088674148a72c5e0534111e85b8b13042c0af7fcb8a8979579d5f81ae16216aa SHA512 b8227e864819fbd9beed0831cda2ca72eb8fb2a0c39852d4bfc82a834b462009e92b1aa83d50ce5955e934da2d4c8eb3ce3740cf812f4f3eebc3171c8b22a95a
+DIST opensurge-0.5.1.2.tar.gz 27992793 BLAKE2B a52194969c0e49f560a5eb256b86b6b11538e20fe75449685b4f3a37d51c940eed4a9b7be604b92877a68b0fa68aaf03ce250b7c0b6698a52e4c372e17c3fa63 SHA512 b58e1fb410147a883523ed7ae765a9499994f8f07a195400f4df6bcee386602ab91392a7cf5eb54445819ca68a06695cf23be773d0d8a750657cadff6e79a4fd
diff --git a/games-arcade/opensurge/files/opensurge-0.5.1.2-fix_executable_install_path.patch b/games-arcade/opensurge/files/opensurge-0.5.1.2-fix_executable_install_path.patch
new file mode 100644
index 000000000..95d31574d
--- /dev/null
+++ b/games-arcade/opensurge/files/opensurge-0.5.1.2-fix_executable_install_path.patch
@@ -0,0 +1,23 @@
+From 0ad31f29ace91c1f542f8e25d8456b4473f7f91a Mon Sep 17 00:00:00 2001
+From: Haelwenn Monnier <contact@hacktivis.me>
+Date: Sat, 11 Apr 2020 01:52:33 +0200
+Subject: [PATCH] CMakeLists.txt: Fix executable install path
+
+This installs the unix executable into a `$PREFIX/bin` folder so it is present into the PATH.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a0a18c..6f0d5d0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -661,7 +661,7 @@ SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${CM
+ # Installing on *nix
+ IF(UNIX)
+ INSTALL(CODE "MESSAGE(\"Installing ${GAME_NAME} ${GAME_VERSION}... Make sure that you have the appropriate privileges.\")")
+- INSTALL(TARGETS "${GAME_UNIXNAME}" RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}")
++ INSTALL(TARGETS "${GAME_UNIXNAME}" RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin/")
+ INSTALL(FILES LICENSE README.md CHANGES.md logo.png surge.png surge.rocks DESTINATION "${GAME_DATADIR}")
+ INSTALL(DIRECTORY characters scripts sprites config images levels musics quests samples scripts themes languages fonts licenses DESTINATION "${GAME_DATADIR}" PATTERN ".git" EXCLUDE)
+ INSTALL(FILES src/misc/opensurge.png DESTINATION "${DESKTOP_ICON_PATH}")
diff --git a/games-arcade/opensurge/opensurge-0.5.1.2.ebuild b/games-arcade/opensurge/opensurge-0.5.1.2.ebuild
new file mode 100644
index 000000000..f74724bfa
--- /dev/null
+++ b/games-arcade/opensurge/opensurge-0.5.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alemart/opensurge"
+else
+ SRC_URI="https://github.com/alemart/opensurge/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="fun 2D retro platformer inspired by old-school Sonic games"
+HOMEPAGE="http://opensurge2d.org/"
+LICENSE="GPL-3"
+SLOT="0"
+
+# Allegro:5 libs to USE
+# - image: jpeg,png
+# - primitives: opengl
+# - font+ttf: truetype
+# - acodec+audio: alsa/openal/oss/pulseaudio (present in REQUIRED_USE)
+# - dialog: gtk
+# allegro[vorbis] isn't in CMakeList.txt but is required for the .ogg assets
+DEPEND="
+ >=media-libs/allegro-5.2.5:=
+ media-libs/allegro[jpeg,png,opengl,truetype,gtk,vorbis]
+ >=dev-games/surgescript-0.5.4.3:=
+"
+RDEPEND="${DEPEND}"
+
+# https://github.com/alemart/opensurge/pull/30
+PATCHES=( "${FILESDIR}/${P}-fix_executable_install_path.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_STATIC=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/games-arcade/opensurge/opensurge-9999.ebuild b/games-arcade/opensurge/opensurge-9999.ebuild
index e56fc3070..918d90047 100644
--- a/games-arcade/opensurge/opensurge-9999.ebuild
+++ b/games-arcade/opensurge/opensurge-9999.ebuild
@@ -5,15 +5,12 @@ EAPI=7
inherit cmake
-MY_PV="${PV/_/-}"
-
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/alemart/opensurge"
else
- SRC_URI="https://github.com/alemart/opensurge/archive/v${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ SRC_URI="https://github.com/alemart/opensurge/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${MY_PV}/"
fi
DESCRIPTION="fun 2D retro platformer inspired by old-school Sonic games"
@@ -31,6 +28,6 @@ SLOT="0"
DEPEND="
>=media-libs/allegro-5.2.5:=
media-libs/allegro[jpeg,png,opengl,truetype,gtk,vorbis]
- dev-games/surgescript:=
+ >=dev-games/surgescript-0.5.4.3:=
"
RDEPEND="${DEPEND}"