aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-04 23:23:04 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-04 23:23:04 +0200
commit84e64b141cad19839c7757b79630866a1b8d821b (patch)
tree92dcdb3c259376d3d8c5a7d87fc6066a5d72ba10 /games-arcade
parentdev-games/surgescript: Move from cmake-utils to cmake (diff)
downloadguru-84e64b141cad19839c7757b79630866a1b8d821b.tar.gz
guru-84e64b141cad19839c7757b79630866a1b8d821b.tar.bz2
guru-84e64b141cad19839c7757b79630866a1b8d821b.zip
games-arcade/opensurge: Move from cmake-utils to cmake
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opensurge/opensurge-0.5.0_p1.ebuild8
-rw-r--r--games-arcade/opensurge/opensurge-9999.ebuild4
2 files changed, 6 insertions, 6 deletions
diff --git a/games-arcade/opensurge/opensurge-0.5.0_p1.ebuild b/games-arcade/opensurge/opensurge-0.5.0_p1.ebuild
index 8105565c6..071f9fa76 100644
--- a/games-arcade/opensurge/opensurge-0.5.0_p1.ebuild
+++ b/games-arcade/opensurge/opensurge-0.5.0_p1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -38,7 +38,7 @@ src_prepare() {
sed -i '/INSTALL(TARGETS "${GAME_UNIXNAME}" /s/"${CMAKE_INSTALL_PREFIX}/\0\/bin/' \
CMakeLists.txt || die "Failed fixing executable target"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -47,5 +47,5 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/games-arcade/opensurge/opensurge-9999.ebuild b/games-arcade/opensurge/opensurge-9999.ebuild
index da9d29642..e56fc3070 100644
--- a/games-arcade/opensurge/opensurge-9999.ebuild
+++ b/games-arcade/opensurge/opensurge-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
MY_PV="${PV/_/-}"