aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-07 11:38:57 -0400
committerJulien Roy <julien@jroy.ca>2024-04-07 15:03:15 -0400
commitc838e00fcd3518c03a55c0335af8930d80775daf (patch)
treea8d4dcd62c7016f4666d5ff1d49ac0127cd5c319 /dev-vcs
parentgnome-extra/commit: improve S variable bashism (diff)
downloadguru-c838e00fcd3518c03a55c0335af8930d80775daf.tar.gz
guru-c838e00fcd3518c03a55c0335af8930d80775daf.tar.bz2
guru-c838e00fcd3518c03a55c0335af8930d80775daf.zip
dev-vcs/gitahead: restore dropped package
Dropped accidently by a6b3f15b1a76a2b066f9ff763fab5588bab902c6 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitahead/Manifest4
-rw-r--r--dev-vcs/gitahead/gitahead-2.7.1-r1.ebuild115
-rw-r--r--dev-vcs/gitahead/gitahead-2.7.1.ebuild105
-rw-r--r--dev-vcs/gitahead/metadata.xml11
4 files changed, 235 insertions, 0 deletions
diff --git a/dev-vcs/gitahead/Manifest b/dev-vcs/gitahead/Manifest
new file mode 100644
index 000000000..110740de2
--- /dev/null
+++ b/dev-vcs/gitahead/Manifest
@@ -0,0 +1,4 @@
+DIST gitahead-2.7.1-dep_git_git.tar.gz 7968616 BLAKE2B 7d2ea9e1ca1faa1a8b66a9db6b213c02be966cec74abe085139e3e966adcff9efbd74fb942ad145ddea64bab94a6006b91b512c96aa645cb124bcaf6e5a488eb SHA512 37a77870e0df748b023f5381aa969f1126b142a3470c9df4e01d86cf3418a0b0e4cb16a37ef7b162f285bdd540559a3511488ec8591b2f88e495626df019c03f
+DIST gitahead-2.7.1-dep_hunspell_hunspell.tar.gz 506908 BLAKE2B 810117701b16506ab18f3834cbbe6c75c970632a24b504b0fe914d77407e7379000826897aa03584edb7b87d207e26297709dd70613b6dd49731aa0aed1416b4 SHA512 6e0f4fe0a30e3824cff51ab507e3a836021e8b7542c86ed2950689fe9724b3c017648eb9928d1bb86fddcff113903164c25a1725a4fe7c8b94a833c4bf36279d
+DIST gitahead-2.7.1-dep_libgit2_libgit2.tar.gz 7535416 BLAKE2B 220249adafac30fdd329e65eabc0a7dc0f533b2242d2e75743c781d80d427d8aca5abc7c7d6f6874ebb6b379cee1bf2569a57a769b8a00a4d15ff5a94a218ad0 SHA512 eb0d66840210d1a73b11c7374fa2745afded753d5e8a87483efb5dcf76973469b705279e3ddca15874423123f387384f752aec614951ef4185d334b171d78779
+DIST gitahead-2.7.1.tar.gz 37248607 BLAKE2B 0f1399f84b92717c898708859a2b5c70d88dc52885b12ad915becb9943fc8037ec4ff498888b769603da163408a635bc111f0d5302a8631bb07c9683915e11e1 SHA512 c58ba55e0a0e9d11a0f777bd9d2e51cc7e2c93d0d58d266ae5a1c1271b962d5ac479124234b162983ff56870262e356969b841d59b375ae22e39301e689f3ab9
diff --git a/dev-vcs/gitahead/gitahead-2.7.1-r1.ebuild b/dev-vcs/gitahead/gitahead-2.7.1-r1.ebuild
new file mode 100644
index 000000000..4b2278743
--- /dev/null
+++ b/dev-vcs/gitahead/gitahead-2.7.1-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg cmake wrapper flag-o-matic
+
+DESCRIPTION="Graphical Git client to help understand and manage source code history"
+HOMEPAGE="https://github.com/gitahead/gitahead"
+SRC_URI="
+ https://github.com/gitahead/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/stinb/libgit2/archive/834d652bcb932af447d7f0acd1214a4057cb0771.tar.gz
+ -> ${P}-dep_libgit2_libgit2.tar.gz
+ https://github.com/hunspell/hunspell/archive/8a2fdfe5a6bb1cbafc04b0c8486abcefd17ad903.tar.gz
+ -> ${P}-dep_hunspell_hunspell.tar.gz
+ gnome-keyring? (
+ https://github.com/git/git/archive/0d0ac3826a3bbb9247e39e12623bbcfdd722f24c.tar.gz -> ${P}-dep_git_git.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+IUSE="gnome-keyring"
+
+RDEPEND="
+ app-text/cmark:=
+ dev-libs/libpcre2:=
+ dev-libs/openssl:=
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[concurrent,gui,network,widgets]
+ net-libs/http-parser:=
+ net-libs/libssh2
+ sys-libs/zlib
+ gnome-keyring? (
+ app-crypt/libsecret
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig
+"
+
+QA_FLAGS_IGNORED="usr/share/GitAhead/Plugins/.*"
+QA_PRESTRIPPED="usr/share/GitAhead/Plugins/.*"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+
+ cd "${S}" || die
+ local i list=(
+ dep_libgit2_libgit2
+ dep_hunspell_hunspell
+ )
+ use gnome-keyring && list+=( dep_git_git )
+ for i in "${list[@]}"; do
+ [ ! -f "${DISTDIR}/${P}-${i}.tar.gz" ] && die "The file ${DISTDIR}/${P}-${i}.tar.gz doesn't exist"
+ tar xf "${DISTDIR}/${P}-${i}.tar.gz" --strip-components 1 -C "${i//_//}" || die "Failed to unpack ${P}-${i}.tar.gz"
+ done
+}
+
+src_prepare() {
+ if ! use gnome-keyring; then
+ sed -i 's/add_subdirectory(git)//' ./dep/CMakeLists.txt || die
+ fi
+ sed -i 's/add_subdirectory(openssl)//' ./dep/CMakeLists.txt || die
+ # Respect LDFLAGS
+ sed -i '/CMAKE_EXE_LINKER_FLAGS/d' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ filter-flags -flto* # Segfault in libQt5Core.so.5
+ local mycmakeargs=(
+ # libgit2 flags
+ -DBUILD_TESTS=OFF
+ -DREGEX_BACKEND=pcre2
+ -DUSE_GSSAPI=OFF
+ -DUSE_HTTP_PARSER=system
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cd "${BUILD_DIR}" || die
+
+ eninja package
+ cd ./_CPack_Packages/Linux/STGZ || die
+ mkdir -p "${D}"/usr/share || die
+ bash ./GitAhead-2.7.1.sh --prefix="${D}"/usr/share --include-subdir || die
+ rm -fr "${D}"/usr/share/GitAhead/*.so.* || die
+
+ cd "${D}"/usr/share/GitAhead/Resources/GitAhead.iconset || die
+ local res
+ for res in 16 32 64 128 256 512; do
+ newicon -s "${res}" "icon_${res}x${res}.png" "${PN}.png"
+ done
+
+ make_wrapper "${PN}" "${EPREFIX}/usr/share/GitAhead/GitAhead"
+ make_desktop_entry "/usr/share/GitAhead/GitAhead" "GitAhead" "${PN}" "Development"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "${P} collects some statistical usage data."
+ ewarn "To permanently opt-out of reporting:"
+ ewarn "toggle a button in Help -> About GitAhead -> Privacy"
+ ewarn "or write to ~/.config/gitahead.com/GitAhead.conf those lines:"
+ ewarn "[tracking]"
+ ewarn "enabled=false"
+}
diff --git a/dev-vcs/gitahead/gitahead-2.7.1.ebuild b/dev-vcs/gitahead/gitahead-2.7.1.ebuild
new file mode 100644
index 000000000..5408b298d
--- /dev/null
+++ b/dev-vcs/gitahead/gitahead-2.7.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg cmake wrapper flag-o-matic
+
+DESCRIPTION="Graphical Git client to help understand and manage source code history"
+HOMEPAGE="https://github.com/gitahead/gitahead"
+SRC_URI="
+ https://github.com/gitahead/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/stinb/libgit2/archive/834d652bcb932af447d7f0acd1214a4057cb0771.tar.gz
+ -> ${P}-dep_libgit2_libgit2.tar.gz
+ https://github.com/hunspell/hunspell/archive/8a2fdfe5a6bb1cbafc04b0c8486abcefd17ad903.tar.gz
+ -> ${P}-dep_hunspell_hunspell.tar.gz
+ gnome-keyring? (
+ https://github.com/git/git/archive/0d0ac3826a3bbb9247e39e12623bbcfdd722f24c.tar.gz -> ${P}-dep_git_git.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+IUSE="gnome-keyring"
+
+RDEPEND="
+ app-text/cmark:=
+ dev-libs/openssl:=
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[concurrent,gui,network,widgets]
+ net-libs/libssh2
+ gnome-keyring? (
+ app-crypt/libsecret
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig
+"
+
+QA_FLAGS_IGNORED="usr/share/GitAhead/Plugins/.*"
+QA_PRESTRIPPED="usr/share/GitAhead/Plugins/.*"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+
+ cd "${S}" || die
+ local i list=(
+ dep_libgit2_libgit2
+ dep_hunspell_hunspell
+ )
+ use gnome-keyring && list+=( dep_git_git )
+ for i in "${list[@]}"; do
+ [ ! -f "${DISTDIR}/${P}-${i}.tar.gz" ] && die "The file ${DISTDIR}/${P}-${i}.tar.gz doesn't exist"
+ tar xf "${DISTDIR}/${P}-${i}.tar.gz" --strip-components 1 -C "${i//_//}" || die "Failed to unpack ${P}-${i}.tar.gz"
+ done
+}
+
+src_prepare() {
+ if ! use gnome-keyring; then
+ sed -i 's/add_subdirectory(git)//' ./dep/CMakeLists.txt || die
+ fi
+ sed -i 's/add_subdirectory(openssl)//' ./dep/CMakeLists.txt || die
+ # Respect LDFLAGS
+ sed -i '/CMAKE_EXE_LINKER_FLAGS/d' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ filter-flags -flto* # Segfault in libQt5Core.so.5
+ cmake_src_configure
+}
+
+src_install() {
+ cd "${BUILD_DIR}" || die
+
+ eninja package
+ cd ./_CPack_Packages/Linux/STGZ || die
+ mkdir -p "${D}"/usr/share || die
+ bash ./GitAhead-2.7.1.sh --prefix="${D}"/usr/share --include-subdir || die
+ rm -fr "${D}"/usr/share/GitAhead/*.so.* || die
+
+ cd "${D}"/usr/share/GitAhead/Resources/GitAhead.iconset || die
+ local res
+ for res in 16 32 64 128 256 512; do
+ newicon -s "${res}" "icon_${res}x${res}.png" "${PN}.png"
+ done
+
+ make_wrapper "${PN}" "${EPREFIX}/usr/share/GitAhead/GitAhead"
+ make_desktop_entry "/usr/share/GitAhead/GitAhead" "GitAhead" "${PN}" "Development"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "${P} collects some statistical usage data."
+ ewarn "To permanently opt-out of reporting:"
+ ewarn "toggle a button in Help -> About GitAhead -> Privacy"
+ ewarn "or write to ~/.config/gitahead.com/GitAhead.conf those lines:"
+ ewarn "[tracking]"
+ ewarn "enabled=false"
+}
diff --git a/dev-vcs/gitahead/metadata.xml b/dev-vcs/gitahead/metadata.xml
new file mode 100644
index 000000000..741eace42
--- /dev/null
+++ b/dev-vcs/gitahead/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Benoît Dufour</name>
+ <email>benoit.dufour@mail.com</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gitahead/gitahead</remote-id>
+ </upstream>
+</pkgmetadata>