aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-21 23:56:29 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-23 18:29:41 +0500
commit97b57b4f0c335cab2504bbaf5729019a4dcf84cd (patch)
tree0db06f0c0b9e4efc30c2335e03f6ef9552177d6b /dev-vcs
parentgnome-extra/extension-manager: disable tests (diff)
downloadguru-97b57b4f0c335cab2504bbaf5729019a4dcf84cd.tar.gz
guru-97b57b4f0c335cab2504bbaf5729019a4dcf84cd.tar.bz2
guru-97b57b4f0c335cab2504bbaf5729019a4dcf84cd.zip
dev-vcs/lazygit: switch from deprecated eclass
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.31.4.ebuild36
-rw-r--r--dev-vcs/lazygit/lazygit-0.33.ebuild28
-rw-r--r--dev-vcs/lazygit/lazygit-9999.ebuild37
4 files changed, 13 insertions, 89 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index 98f0ed9fc..70ac4c31c 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1,2 +1 @@
-DIST lazygit-0.31.4.tar.gz 3540918 BLAKE2B 58f07b6f4c6fafe787c6e5dcd9e0bf4fa4133be34f893b5c1429021c8308953e0486442e563e99f19be4c51aa2c100067de6b7bf244fd0f932cd54e9d56a06d7 SHA512 2fb4f312ca4c4803f49cebf2487203e73f8d6b2c58f0ca477ff7857a5fc91f422c5942b7ab7b7e820cd95a205f270ba4d09075a1395dc4cf23531151fdb623e2
DIST lazygit-0.33.tar.gz 3729628 BLAKE2B 1cd9a081e5c0b5bd1248404771ed0d2617ef07ce1257a14ebaa13eab785d70ead908d3151fa6019fbc5149d24f7d69a351e7137c2c3878e38cd0630751197e9d SHA512 e878ef0eb64a8d3fb536767f33787dbf06fd27deb2a292e9658f1c97073b5c30d95f3390215bf973e90acc136bcddb839024fddcd4bf25e6dab5f2762a2db379
diff --git a/dev-vcs/lazygit/lazygit-0.31.4.ebuild b/dev-vcs/lazygit/lazygit-0.31.4.ebuild
deleted file mode 100644
index 233a104b0..000000000
--- a/dev-vcs/lazygit/lazygit-0.31.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jesseduffield/lazygit"
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="Lazygit, a simple terminal UI for git commands"
-HOMEPAGE="https://github.com/jesseduffield/lazygit"
-SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-DEPEND=( sys-libs/glibc )
-RDEPEND=(
- ${DEPEND}
- dev-vcs/git
-)
-
-DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
-
-src_compile() {
- GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
-}
-
-src_install() {
- dobin bin/lazygit
-
- use doc && dodoc -r "src/${EGO_PN}/docs/."
- einstalldocs
-}
diff --git a/dev-vcs/lazygit/lazygit-0.33.ebuild b/dev-vcs/lazygit/lazygit-0.33.ebuild
index 7e93aa089..7ec69e16b 100644
--- a/dev-vcs/lazygit/lazygit-0.33.ebuild
+++ b/dev-vcs/lazygit/lazygit-0.33.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-EGO_PN="github.com/jesseduffield/lazygit"
+inherit go-module
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="Lazygit, a simple terminal UI for git commands"
+DESCRIPTION="Simple terminal UI for git commands"
HOMEPAGE="https://github.com/jesseduffield/lazygit"
SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="doc"
-DEPEND=( sys-libs/glibc )
-RDEPEND=(
- ${DEPEND}
- dev-vcs/git
-)
+# TestCanDeactivatePopupContextsWithoutViews fails
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git"
-DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
+DOCS=( {CODE-OF-CONDUCT,CONTRIBUTING,README}.md docs )
src_compile() {
- GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
+ go build -o bin/lazygit || die
+}
+
+src_test() {
+ ./test.sh || die
}
src_install() {
dobin bin/lazygit
-
- use doc && dodoc -r "src/${EGO_PN}/docs/."
einstalldocs
}
diff --git a/dev-vcs/lazygit/lazygit-9999.ebuild b/dev-vcs/lazygit/lazygit-9999.ebuild
deleted file mode 100644
index 1ffebb9de..000000000
--- a/dev-vcs/lazygit/lazygit-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jesseduffield/lazygit"
-
-inherit git-r3 golang-build golang-vcs
-
-DESCRIPTION="Lazygit, a simple terminal UI for git commands"
-HOMEPAGE="https://github.com/jesseduffield/lazygit"
-EGIT_REPO_URI="https://github.com/jesseduffield/lazygit.git"
-SRC_URI=""
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc"
-
-DEPEND=( sys-libs/glibc )
-RDEPEND=(
- ${DEPEND}
- dev-vcs/git
-)
-
-DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
-
-src_compile() {
- GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
-}
-
-src_install() {
- dobin bin/lazygit
-
- use doc && dodoc -r "src/${EGO_PN}/docs/."
- einstalldocs
-}